Realtek Wifi Drivers for Ubuntu - Dongle version: 8188eus, Ubuntu 21.04

Hello peeps
I just bought a WiFi dongle
The name if the dongle is Realtek 8188eus
I want to use it but don’t understand how to install the drivers.
The Linux folder in the driver CD which is given shows this:

I am not an professional linux user. I will be, but I am not now.
Please help when free

Thank you in advance,
Hrishikesh Kelkar

You should probably read the readme.txt and ReleaseNotes.pdf files first.

However: There is a script in the folder, so what you should probably do, is to create a folder (say wireless) in your home folder /home/your_username and copy the contents of the Linux folder into it.

Then open a terminal and type:

sudo /home/your_username/wireless/ and hit ENTER

That should do the trick. If everything works fine, you can delete the wireless folder afterwards.

Got it
Will try and reply

Thank you

Anyone here to help?

Did you follow the steps @Mina recommended?
If it did not work please add information about the trouble. Error messages, etc…

Where is the “try and reply”?

I tried it but it did not work…

I forgot that when I was uploading that video of the error which the terminal was showing,
I guess there was a power-cut.
Sharing it now:

Sorry, Guys,
I totally forgot that the video was not uploaded.

Thank You :pray: :pray:

Is it uploaded by now? Still doesn’t seem to work.

Read this please:

Now think, what did you wrong?
Hint: ./

Sorry, can’t get you or the article…

Did you read it?
This is your part:

Unix (and Unix-like systems like Linux) shells do not check the current directory for executables before checking the PATH environment variable, and Unix systems tend not to include ./ in the PATH for security reasons. By having to specify


rather than just


the user is saying, “yes, I do want to run this executable in the current directory”

How did you try to start :wink:

So, I have to do ./

Of course, still you need sudo to get the root rights.
The solution of the puzzle for now is:
sudo ./

I guess you learned something today :wink:

Still showing an error.
Sorry for disturbing you.

Is that in that (current) dirctory?
Is it executable?

Oh wait
I did sudo bash ./
Some programs ran I guess but one more error.

It is the current directory.

The script now obviously starts :smiley:
However I have no idea how to overcome make errors :confused: