Redcore Linux Running KDE

Want to run Gentoo without all the package compiling? Well Redcore Linux is
doing a pretty decent job!!! I have it running in VirtualBox, but only after a few
tweaks with VirtualBox settings, thinking about installing Redcore Linux as a
test trial on one of my laptops. I wish it was running Mate instead of KDE but
KDE is all Redcore has, for a DE.
When first installed, one has to run emerge --sync and emerge -a --oneshot portage
from the command line. Then the Sisyphus Redcore package manager can be
opened with the GUI to update and upgrade the system. Sisyphus installed 581
packages in a little over an hour, Gentoo would have taken probably all day and night.
It isn’t Gentoo, but one can still use emerge and install packages that is not in
I thought Redcore was out of Russia, but come to find out it is out of Romania. Will
play with this thing for awhile.

So you should be able to remove kde and install mate.
Theres a challenge

out of Romania

Yes I thought Russia too.
There was a Linux Magazine article on Redcore a while ago. I was sure it said Russian… will check.

Maybe!!! More than likely will break the VM!!! Redcore uses a harden Gentoo profile,
that I have never used. I do know it is using binary packages, probably from the
whatever Redcore server that the developer is using.

The Linux Mag article is here

It does not mention place of origin. I was wrong about that.

It was with great pleasure that I discovered Redcore uses the OpenRC init system ( not systemd)

Makes one think, do I need more USE flags in our Gentoo builds!!!

I encountered that last night. It was a long compile.
No I dont think we need to use more flags. It is just saying that piece of software has a lot of additional features compiled in. Setting some of them as global flags would compile them in for all packages. Setting some of them as local flags would do nothing… it already sets them, unless it sets them negative… then setting a local flag would do something.

I only seem to need to set flags when there are compatability problems with versions of dependencies, or when I really need something (like openmp for R)


Can you explain as to what the different colors mean? Are the green just sub-directorys of make.conf? If so what does the “00-” mean?
I may break Gentoo, but I intend to try and set Gentoo to use bin-packages.
Will need your help!!!

You are in a shell, so the shell determines the colours. I dont think portage tells the shell to use certain colours… or does it?.. when you do an emerge and it lists all the use flags there are colours, and brackets… they mean something so emerge must set those.

I have no idea how you tell a shell to use colours. I think we looked at colors in the prompt once… that is special, the shell really owns the prompt… Output from programs is different, they must signal colors to the shell.

So, a whole lot of guessing and I cant really work it out. We need to go and look it up.
Color is getting to be important.

That is usually used when you want to set the order in which something deals with a set of files. For example in /etc/grub.d

try and set Gentoo to use bin-packages.

You mean in redcore?
That link is about creating your own binary packages, and how to emerge them. I dont think Gentoo repo has many binaries… just stuff like firefox-bin.
Why do you want to do it?

Found this summary of use flag color
USE Flags

  • An unmarked USE flag is unchanged and enabled.
    • A dash preceding a USE flag (yellow, green or blue) shows that it is disabled.
  • % A percent symbol following a USE flag indicates that it is new for this package. Identical to yellow output.
    • An asterisk following a USE flag indicates that its meaning/scope has been updated. Identical to green output.
  • () Parentheses around a USE flag indicate that it is currently masked by your profile. This is usually because the USE flag can not be supported on the given platform (for example, the win32codecs on amd64 with non-binary packages) or is irrelevant (for example, sse is available on all amd64 CPU’s, so there’s no point being able to disable it in a 64-bit environment).

Color Output

Portage returns information to you using both symbols and colors. While the combination makes for a pretty output it also may appear confusing on first glance. Note that the color information is not required, so it repeats the symbolic output.

  • red - The USE flag is enabled and has not changed.
  • yellow - The USE flag has been added since the package was last installed.
  • green - The USE flag has changed since the last time the package was installed, as the asterisk after it indicates.
  • blue - The USE flag is disabled, as the dash before it indicates.
    Back to top View user's profile
1 Like

But why did the developer of Redcore go to such extreme, just to edit the make.conf?
Gentoo can indeed be set to use bin-packages. it is just knowing what to enter in
make.conf to change from sources-packages to bin-packages. This could greatly lead
to a lot less compile time. You can even build bin-packages for your own Gentoo
system, but it requires a lot of disk space, and it does not take the place of pre-built
–ebuild packages.

It seems to be like grub2. There is probably a script that reads his make.conf directory.
He seems to have separated all the lines of make.conf into files and then added sysyphus.make.conf.
No idea why, just trying to be different?

Remember binaries reduce compile time, but increase download time. it is a tradeoff, not a complete win. You can build binary packages for Debian too…I have never tried.

So their is nothing wrong with the way we have installed Gentoo, it is just more generic or
more like the Gentoo way.

I think so. After all, we followed the handbook

1 Like


I finally got net-libs/webkit-gtk-2.40.1 to compile on my W11 Redcore VBVM, after several
hours of compiling, Mate has to have webkit-gtk, for some reason.
Did not uninstall KDE or SDDM, I just chose Mate from the drop-down SDDM menu. Mate
is much beter than KDE, not as flashy, but it works.

Watch out for clashes. I had KDE with Xfce and they clashed… some apps did not work
Had to remove KDE.
Dont remove SDDM… you need that.

Some people would say make 2 users, one for Mate, one for KDE… keeps their dot files separate.

Well, found out last night that the “grub-mkconfig -o /boot/grub/grub.cfg” command is
of no use with Redcore. After he-hawing and scratching my head, I finally ran this
command “grub2-mkcomfig -o /boot/grub/grub.cfg” and it worked.
All in all though my experience, with Redcore, has been very positive, it has made a very lovely and stable Distro.

Did you try update-grub or update-grub2
grub-mkconfig is the old command name

Do you think Redcore would work for people who will not touch Gentoo?

What did the hardened profile do?

Yes, I tried all of that, I remember seeing this before, either in Manjaro or Arch, my
memory just had to have a little nudge, but the “grub2-mkcomfig -o /boot/grub/grub.cfg”
is how to update Redcore grub.

That is why I am using Redcore!!! My last Gentoo build was a mess, I was spending more
time updaing and compiling, than I was in using Gentoo. Redcore has a lot to offer, over
and what Gentoo does, and the Redcore Sisyphus package manager can keep Redcore
updated with just a mouse click or two. One thing, although I have Redcore running in a
W11 VBVM, it really performs a lot better with a hard install, after the install one needs to
run “emerge --sync” and “emerge -a --oneshot portage”, this will sync Redcore with Gentoo
and all one has to do then is use the Sisyphus GUI and update and upgrade Redcore. It is just as easy to run as Debian or Ubuntu.

Gentoo hardened profiles are just more locked-down versions of the stage3 compile.

Found the Redcore wallpaper on Git and downloaded the zip file, cool!!!

Do you mean all updates can be done after that just with Sisyphus. No emerge commands at all? So one could ignore portage ?
Does Sisyphus just update the Redcore stuff, and not the Gentoo packages?


First, Redcore is using a modified Gentoo lts kernel. This is the big difference
between Redcore and Gentoo, is on how the kernel is compiled. In reality, one could
do the same with Gentoo, if one had the time and code. I for one do not have the time
or the code, or the expertise, so I am trying Redcore.

I haven’t really reached a point where I have had any updates with Redcore, but basicly yes
Redcore can be updated without using the emerge command, but porrtage and emerge can
be used.

I used both Sisyphus and emerge when I compiled the webkit-gtk paxkage. I used the
“emerge -ask =net-libs/webkit-gtk-2.40.1” command to compile webkit-gtk and used the
“sisyphus install mate-base/mate --ebuild” and this pulled in both bin and non-bin packages.
So yes, Sisyphus will pull in Gentoo packages.

1 Like

OK, so you have Gentoo with GUI package manager… but you still need to understand Gentoo packages including use flags and dependencies, and masking.
It is supposed to help someone who has never used Gentoo… do you think it achieves that?