Reinstalling xubuntu 18.04


#1

My computer crashed. I put in CD and checked the box install with documents. Can only run xubuntu with CD in. If remove CD and restart, I get iniframfs. With a blinking cursor below it. Thank you

Thank you all for your help. Install with keeping documents just didn’t work. Installed with erase entire disk. Working fine now.


#2

It would help a lot if you would attach screenshots of what you see, of what you do. Also elaborate what exactly you did before the computer crashed and what CD you used and if you actually installed from live medium or not.


#3

Back up your data, format the hard drive, then do a clean install. Nothing is better than wiping the work area clean before resuming.


#4

I had a similar issue quite recently with some of the distros on my machine - three of them fell into an initramfs prompt when I tried to boot into them. I was more or less resigned to going through the reinstallation process, but thought I’d just try a grub update first (I’m lazy, and use Grub Customizer, but it just does the basic grub update operation behind the scenes). Hey presto, this worked, and all three distros now boot up just fine.


#5

The only purpose of an initramfs is to mount the root filesystem. The initramfs is a complete set of directories that you would find on a normal root filesystem. It is bundled into a single cpio archive and compressed with one of several compression algorithms.

At boot time, the boot loader loads the kernel and the initramfs image into memory and starts the kernel. The kernel checks for the presence of the initramfs and, if found, mounts it as / and runs /init. The init program is typically a shell script. Note that the boot process takes longer, possibly significantly longer, if an initramfs is used.

For most distributions, kernel modules are the biggest reason to have an initramfs. In a general distribution, there are many unknowns such as file system types and disk layouts. In a way, this is the opposite of LFS where the system capabilities and layout are known and a custom kernel is normally built. In this situation, an initramfs is rarely needed.

There are only four primary reasons to have an initramfs in the LFS environment: loading the rootfs from a network, loading it from an LVM logical volume, having an encrypted rootfs where a password is required, or for the convenience of specifying the rootfs as a LABEL or UUID. Anything else usually means that the kernel was not configured properly.


#6

Sounds like a corrupted boot sector to me. So:

1-A clean re-install is the only sure way to perfectly restore your system. This entails completely overwriting your existing partition.

2-Though the easiest is to use Timeshift and restore your system to its last stable state.

3-But if I can’t get a machine to boot the first thing I do is re-install “GRUB” with a “Rescatux” live CD. If you don’t have one you can get it here:

https://www.supergrubdisk.org/category/download/

You’ll get an ISO file which simply needs to be burned onto a CD. I understand you can now download a USB version but I haven’t tested it.

Making sure in the BIOS that the machine is set to boot from the right devise, boot it up. If you do use a CDrather than a live USB, relax and put your feet up: it’s going to take a little while. But it’s worth the wait because it has always worked for me.


#7

Thank you, I will work on getting these.