Remind me why Linux, again... am I a glutton for punishment?

I currently spend an inordinate amount of time at my home office desk, and thought I could do some doodling/sketches [e.g. while tele-conferencing], so I decided I was going to break out my Lenovo Thinkpad X201 “convertible” (it’s a pen enabled tablet/laptop, Quad i5, 8 GB RAM, 256 GB SSD) again and keep it on my desk, in front / below my 32" - after trying out the installation of Autodesk Sketchbook x64 (it’s now FREE) via Wine (v 5) on my main desktop (the one hooked up to the 32", running Ubuntu 20.04 - upgraded from 18.04) - it installed without issues and works flawlessly.

Fresh install of xubuntu 18.04.1 (why xubuntu? well stock Ubuntu 18.04 had issues [e.g. even from “live usb” - and XFCE is what Ubuntu Studio used to use [they’ve since switched to KDE I think]), do all the updates, the Wacom Pen and touchscreen all work flawlessly… Install Wine…So I try install Sketchbook and it barfs on a bunch of things it wants (like gecko and some other crap)… I check Wine version on the desktop machine - it’s 5, but here on the tablet its 3. So I remove wine 3, add a PPA for wine 5, install wine 5, then try install Sketchbook again - same deal… so I purge wine and remove that PPA : then :

Upgrade the machine to 20.04 (do-release-upgrade -d), wait an hour+, install wine32 and wine64 and winetricks, install Autodesk Sketchbook using winetricks, it’s fine - installs no issues, runs no issues - it’s then that I discover the GODDAMN Wacom Pen and Touch features NO LONGER F__KING WORK! ARRRGH!

Here’s the symptoms - when the thing boots up - and I’m logged in - touch and pen work (for a bit), then a message “System program problem detected” pops, but unhelpfully, NO diagnostic information, so I don’t have a clue what is having a problem… then right about then, pen and touch stop working! I’ve no idea if that error message dialog is related to the Wacom stuff or not!

The only things being logged that look related to Wacom - look like “information” messages, i.e. not failures :

─➤ dmesg |grep -i wacom
[ 5.058801] input: Wacom Serial Penabled 2FG Touchscreen Pen as /devices/pnp0/00:05/tty/ttyS4/serio3/input/input15
[ 5.059143] input: Wacom Serial Penabled 2FG Touchscreen Finger as /devices/pnp0/00:05/tty/ttyS4/serio3/input/input16

See - those look like “good things”… it’s logging that they’re there, and working…

As an “aside” - I do have an ancient USB Wacom Bamboo (8/9" I think) - bought in 2004 - plugged this into the desktop machine and it worked, even the eraser end, it was plug and play (having said that - it did’t really work well in wine running Sketchbook, i.e. treated the eraser end the same as the nib end).

One really annoying thing about Sketchbook, it was originally developed by Alias (developers of Wavefront and Maya - Industrial scale 3D graphics apps used by the likes of Pixar and ILM) when it was owned by Silicon Graphics - ON - SGI’s UNIX “IRIX” (and then ported to win32 and powermac). If Autodesk could just release it on Linux I’d be happy (they do other software on Linux, like Maya, and Mudbox).

Another thing? If I let zsh cli completion finish “sudo apt install waco…” it suggests “wacomtablet” package (so it’s querying that from somewhere!) - but then I get :

─➤  sudo apt install wacomtablet 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package wacomtablet

I don’t anticipate any of you folks out there will have a solution… just griping…

Put a fair amount of work into this… but I reckon I might wipe it and re-install Ubuntu Studio 20.04… and amongst all this - I remembered one decent “infinite canvas” drawing/sketching app for Linux which was okay (minimal interface like Sketchbook) - but can’t remember the name, and it doesn’t come up on any searches, google found TWO It’sFOSS articles about drawing/painting apps, they listed Gimp, Krita, Pinta, some other Microsoft Paint Clone and Inkscape (that’s not a sketching app - I use it all the time, it’s a vector art tool like Corel and Illustrator, easier to use a mouse in it than a stylus) - but not the app I was looking for…

3 Likes

It often seems that describing my problem helps me think of it in other ways - e.g. it will often happen at work - I hit some bizarre issue, which I don’t have a resolution for, and cannot find anything via google-fu… if I break it down, start writing an email to the affected “user” (most “users” I deal with on a day to day basis are “power users”) describing the issue, the symptoms, attempts to fix, and somewhere along the way, while the email is still being drafted, I’ll have hit on the solution, so my wordy multi-paragraph draft email is redundant, but it helped me fix the issue (and I’ll usually save that email in my drafts folder).

So - here - I did some more digging, and this seems to have been a bug with Linux on Lenovo X201 “tablets” for at LEAST SIX YEARS.

Found this bug report (2014!) :
https://bugs.launchpad.net/ubuntu/+source/xinput/+bug/1275416

Ran this (from post by Ronald J. Right https://launchpad.net/~logiconcepts819) :

sudo inputattach --daemon -w8001 /dev/ttyS4

and just like by F–KING MAGIC it started working again (touch and pen)…

And in the interim - I tried booting a live image of Ubuntu Studio 20.04 (it’s still using XFCE) - and the EXACT same symptom, pen and touch worked for a period (like less than 10 minutes) then stopped… so went back to xubuntu 20.04… and it’s working… and I have now also found the “Infinite Canvas” app I’ve use previously - My Paint :

http://mypaint.org/

And it kicks ARSE and cooks with gas at the same time… supported the Wacom eraser “out of the box”…

I’ve tried Krita in the past, but it’s got so many bells and whistles, it’s a major distraction - but MyPaint’s infinite canvas doodle pad is just what I was looking for :smiley: PEACE :heart_eyes:

3 Likes

90% of the time when I post a question or a problem - even after pondering on it, working it for days, I suddenly get a solution. HAA Helps to vent :smiley:

2 Likes

Also - one of those It’s Foss articles does mention MyPaint (both of them do I think) - but one of them compares it to F–KING Microsoft Paint for Windows (which itself was based on PCX Paintbrush for MS-DOS which MS rebadged and sold with their “Microsoft Mouse”) - when MyPaint is NOTHING like MS Paint… they’re leagues apart…

So - the app I was looking for looked and felt absolutely NOTHING like the “venerable” MS Paint - but the author said it was like it???

To be fair, neither article was written by Abishek, I think both were written by Ankush Das? Anyway - some other article Ankush wrote (https://itsfoss.com/open-source-paint-apps/) didn’t compare MyPaint to MS Paint, and gave it a reasonable rating…

1 Like

It was this It’s FOSS article by Ankush Das :

Yet another open source Linux tool for digital artists. MyPaint focuses on drawing sketches. If you have a touchscreen enabled display, you will be able to make the most out of it. The user interface is quite simple and easy to use.

It is definitely a worthy alternative to MS Paint on Linux with some advanced features.

“worthy alternative” to MS Paint? Reading that - I thought - “well I don’t want ANYTHING that looks like some microsoft software that still heavily stinks of its 1980’s MS-DOS heritage”… Lucky I didn’t end my search at this article - because MyPaint kicks some SERIOUS ARSE :smiley:

And IT IS NOTHING LIKE Microsoft Paint - nothing! NADA!

MS Paint :
image

MyPaint :

1 Like

Daniel, I had the same issues with my Wacom tablet in the beginning. My tablet is even the newer Intuos S Draw. Ubuntu 18.04 recognized the pen w/o any settings available, but not the tablet period.

Then came the update to Ubuntu 20.04 which recognized the tablet too. At least to some extent. Yet, their printer driver now took a toll on my previously nice running Cannon printer and rendered it useless.

That all changed when I took the drastic measure to get rid of it, flattened the hard disk, and installed Linux Mint 19.3 Cinnamon which is based on Ubuntu. Now everything runs fine. My printer works again, and my Wacom tablet settings, as well as my pen settings, are available like I was used to on my former Win10. The only minor issue is that those 4 buttons on top of the tablet are not recognized. However, that’s a minor issue I can live with, as all other settings are available.
So, bottom line is, I will stick with Mint, the more as it’s still Ubuntu in its core.

2 Likes

Welcome to It’s Foss @hamaer.
I feel kind of lucky. I started with Linux Mint just 2 years ago and it does everything I need it to.

Thank you for the feedback. I’ll make sure that I add some clarity to how I describe the alternatives in my future work.

3 Likes

Well I kinda gave up on the Lenovo… it was working, “after a fashion” - but I replaced it with my 12.9" iPad pro - so I can “doodle” with my iPencil (mostly Autodesk Sketchbook, but sometimes ProCreate), while I’m working, sat below the 32" QHD monitor of my Focal Fossa desktop machine.

Incidentally - instead of a pair of phone books (do they even exist these days?) for a monitor stand - I’m using an ancient Sun Sparcstation IPX “lunchbox” case, last time I booted it (before the NVRam battery died and it lost its MAC address and hostid and date/time), it had a 1 GB SCSI HDD, 64 MB of RAM (that was a SHITLOAD in 1991!) as a monitor stand (and don’t forget the kick arse 40 Mhz sparc RISC CPU! - these things used to run whole data centres and hundreds of realtime users)…

In a heartbeat, I’d happily replace the iPad with a pen enabled multi-touch (the Lenovo X201 only has two touch points) tablet and use MyPaint, but purchase of suchlike is way down my priority list…

1 Like

OK - got my XP-PEN 13.3" pro tablet display…

Few disappointments (buyer beware) - I had assumed because it came with a glove for the pen hand, that it was “touch aware” - and thus I could use gestures (e.g. pinch to zoom, two or three fingers to swipe drag viewport) - but no… it’s not a capactive screen, just stylus (proprietary stylus) aware… So - it aint really much different to using the screen on the Thinkpad X201, but it’s still better… And XP-PEN do support Linux and have Linux drivers for download…

So’s anyway - it’s still useful, if a tad expensive… and wouldn’t you know it - the week I ordered this - a local stationary and office supply chain “OfficeWorks” are offering a similar specc’d Wacom Cintiq for only $100 more… too late…

In my hunt for stuff to use it with - I came across “azpainter” - it’s developed by someone in Japan, and a lot of the info out there is in Japanese - but - there’s enough English stuff (including the git repo) to be able to get it running on Ubuntu 20.04 :

Index of files to download :
http://ppa.launchpad.net/alex-p/azpainter/ubuntu/pool/main/a/azpainter/

As I’ve previously stated - I don’t use PPA’s, but that doesn’t stop me going to them to manually download a DEB file to install with “dpkg -i $PACKAGE.deb”…

The app is pretty lo-fi - but I like it - paint in pixels and create pixel art, none of this “simulate oil paint with pixels” rubbish for me thank you… Just gotta configure the buttons on the tablet display to do various azpainter shortcuts…

Coming to an NFT store near you :


For those of you who are too young to have heard of it, Dan’l Baboon was a mandrill (not a baboon) in the 1960’s “anime” (we didn’t call it anime back then, it was just cartoons) series “Kimba The White Lion”, whose “counsellor” was Dan’l Baboon… FYI - Disney ripped off the whole thing with “The Lion King” (young lion call Simba?) - and the “counsellor / wiseman” was a mandrill called Rafiki…

This is how you instantly recognize a good product. If it’s from Japan, it must be good. :jp:

Not unusual for them. However, in their defence, a lot of companies do that. Especially movie makers.

1 Like

Here is what I use natively in Linux. HUION Inspiroy H950P Graphics Tablet, Battery-free Pen with ±60° Tilt Function, Graphic Drawing Tablet for Mac Windows Android, Ideal Drawing Pad for Work from Home & Remote Learning: Amazon.co.uk: Computers & Accessories

Now that Ubuntu 18.04 and 20.04 are at Kernel 5, this art tablet works flawlessly in Linux. For years hunting around for the right one that works for Linux, then suddenly we go to kernel 5 and every driver you can think of is in there. This plugs into your computer via USB you get a non wired pen, with pen nibs, comes in a beautiful box, this list is going to go on, bare with me, it works out of the box with GIMP, plus all the other Linux art programs. No need to worry about the pen lead getting in the way, as the tablet has sensors, when the pen goes over it, it detects straight away and instantly on screen. The pen acts like a mouse, but so comfortable to use. I got a Stand for it too. If you’re an architect I highly recommend this tablet, it does it all.

I’ve already that exact functionality with my 8" Wacom Intuos I bought in 2004 (my 2nd Wacom, I previously had a serial port 6") - and it still works… Stylus is wireless and battery free… It’s plug and play, I’ve never had to hunt drivers for it.

But this thing from XP-PEN is a display tablet… i.e. like a Wacom Cintiq… wireless / battery less pen… 13.3" display. I occasionally break out my Wacom tablet, but hardly ever, it’s fine for editing stuff, but not for creating something from scratch, the displacement between what’s on my screen and what my hand is doing is too incongruous to me. I read somewhere that drawing with a mouse is like drawing with a bar of soap, well drawing with a non-display tablet is like drawing with a big fat crayon and wearing blinkers :smiley:

Huion also have display tablets - but their prices are up there with Wacom - me? If I was spending big and not “on the cheap” - I’d always lump for Wacom over any other brand, they’re the “industry standard” - most hardware vendors with stylus support, like Samsung, defer to Wacom and license their tech (Microsoft did too with the first few generations of Surface, as did IBM / Lenovo with the first iteration of “hybrid” tablets with their X series Thinkpads [I’ve got two of them])…

** That Wacom that I mentioned only being $100 more than the XP-PEN? Well - it turns out that’s not touch either - i.e. no pinch to zoom… and the price has gone back up to well over $200 more than the one I bought… I don’t feel so bad now!

In fact I haven’t seen anything with a cord/wired stylus since a cheap knock off clone of a Summagraphics digitizing tablet I bought in the 1990’s (it worked till I fried it by plugging it into a PS/2 port while the PC was on - it also fried the motherboard - but a mate soldered a replacement capactor / resistor on the mobo). Oh and light pens on mainframe terminals :smiley: … I never really saw the point in light pens, and when I supported mainframe terminal users in a hospital, only ever saw one user using the light pen…

Lack of touch is a bit of a bummer, and pinch to zoom in, and pinch out to expand - they’re features I’ll miss that I’m used to on Galaxy Note smartphones and tablets, and my iPad Pro 12.9" with iPencil, Autodesk Sketchbook*** on both, and ProCreate on the iPad… The XP-PEN has a “wheel” doohicky at the side that you can configure - some apps know it’s a zoom in / out (Krita) but others don’t (azpainter) - both both those apps know I want zoom when I scroll the mouse wheel - and - if I stupidly give focus to Chrome and scroll that wheel on the tablet - it zooms in and out of Chrome!

** and that Wacom display tablet I spotted is not even a “Cintiq” - it’s a “Wacom Creative”…

*** Sketchbook for Windows installs and runs perfectly in Wine - but - the Windows version isn’t as good as the iOS and Android versions. I’ve been using the app on and off for nearly 20 years… It was originally developed by Silicon Graphics Inc, for both Irix (a UNIX) and Windows NT… I used it on NT 4 and Win2000 with my serial port Wacom tablet.