Replacement for pkexec as sudo front-end?

As the title says, has anyone come up with a replacement that works?

What’s the point of using pkexec instead of plain sudo?

Peer Guardian needs it allow authenticated users… It’s an old piece of software, used to be able to set it up all the way to 18.04. Just installed 20.4, and without pkexec for a sudo front-end, it’s functionality is reduced.

Do you want to have sudo functionalities in a non-interactive environment?

Yes, Akito, that’s the reason. Perhaps I can get it restored to full function. If I could find equal or better piece of software, I’d give them a try, but they appear to be as rare as turtle hair…

I have read it’s supposed to be used for GUI applications, so perhaps we aren’t on the same page about that. However, if you are looking for a sudo alternative that is specifically designed to be used in non-interactive environments, you can use my creation:

Still, if you need a sudo for GUI applications, you need to find an alternative. I’m sure, if this is a real problem, you are not the only one who has encountered it.

2 Likes

I bookmarked your effort, to peruse, and perhaps use, at a later date, thank you.
It actually is a gui app, but when you change the lists, config, it pops up a dialog saying you need to authenticate due to changing system values (firewall). Which is leading me to take a look at the cmd line app. I’ve gotten so used to using the gui for all the tasks, I haven’t studied the core of the cmd portion of the ensemble. :grin:

The way I get around pkexec is install nemo file manager. For years I used Peppermint with Nemo file manager and now on Linux Mint XFCE I installed Nemo. I have even in Virtualbox installed the new Zorin OS 16 and installed Nemo in there. Nemo has pkexec to authorise opening system as superuser. If this isn’t what you want, then I apologise.

Here is the instructions to install and set Nemo as default.

sudo apt install nemo

To run the desktop background settings

gsettings set org.gnome.desktop.background show-desktop-icons false

To have it run as default file manager

xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search

To have Nemo setup to open with Terminal

gsettings set org.cinnamon.desktop.default-applications.terminal exec

1 Like

What I did forget was to say or type after exec put in space then the name of the Terminal you’re using. You can find the name in the about section of your Terminal in help inside Terminal.

This morning, I opened the terminal, logged in as root with sudo -i, cd’d to /bin, entered “pglgui,” which starts Peer Guardian. I left the terminal running while I used the “configure” menu of PG: worked! Now I just closed the terminal, and it still works.

I normally start PGLinux at system boot, so I’ll have to research how to run it with root unattended.

All help appreciated!

It appears I spoke too soon…A few hours later, I shut the terminal down, and it closed the app. So at this point I have to keep the root process in the terminal open.

I’ll keep researching the issue, and maybe some developers will come up with something :smiley:

And, “sudo pglgui” works as well…Likely I will be able to come up with a script as well. I saw that putting a single command inside the sudoers file may do it. Using visudo, of course, with a recommendation to keep another terminal open while doing so.