Resize ubuntu windows dual boot

I have a system running dual boot Ubuntu 20.04 and Windows 10.

I would like to add space to Ubuntu by removing space from Windows. By 150gb.

Is this doable?

If it is please explain.


Yes. :wink:
As a rule of thumb, I tend to use Windows tools to mess around with Windows file systems/partitions whenever possible.
So I would try to shrink Windows partitions from Windows. Either use builtin tools for that (disk manager), or some 3rd party app. Partition Magic had a free edition when I last time needed it, that will do the job easily.
So, first get that extra 150GB free from your Windows installation.
Of course your win partition has to have at least that amount of space free (better more).
Once you have unallocated space on your drive, you can boot a live system, and use Gparted to move/resize/rearrange your Linux partitions.
That’s it… :slight_smile:
Any time, anything can go wrong, if you play with partitions, when something unexpected happens, you may loose partitions, or data on that. So the best practice is to have backup of EVERYTHING.
Do you need more detailed help, or is that enough?

1 Like

Thanks. I don’t enjoy the risk so I think I’ll stick with what I have for now.

I ran your message by a sysadmin I know who said unless I really need the space to avoid resizing Ubuntu and Windows and to watch grub.

I have two external drives. Would it be better to move /home to HDDX/home to gain space? Or , is that also tricky ?


I did partition moving/resizing countless times, and did not have a problem. It’s the usual warning to have backups before starting to do such thing.
If you don’t have backup, the risk is already there: any hdd/ssd can die at any time. I learned this the unhappy way many-many years ago.
If you have a desktop computer, it’s easy to install another drive, and move /home to it.
However, I would not move /home to an external drive - it’s possible though, but you need to make sure that drive is attached upon boot.
If it is about a laptop, installing another drive is probably hard or impossible, so I would go for the resize/move job, if I’d really need that space.
As for moving /home to somewhere:
I’d attach the drive, partition, format to ext4, etc.
Then mount temporarily into /mnt/home.
Then rsync -va /home /mnt/home
After rsync ran, edit /etc/fstab, so that the new drive will be mounted on /home.
Rename current home to something, and create a new (empty) /home. Also, chmod 755 it, if it was not created so.
Double check that fstab is correct, to avoid the necessity of a recovery mode :smiley:
If everything works as expected (it should), delete the old (renamed instance) of /home.

So, I had the chance, and created a test VM (no thorough setup, just quick and dirty done thing…), which I made EFI dualboot Win10 / Debian.
I have set it up with a 128GiB virtual drive, and originally made assigned approx. the half of the space to both systems. Then I “changed my mind” :smiley:
I wanted to add additional space to my Linux install. Vide starts here :wink:

The principle is the same, as it would be for you.

  1. Boot windows
  2. Shrink volume (there’s a recovery partition, which I completely forgot - I moved it with Gparted)
  3. Boot a live Linux (for me it’s Debian, but for you it will be Ubuntu. Doesn’t really matter, the idea is the same)
  4. Use GParted on the live medium to adjust Linux partition(s) - well, the rcovery too in this case :wink:
  5. Done :smiley:


Thanks for the input. I will read it carefully and consider my options.

After thought you are correct my additional drives are external.

If I go with the shrink Windows and grow Ubuntu I will let you know. Will gparted handle the grub entries?


1 Like

You’re welcome :wink:

No, and there’s no reason to touch GRUB in this case.

Just attempted this myself (on a single boot system)… I need a tiny Windows system to program some mini keyboards I want to use… Neither of the work allocated Windows 10 systems I have access to will let me run the binary!

DAMN I miss the good old days when IT Engineers were GOD on their computers! Now we have to log tickets to get an hour’s worth of Privileged Escalation and we have to get it approved by a boss and we have to justify why we think we need privilege escalation - I say f–k that!

Anyway, attempted to shrink the 1 TB NVMe SSD on my ThinkPad E495 running Ubuntu 22.10 - it’s encrypted! Doh! First attempt panicked my system.

Then I remembered - I bought this device with 256 NVMe SSD (and formatted it to run Fedora - i.e. didn’t even attempt to boot the Win10* ) - was gonna swap the SSDs around - but remembered I have the 256 GB one in a USB3 enclosure - so - I’m going to attempt :

  1. ventoy boot from Win10 ISO on a 16 GB USB drive
  2. install Windows 10 onto 256 GB USB 3 SSD
  3. adhoc boot Windows 10 (by interrupting UEFI) when I want it… not going to add it to the UEFI…

Note : I can easily get my Windows 10 license details :

sudo strings /sys/firmware/acpi/tables/MSDM

Now - I can just imagine spending the rest of today (it’s now Sunday morning) just getting drivers and installing them - man I hate Windows… Ubuntu and MacOS have spoiled me as they just go out there and get my drivers for me! Fingers crossed this Windows 10 installer can do most of the heavy lifting…

But I don’t expect so… Last time I remember doing something similar was on MICROSOFT HARDWARE - a Surface Pro 3, and yeah, I spent about 4-6 hours having to located and download drivers! WTF? Yeah - Windows 10 DID NOT have Surface Pro 3 drivers!

* doh! Why didn’t I just leave Windows 10 on there??? I didn’t even need a 256 USB drive! Got several already!

CRUMBS! “Windows cannot be installed to this disk. Setup does not support configuration of or installation to disks connected through a USB or IEEE 1394 port” … Fair enough on the firewire bullshit - but USB? WTF Microsoft?

So it looks like I might need to tweak my UEFI to support this “feature” that’s pretty standard in Linux world…

This is all getting too hard… I reckon Imma gonna have to trash this Ubuntu 22.10 - install Windows 10 to a small partition… sort that… then install Ubuntu again… maybe before that I might backup Ubuntu 22.10 “stuff” - mostly Steam games - the rest is in my selfhosted cloud solution (Resilio Sync)…

Naaah bugger that - too much work…

Got a Windows 10 VM in virtualbox - gonna try and setup USB passthrough and program the mini-keyboards that way… I got two minikeyboards “earlier” and got the software (different) working under MacOS and was able to program one button to be Cmd+C and the other one Cmd+V… trouble is - even with Synergy KVM - those are send as Super+C and Super+V - but in Linux and Windows Copy is Ctrl+C and Paste is Ctrl+V…

So - I got a pair of ones with 4 buttons… I want to program them 1=CMD, 2=C, 3=V, 4=Ctrl…

Some might call this a StackOverflow solution - and - IT IS! i.e. universal copy and paste… I not that I especially need this - at home I’m running MacOS and Linux only… at work usually ONLY MacOS…

But - I do a fair amount of work in RDP on Windows servers or Windows VDI (virtual desktops) - and - I’d like a general Copy+Paste keyboard… I also mostly use a Mac Keyboard - and I HATE not having a Right Ctrl key… So I need a right CTRL - I’m left handed you see, and hitting Ctrl on a Mac Keyboard, usually means taking my left hand OFF the mouse - which is a PITA - okay - so it’s like maybe 2 seconds, but 500 times a day? That’s SIXTEEN MINUTES of lost productivity!

So much for that … still not the right software… piece of crap… Saved myself the drama of repartitioning to install Windows 10 so I can run some shitty Chinese software (the download website is in Chinese) which amazing has an “English” version, I’ve got passthrough USB - and the device gets passed through to Win10 VM, but, the stinking pezzo di merda software doesn’t recognize the device, so now I gotta find some other source for YET ANOTHER programming (eeprom writing or whatever TF) solution - probably yet another web page in Chinese…

Talk about DODGY-Brothers (an Australian thing from a comedy show):
Got it working by download yet more Chinese software shared on someone’s google drive…

But at least now I can use them :

So - now I gotta figure out how to turn those STUPID F–KING LED lights off :rage:

OK - that program has another “tab” to set LED behaviour… sorted that now too… Needed Windows… stinking crap! the LAME as F–K Amazon entry for the item says "compatible with Windows, Mac, Linux. My arse is it is… IT’s compatible if you’re happy with the factory setting of EVERY key is “c”!

1 Like