Restore email to Thunderbird

Greetings!
I’m having trouble restoring my Thunderbird email data to a newly configured hard drive. I’m running Mint 19.2 and had to re-partition my drive. I’ve tried using “thunderbird -profilemanager” to switch back to my previous profile. I get a message that this is a newer version of Thunderbird and my data isn’t compatible.
Any ideas?
THANKS!!!
Jim

That’s your issue. You should look up how to convert to the new data format.

I thought I was on a relatively new version of Thunderbird - 68 something.

Thinking of trying to find an older version of Thunderbird just to get my data back…
I’m certainly open to suggestions.

Hey Jim,
First, I’m assuming you want to migrate your old Thunderbird settings to a new Linux partition. Including your address book, message archives and SMPT and IMAP servers.

If you want to migrate setting from another Linux machine there is a very simple trick. Inside Home is a hidden file .thunderbird. (To see it hit Ctrl h). When you open it you’ll usually see 4 files. You want to copy “profiles.ini” and second file that appears to be a random string ending in “.default”.

Open Home/.thunderbird on your new partition. Remove the profile.ini and .default files and swap in the copies.

As long as the old partition is up to date (60.9 I think is the latest) it shouldn’t matter. Your old .default folder has all the info–including update history–to reproduce your old client on a new machine.

Now I just tested this method on my own ancient laptop which had never had thunderbird on it until under 5
minutes ago. The only real difference in our situations is that both my machine are running Mint 18.3.

1 Like

Thanks Dave!
I believe that’s how I started out - replacing folders under .thunderbird with my saved versions. Since then, I’ve tried updating profiles.ini and using the “thunderbird - profilemanager” program in the terminal.
Still not getting anywhere…

I just can’t seem to get Thunderbird to accept the folders with the old profile name. Arrrrgh…

I ended up downloading and installing an earlier version of Thunderbird - 67.0b3 - a beta version. After starting it, I changed it to use my saved-profile.default in the .thunderbird folder and it worked! On checking the Help to see that I really was using the older version, it apparently upgraded me to another beta version - 72.0b1. Whatever. I’m able to send and receive emails and all of my saved/archived emails are back. (Not sure how I’ll get back to non-beta versions but…)
Thanks to all for your help!

Hey Jim,

Glad to hear you got that straightened out. I can imagine that instance of angry panic: “I’m gonna have to boot into another partition every time I want to get my email? That aught to make opening an online account extra-super fun.”

Being a long time collector of problems and solutions and for the benefit of less experienced users I was wondering whether you could add to or correct the following.

I’m guessing you added a partition to run Linux Mint 19.2. You downloaded T-bird from Software Manager and got a 7x.x version. I’ll further guess that the source of your .default file was an older Linux OS, perhaps Mint 18.3. Since Mint’s thing has always been stability, they tend to withhold updates. So your source–like mine–is probably running version 6x.x. Thunderbird is still getting updated, it’s just staying comfortably behind.

And so shortly after you got T-bird running you got an update which installed the latest version.

Therefore, somewhere between versions they decided to re-write the file system. And as long as you were getting regular updates one of the updates would do just that. So Akito was bang on in that your archives needed to be converted.

But rather than coming up with a script, you found the most elegant solution. T-bird already wrote such a script! It’s contained in an update, so why re-invent the wheel?

So you found an older version (perhaps a .deb file) installed it, opened it once and closed it again. (To create profile .ini and .default files.) You swapped out the files and when you re-opened T-bird you were back in business.

Does this sound about right?

1 Like

Solved that issue when I opted to just run the web instance of Gmail. Works all the time.

Hey Dave,
That’s pretty accurate but I re-partitioned my hard drive because I didn’t initially setup enough space in the root partition and, after a year or so, started getting messages about lack of space. I was running Mint 19.2 and I always apply all of the recommended updates in Update Manager. That’s why I was surprised when, after reinstalling 19.2, I had the problem with Thunderbird. I had seen the posts about TB 68.2.2 but, as it didn’t come up in Update Manager, I didn’t try to install it and I know that I was on some earlier version than that one.
I found a pre-68 version on https://ftp.mozilla.org/pub/thunderbird/releases/ and grabbed one labled as a release 67.x - I didn’t realize that the ‘b’ in the name meant that it was a beta version. I nervously installed it, swapped the profile name to my saved profile in a backup of .thunderbird and, it worked! Then, Thunderbird updated itself to the newer Beta version of 72.01b.
I did find that the data is backwards compatible to a release version using “thunderbird -P --allow-downgrade” (see website: https://support.mozilla.org/ar/questions/1272094) but, I think I’ll use this version for awhile until I get brave again. It’ll probably be awhile. :wink:
Nervous?? Nah. This is me preparing to wipe my hard drive, re-install the operating system and see what happens…


Thanks Dave and Akito for your help!!!
Wgberninghausen, thanks for looking and your reply. I currently have too many different email addresses to use the web for each one.
Best,
Jim

3 Likes

Guess this is, more or less, solved…

Hey Jim,
It looks like you found an issue based purely on bad timing. Judging by T-birds’ release pattern and my update history I’ll get the critical update this spring. And since I plan to upgrade everything to19.3 the spring after that, I would never have been aware there was a problem.

I was getting memory warnings on an old desk top. It’s a beast with 8 cores and 32gb of buffered RAM. I use it only for a few things. Copying backup external drives, mass format conversions and secure internet financial activity. I don’t store any data on it. Apart from a handful of small apps it’s Linux Mint 18.3 right out of the box. It used about 85GB of a 125GB SSD after installation.

Nevertheless about every half year or so I get the memory low message. This is when I notice my system has bloated out to 120GB.

And I know where it was all goes: Timeshift backups. Don’t get me wrong, I love Timeshift, but on machine which contains 0 unique files, is running an OS which has been error free for 3 years, and can be re-made from scratch in 45 minutes, do I really keep every backup?

Anyway, deleting Timeshift files is fun–because it really seems like such a crazily irresponsible thing to do. And it works great too! :laughing:

85 or 8.5? i have a fairly fresh mint 19.2 vm installation that takes only 7.3 gb and a full 18.3 in a separate partition that is less than 10.

i tend to be a bit (i feel) over-cautious when it comes to backups. i have 27 snapshots of my five month old bodhi linux 5.1 installation that take up just about 43 gb of space in addition to the monthly clonezilla images i make.

i do keep all of mine on external drives just in case the internal one goes without warning though.

was there something else you were hoping to do like get off of the beta channel? asking because of the ellipses … :slight_smile:

Well, I’d like to go back to the regular release (not beta) version but, so far, I’m not having any problems with the beta. Sorry about the ellipses.

8 posts were split to a new topic: Keep old Timeshift backups?

Don’t know, if still relevant, but for Thunderbird’s data (emails, contacts, profiles, …) I use (and recommend when asked) the Add-In Import-Export-Tools
You can even schedule backups.

1 Like

Hey Fast.Edi! (You shoot lucky! :wink: )
The import-export tools sound like they’d definitely be something I could use. When I looked though, it came up as incompatible with my new beta version of 72.xxx. It’s always something.
Thanks and I’ll keep it in mind when I finally get back on normal releases.

2 Likes