Return to Castle Wolvenstein

I am looking for some help. I have the disk RtCW and I used to play it on my Ubuntu machine years ago. I recently rediscovered the disk and trying to play it again. I have W.I.N.E. installed and I installed playonlinux. When I try to install it is says you have insufficient disk space. I have 2Tb. I have updated to to latest version of W.I.N.E. and same results, insufficient disk space. I have uninstalled playonlinux and reinstalled steam hoping I could open it with that. My question is this how do I expand the virtual drive and where would I look? I have Virtualbox installed and if I look in Virtualbox Machine Manager nothing is listed corresponding with either playonlinux, W.I.N.E or steam. I can find .wine in my home directory but nothing points me in the right direction, not that it would do me any good I still don’t know how to expand it.
Sorry if this is on the wrong place, I am running Ubuntu 20.04.3
I’ve perused the gaming forum and found nothing to help me.

Did you use PlayOnLinux’ preset for this game, instead of manually installing it in Wine?

1 Like

I installed it via Ubuntu software center and also via terminal. Then went to the web site to see if I could download it from there. I open playonlinux then install from the CD get to the registration window, it appears you have a val


id CD key, click install, sorry it appears you don’t have enough disk space

Did you check out the following resources?

https://www.playonlinux.com/en/topic-10246.html
https://www.playonlinux.com/en/topic-10847-There_is_not_enough_space_error.html
https://www.playonlinux.com/en/reply-16561.html
https://www.playonlinux.com/en/topic-16561-SWTOR__Unable_to_retrieve_patch_data_due_to_insufficient_disk_spaceError_304.html

https://forum.winehq.org/viewtopic.php?t=31027
https://forum.winehq.org/viewtopic.php?t=31311

Please check out all the information available, thoroughly.

I will thank you. I did read the post about SWTOR but found nothing relevant there.

I see. Did you read all the other posts? Some gave a couple of great hints. For example, one was leading into the direction of permission issues, which I find to be likely the cause for your issue.

I did but it went over my head. What I’m trying to understand is where it creates the virtualbox and how to access it. That’s my starting point. I did install q4wine which has gotten me closer to my goal but still struggling. I create a fake drive update it and try again to install this time rather than on C drive I chose a different drive and created a file called rtcw, copied all the files into it and again the same results not enough disk space. I then deleted that drive I created then placed all the files into the temp folder on C drive. Same results different day. I would ultimently like to create a drive of say 25Gb then install to that drive or at least access the current drive and increase it’s size. I will peruse the wine forum again and also the q4wine forum.

I do not really understand this. This sounds 10 times more complicated than just reading the posts and trying to find the right solution, instead of randomly pursuing pure actionism, by trying out different difficult solutions, in the hopes that one might work, accidentally.

The problem with your approach is, that you are not trying to find the root cause of the problem, but instead just randomly do stuff, without a proper problem analysis.

What you are trying to do is also a case of:
https://xyproblem.info/

Akito you are very astute, and I see the error of my ways. I am going back over the links pointing to permissions being my problem. For me to understand the problem is like trying to read a scientific journal. I understand some of the words but some I need to sound out even try to spell them just to pronounce them. Just because I can doesn’t mean I now know what it means. I still need to do more research to get to the root. I do appreciate all the help I have gotten from this forum over the years and will continue to seek out knowledge here. I thank all who have contributed in the past and one day I might be able to help you as well,

I have discovered a way to install RtCW I did it via Virtualbox and my Window$ 10 VM, using this information for others who are interested in trying.

Is it possible to insert a physical CD into a VirtualBox machine?

Ask Question

Asked 4 years, 8 months ago

Active 5 months ago

Viewed 33k times

I have CDs for Age of Empire III and I would like to play it in a Windows 10 VM. Is this possible? I know how to insert virtual CDs (i.e., ISO files) into a VirtualBox VM (via the “Storage” settings), but physical CDs are a different story. The best solution I can think of is to add where I’ve mounted the CDs on my Linux system to the system via shared folders.

Yes you can, but you need to have DVD passthrough active.

Go to VirtualBox’s Machine > Settings > Storage > Enable Passthrough for the DVD drive.

To allow an external DVD drive to be recognized by a VirtualBox Virtual Machine (VM) it must be configured in such a way that “passthrough” is enabled. Enabling Passthrough allows the underlying operating system to pass the required commands through to the device that is connected to the Virtual Machine as opposed to the host operating system instance.
Thank you again Akito, for any help you have given me, my next problem is it loads but doesn’t see my mouse. I’m thinking I need to install DirectX or it’s a permissions issue. But I’m making progress.

Maybe skip Wine and try Lutris - Lutris should be able to find you a NATIVE LINUX engine to run it on - it will be one of the Quake engines that John Carmack wrote (note he mostly always developed his engines on UNIX systems like NeXT cubes and probably later on on Intel based Macs) - and benevolently made open source (unlike those ASS-HOLES at Bethesda) so it can be backported for forward-ported to other platforms and architectures…

I run a bunch of ID games through Lutris - it even has wizardy things to help you… you might have to do some reading, but it should be eminently doable…

I’ve played Quake III and IV and Doom3 (and Doom3 BFG) via Lutris - on Ubuntu - it works a treat…

I bought the games on Steam, then told Lutris where to find the binaries (and the all important WAD or PAK files)…

But as for Wolfenstein - the only one I’ve played successfully on Linux was “The Old Blood” (i.e. circa 2012??? ) and that was through Steam and “Steamplay” thanks to proton/wine… don’t ask me too m any questions about that - because I let Steam do all the magic under the hood and I barely have to touch fuckall whatsoever… But - it played REALLY well - and I’m pretty sure that was on my old rig (Phenom II X6 16 GB RAM and GTX1650 super - aint tried it on my Ryzen 7 with 40 GB RAM)…

Thank you Daniel, I appreciate you taking the time to read and respond to my dilemma. Now I saw you said not to ask to many questions but if I may. Lutris, where do I find it, when you told steam where to look for the binaries could you explain that? Did you download the files to a folder on your machine, I really don’t understand how that works. Last question WAD or PAK files? Is that the same as .bin and ,exe?

Sorry - I just google searched I think (and as I mentioned - pretty sure Lutris has a “Wizard” or help thing that will assist you).

Google for “Lutris” - you add a PPA or something and it installs :

https://lutris.net/

PAK or WAD files are the game files, e.g. they contain the game data, 3D models, textures, maps… 9/10 times they’re platform agnostic (i.e. can potentially be run anywhere). e.g. the original Doom 1, shareware came with a WAD file that only had the first 10 levels, if you wanted the other 20, you had to buy it and for that money you got additional WAD files.

.exe files are usually specifically ONLY for Microsoft (DOS or Windows) stuff… yeah an EXE files is what you would run in Wine if you were going to try to run a Windows app in Linux.

Anyway - read this about RTCW :

If you get stuck - read it again? If you’re still stuck, web search for possible answers resolutions. I won’t have the answers, because I’m pretty much “set it and forget it”…

Thank you Daniel, I did just that yesterday morning and found Lutris and installed it via terminal for Ubuntu 20.04.3. First time running it it said that my nVidia drivers weren’t up to snuff and I needed to install XXX drivers I did rebooted and wow! I couldn’t get back far enough from my screen to read it. I tried to revert back to my original driver and just wouldn’t allow it. I reinstalled my backup and now I’m trying to figure out what happened.
I own the original disk that is why I asked about the .bin and .exe files. I created a folder in my home directory: Home/Games and placed all files (316) from the CD in there. Nothing, I then saw GOG and installed that and saw it created a directory: Home/GOG Games. I copied the files over to there tried to install through GOG and looked in the library and nothing. I reinstalled Steam tried installing via Steam nothing. I have the latest WINE and Winetricks installed. How do I install from a Window$ oriented game CD into Linux? Lutris, GOG or Steam running PROTON? I just need a link, something to point me in the right direction. I see it can be done. Thank you all who take the time to read this.

I’m not a wine expert. Though as far as I know, wine tries to do everything in the /home/<user> directory. If your /home directory is a separate partition, you will quickly hit the size limit when you try to install large software.

Run ‘df’ in a terminal:

/home/<user>~$ df

you will see a few lines like

udev             8159040         0   8159040   0% /dev
tmpfs            1636540      1460   1635080   1% /run
/dev/sda2       38186548  30691792   5525248  85% /

If there is a line for /home, like

/dev/sda3       38186548  24186024  12031016  67% /home

then your /home directory is a separate partition.

In that case you should consult the wine documentation to see how you could use a different directory for your wine install. Maybe someone in this forum has an off-the-shelf solution for it?

mikey@mikey-desktop:~$ df
Filesystem 1K-blocks Used Available Use% Mounted on
udev 8141108 0 8141108 0% /dev
tmpfs 1634248 2000 1632248 1% /run
/dev/sda2 2882703568 220700124 2515500020 9% /
tmpfs 8171224 5044 8166180 1% /dev/shm
tmpfs 5120 4 5116 1% /run/lock
tmpfs 8171224 0 8171224 0% /sys/fs/cgroup
/dev/loop5 148096 148096 0 100% /snap/chromium/1810
/dev/loop2 73728 73728 0 100% /snap/bitwarden/58
/dev/loop4 9344 9344 0 100% /snap/canonical-livepatch/126
/dev/loop3 9344 9344 0 100% /snap/canonical-livepatch/119
/dev/loop0 128 128 0 100% /snap/bare/5
/dev/loop1 73728 73728 0 100% /snap/bitwarden/57
/dev/loop7 101888 101888 0 100% /snap/core/11993
/dev/loop8 56832 56832 0 100% /snap/core18/2246
/dev/loop9 56832 56832 0 100% /snap/core18/2253
/dev/loop6 151424 151424 0 100% /snap/chromium/1827
/dev/loop11 101888 101888 0 100% /snap/core/11798
/dev/loop12 224256 224256 0 100% /snap/gnome-3-34-1804/77
/dev/loop10 63360 63360 0 100% /snap/core20/1169
/dev/loop15 253952 253952 0 100% /snap/gnome-3-38-2004/87
/dev/loop13 66688 66688 0 100% /snap/gtk-common-themes/1515
/dev/loop17 224256 224256 0 100% /snap/gnome-3-34-1804/72
/dev/loop16 66816 66816 0 100% /snap/gtk-common-themes/1519
/dev/loop14 168832 168832 0 100% /snap/gnome-3-28-1804/161
/dev/loop20 33280 33280 0 100% /snap/snapd/13640
/dev/loop18 63360 63360 0 100% /snap/core20/1242
/dev/loop25 43264 43264 0 100% /snap/snapd/14066
/dev/loop23 55552 55552 0 100% /snap/snap-store/558
/dev/loop19 267008 267008 0 100% /snap/kde-frameworks-5-core18/32
/dev/loop26 4352 4352 0 100% /snap/tree/18
/dev/loop24 17408 17408 0 100% /snap/mcpelauncher-thesonicmaster/15
/dev/loop21 52224 52224 0 100% /snap/snap-store/547
/dev/loop27 768 768 0 100% /snap/ufw/501
/dev/loop22 162688 162688 0 100% /snap/qbittorrent-arnatious/83
/dev/sda1 523248 8036 515212 2% /boot/efi
tmpfs 1634244 52 1634192 1% /run/user/1000

You shouldn’t need either Steam or Gog if you want to play your copy of the game…

Sorry - I didn’t realise the Lutris method assumed Gog or Steam…

I own Quake I, III and IV on CD/DVD… but it (and Doom 3) were so cheap on Steam - I just bought them again anyway… e.g. Doom 3 was less than $5… it’s no brainer (it is ANNOYING that Steam do NOT have the Linux port)… I mean that’s the cost of a coffee in the First World… I guess I should care and think “I already paid for it once, why should I pay again…”, and then there’s reality… I’ve been working from home mostly the last few months, and saving a fortune on barista made coffee, so I can spare $5 here and there for the odd game…

Sorry if I steered you in the wrong direction mate…

There may, or may not, be a Wine way to do it. I don’t have the answer… but I’m pretty sure there’s a native Linux engine for RTCW…

Maybe have a read of this series of reddit posts :