Revitalizing a really(!) ancient machine

I helped a friend here to get started on the way towards Linux, and his old, but still usable Laptop got a 32 bit Linux Mint 19.3 XFCE. He was amazed how well this system performed on his old laptop. He gave me his very first ancient laptop just to see if I can put Linux onto it too?
It’s a HP pavilion ze4200, AMD Athlon XP2200+ (mobile) and having 512MB RAM.
Originally Windows XP was installed, booting in several minutes, I’d say it was unbearable…
This laptop has no real use today, so there was nothing to loose.
There’s a PCMCIA adapter attached providing USB2.0 ports to use a Wifi stick, becasue this dinosaur is so old, that it doesn’t have a wifi builtin.
So the task specification looks so:
-Find and install a Linux distro, which is light enough to run on this CPU/RAM
-it has to be able to use the PCMCIA USB 2.0, and the wifi stick plugged in.

I started too look for lightweight distros, such as Antix, older Lubuntus, Puppy, Sparky, etc…
Having burnt couple boot/install CD’s I felt that I’m going to waste a bunch of discs, so looked for something that let’s me boot from USB despite the very old limited BIOS.
So I found plop boot CD:
https://www.plop.at/en/bootmanager/download.html
There’s one problem: this plop thing freezes whenever I touch the keyboard, so I can’t really choose the boot device…
Thanks God, I found in a forum (can’t recall the source), that in BIOS disabling legacy USB support would solve this problem. I tried, and violá! It worked.
I could boot up my USB drive. This opened up the possibility to try a real big heap of distros without wasting a disc for each…
So the game started: download an iso, flash to USB, boot it up, get into live sessions where possible, install, and evaluate…
…none of the promising distros made me really happy with this machine.

Because I’m in love with Debian, gave it a try too. Jump in time here 4 days, and I tell in a nutshell, that Debian 8.11 with LXDE won my contest :smiley:

Here’s what I did with it:
-downloaded the netinst image ( https://cdimage.debian.org/mirror/cdimage/archive/8.11.1/i386/iso-cd/debian-8.11.1-i386-netinst.iso ), and made the install using it.
-at the tasksel stage I asked for LXDE desktop
By default I get the 686 PAE enabled kernel, but with this kernel the ACPI functions don’t work on this laptop. So I installed the non-pae kernel ( apt install linux-image-586 ).
Booting with this kernel the ACPI functions work too, the shutdown will also switch off, and it’s possible to change the LCD brightness. These things don’t work on PAE kernel, even if started with acpi=strict or acpi=force.
The PCMCIA worked out of the box, but I needed to mess with firmwares in order to use the wifi stick.
The dmesg told me about firmware problems, when plugged in the stick.
First I “stole” the rtlwifi directory from another distro’s /lib/firmware, which could use the stick.
So I basically just copied the firmware, but later I found that I can install them in a correct way:
enable non-free repo in /etc/apt/sources.list

deb http://deb.debian.org/debian/ jessie main contrib non-free

Then run
apt update; apt install firmware-linux-nonfree; apt install firmware-realtek

So the stick works…
Unfortunately Wicd (LXDE Network managing stuff) doesn’t really work well. So I purge it, as it’s useless. I need network manager!

apt purge wicd*
apt install network-manager network-manager-gnome

Booting now LXDE, in the network corner my Wifi shows up, I can connect, etc. So it just works as I expect it to. :sunglasses:

Because I like to tap as click, I need to add a config file in /etc/X11/xorg.conf.d/20-tapp.conf with the content:

Section “InputClass”
Identifier “touchpad catchall”
Driver “synaptics”
MatchIsTouchpad “on”
Option “TapButton1” “1”
Option “TapButton2” “3”
Option “TapButton3” “2”
Endsection

Reboot or restart lightdm ( service lightdm restart ), and tapping as mouseclick works too.
This whole thing with Debian 8.11 on the non-pae kernel boots in 38 seconds: I measure from GRUB to the login screen, BIOS POST time not included.
Having entered the login informations, from pressing [Login], additional 15 seconds are needed until the desktop fully loads.
This isn’t very fast of course, but be aware that Windows XP took almost 7 minutes to load completely on this rusty old machine. :wink:
With a freshly started idling desktop approx. 170MB RAM is consumed.
I wouldn’t love to use this system, but if there would be a real must, at least it’s not unbearable.
So if someone looks for a super-lightweight Linux, check out Debian + LXDE too! With some small modifications it could be a good bet!

2 Likes

Nice work. Thanks for sharing.
We had some other “oldies” on our community meeting last week: 2 Asus eee-PCs
Slightly newer than your Pavilion, but still useful.
We fired a Crunchbang upon the first and an AntiX on the other.
Working nicely and fast (in perspective of the hardware).

2 Likes

Well done You :1st_place_medal: I like that you did it just for the hell of it? :+1:
I have my original Win95 Pentium2 Computer with digitizer graphics pad - AutoCAD LT97 menu - down the shed if anybody nearby wishes to revitalize it? Free of course and can deliver if near a Holiday Destination for MotorHome.

2 Likes

Some of the newer systems, like Lubuntu 16.04, required nomce kernel parameter to be able to start at all -but they started.
I also had great expectations and hope of Antix, but to no avail. I found no trick for it, always just freezed :frowning:

2 Likes

Yes, for me it was the temptation: proove, that Linux can revive an old computer.
I could have easily failed, that would be no problem. But I succeeded!
S.D.G. :smiley:

3 Likes

GOOD JOB!!
I put Manjaro on an ancient laptop that I have. Again, just to see if I could do it. It runs well but I never use it.

2 Likes