Scanner Detection

I have 2 desktop computers both with recent installations of Zorin-16. (Ubuntu 20.04) One of them (Lenovo) can print to and scan from my HP LaserJet Pro MFP M130fn. The other one (HP EliteDesk) can print, but cannot scan. A common ethernet network connects the three devices. The scan app is “Document Scanner” (comes with Zorin). HPLIP is not installed on either box, having been removed on both because it didn’t help. The only difference I can see between the two is that when the Lenovo scan app looks for scanners, it comes up with TWO choices: one that starts with “ESCL HP…” and the other starts with “Hewlett Pac …”. The device that has been chosen is “Hewlett Pac …” and it works. On the HP desktop, when the same scanner app scans for devices, it comes up with only ONE choice, and it’s the one that starts with “ESCL HP…” – and it doesn’t work. The error message is “FAILED TO SCAN, unable to start scan” However, at the same time the scanner does come to life and I can hear it mechanically scanning, but the printer display screen hangs at “Scanning to computer” so the printer receives the request to initiate a scan, but when it tries to send the data to the computer the computer won’t accept it. Again – BOTH boxes can print. Why would one box work and the other one NOT?
Any ideas out there? :thinking: (Yes, I can just scan to the one that works… :unamused:)

Can you find out what scanner drivers are installed on each desktop. That might be the difference

In Lenovo desktop, printer shows up with URI:
and this is the printer choice that works for the scanner
in the HP desktop, the above URI is not present with any of the three ‘printers’ that are ID’d in Settings / Printers. I tried changing one URI to this, but it resulted in no scanning and no printing either.

I think they are different but I’m not sure how to make them the same. I tried copying the file
/usr/lib/cups/filter/hpcups from the Lenovo to the HP box, because at one point in trying to install drivers the HP box complained that the above file was missing, and it was. I got it installed using apt to install printer-driver-hpcups. However it still didn’t work, and that hpcups file was less than half the size of the one on the Lenovo, obviously not the same. So then I copied the one from the Lenovo, but that didn’t fix the problem either. And I really don’t know if that is “the driver” or if they are somewhere else. I also manged to “create” a printer with the URI copied from the Lenovo, but it wouldn’t print or scan either. I’m so good at this that now I can’t even print! The driver search that takes place during “ADD PRINTER” actually does find three of them for my exact model of printer, but one is obviously not appropriate (I forget why) and the other two have both been tried without success. Maybe I just need to let this problem rest for a while and use the Lenovo for scan and print. But it bugs me!

As @nevj stated, what drivers have you used?
Is it the drivers that hp offers?
or the direct download for Zorin

Just a suggestion, though.

You seem to be confusing printer drivers with scanner drivers.
Nothing to do with CUPS or printing. Linux sees the scanner as a separate device from the printer.
Scanner drivers are separate and are usually installed as a package.
Look through dpkg -l | more
this gives a list of all installed packages
see if you can see packages with ‘scan’ in their name

You need to reinstall the hplip and hplip-gui packages on that machine and install the printer via hp toolbox or it may say hp device manager. Then try scanning again. On some hp lazer printers you will also need a plugin from HP to get the scanner to work properly.
If that fails on the zorin hplip driver go to hp’s linux driver site found here HP Drivers and follow the instructions on their page to install.

You can also take a look at the Xsane software:


xsane works with most scanners, so if your current efforts come to naught, give it a try.

Thanks for explaining that scanner and printer have their own drivers and are seen separately. Understanding the situation is worth a lot. I did dpkg -l | grep scan on both machines and got exactly the same lines of output. I don’t see any that look like a driver for a flatbed scanner.
jim@EliteZorin:~$ dpkg -l | grep scan

ii libsane:amd64 1.0.29-0ubuntu5.2 amd64 API library for scanners
ii libsane-common 1.0.29-0ubuntu5.2 all API library for scanners – documentation and support files
ii libsane-dev:amd64 1.0.29-0ubuntu5.2 amd64 API development library for scanners [development files]
ii libzbar0:amd64 0.23-1.3 amd64 QR code / bar code scanner and decoder (library)
ii mawk amd64 Pattern scanning and text processing language
ii sane-utils 1.0.29-0ubuntu5.2 amd64 API library for scanners – utilities
ii simple-scan 3.36.3-0ubuntu0.20.04.0 amd64 Simple Scanning Utility

When I did dpkg -l | grep print I got tons of lines with the word driver in them

the HPLIP package is described by HP as “Print, Scan, and Fax Drivers for Linux”, and the latest version includes a printer driver for my particular model of multifunction printer. When HPLIP is installed you can run hp-setup which will get the PRINT function going, and maybe the scanner too, but often NOT. Zorin comes with HPLIP installed but on the Lenovo, I found that after removing it, the printer and scanner both still work; the drivers have been installed so HPLIP isn’t needed unless I want to change or add something. I don’t know where the scanner driver is installed, or if it came via HPLIP or other means. There is a second package “hplip-gui” with which “hp-setup” is taken care of graphically. If hplip is not installed and you install hplip-gui, here is what it displays:

jim@EliteZorin:/etc/cups$ sudo apt install hplip-gui
[sudo] password for jim:
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following additional packages will be installed:
hplip hplip-data libsane-hpaio printer-driver-postscript-hp python3-renderpm
python3-reportlab python3-reportlab-accel
Suggested packages:
hplip-doc python3-renderpm-dbg python3-egenix-mxtexttools
The following NEW packages will be installed:
hplip hplip-data hplip-gui libsane-hpaio printer-driver-postscript-hp
python3-renderpm python3-reportlab python3-reportlab-accel
0 upgraded, 8 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/8,525 kB of archives.
After this operation, 17.5 MB of additional disk space will be used.
Do you want to continue? [Y/n

I just noticed the “suggested packages” line. Maybe I should install those, but the Lenovo works fine without them.

That confuses me.
My brother MFC has separate drivers for the print and scan functions and they appear as separate packages
Maybe HP bundle them all into the one package, I dont know, I do not have an HP printer.

You coukd try lsmod
That tells you what modules the kernel has loaded.

I dont think Suggested Packages will help

I notice you have sane packages.
Did you try Xsane ? That is what I use to scan. It works for me

Drilling Down:
Thanks to all who have replied. I have removed and re-installed Document Scanner and hplip-gui on the computer that cannot talk to the flatbed scanner. Document Scanner now finds an additonal “scanner” on the network, and when that one is chosen, “HP Device Manager” says that there is a missing plug-in. Replying “yes” to the offer to install it brings up “Network Connection not Detected”, and after a few seconds another message from “HPLIP Status Service” says “No System Tray detected on this system. Unable to start, exiting.” No other programs have trouble with network connection.

Thanks for your replies. Yes, I have tried Xsane, and it has the identical problem. Document Scanner is based on sane, so I suppose that’s why they both respond this way. Incidentally, I tried the free version of “Vuescan” which is a scanner program that is not a Linux type “package” – it is a binary file with an installer (like Windows) and it worked fine; they include drivers in the program – but it puts a huge watermark on every scan and you have to pay to get the “real” version. Maybe I’ll have to pay, but I would much prefer to get it to work like it should. See also my “reply to all” – seems like I’m getting closer, bu t not there yet.

As @nevj stated, what drivers have you used?
Is it the drivers that hp offers?
I think I have used every driver under the sun. (a)via Zorin “Programs” (b) via “sudo apt install”, and (c) via “HP Linux Printer Support” . The “drivers” are all based on the device model number; there is no distinction given to the scanner, or mention of a “scanner driver”. The latest roadblock comes on the path of using HPLIP-GUI downloaded from HP. It installs with no problem and identifies the LaserJet MFP, but near the end of printer setup it says “there is a missing plug-in, would you like to install it?” (sic) and saying “yes” is followed by this:

But I do have a working network connection.

1 Like

This page from HP may be helpful. Plugins
The system tray error is nothing to worry about just saying it can not find a place to put the Hp Printer Icon. You need to get the plugin installed.

1 Like

That may not mean what you think.
It is looking for a plugin, and the installer probably has a defunct URL it is trying to look up.

Dont know what you do about it, other than try and find the name of the plugin, then search for it at HP.


This is Slackware’s version of installing Xsane (because I lost the link to the Ubuntu one I used) Take a gander, I think you will find it useful.

More good info here:

Networking pointers.

@nevj Thanks for your comments.
I retried plugin install (assume it is scanner plugin, but it is only called the “missing” plugin). This time I used a .run file of latest hplip downloaded from Results were a repeat of what I have seen before: (1) The printer gets installed, but then it offers to install missing plugin, I say OK, then it says “cannot get key from keyserver, want to install plugin anyway?” and I say OK, then after cranking for a while, it says “install failed”. I’ve been given some other suggestions, which I will explore today. If you are interested, here are some screenshots, two of the install gui, one from the terminal where the .run file was launched. I do use Python, but don’t know what a “gobject/dbus” is.

Aha, the networking info:

Follow those links from @kgwoo
You need more info

You need to find out where these 2 desktops differ.
How about doing dpkg -l in both desktops, and comparing the 2 outputs?
If the one that works has extra packages, try making them the same

If there is no difference in the packages, there must be a difference in the configurations. That is a bit harder to compare … the config files are spread everywhere