Sending newspaper items as emails

I am using Linux Mint 19.3 cinnamon and the latest edition of Firefox. For years I have read newspapers and sent items of particular interest by clicking the email symbol in the sidebar. The url comes up in an email form, and I can simply fill up the name of the recipient and send.
Quite recently, that hasn’t worked. Ticking the email box produces no result, except for the url appearing at the bottom of the page. I have tried other browsers with the same result and tried to get help from the respective forums, but with no luck.
I wonder if anyone here can let me know what might have happened to cause this change.

I don’t know this functionality.
Is it something that LM provides or is this a browser specific thing?
Maybe an Add-On to FF?
Perhaps you could provide a screenshot to clarify things.

1 Like

Thank you for your reply. I have taken a screenshot but am embarrased to say I can’t see how to attach it. Perhaps you can help. This sidebar exists in most British newspapers that I read. I meant to say in my first request that I have used Firefox and Flashpeak Slimjet and have done so with all add-ons disabled. It makes no difference.

Click the button that looks like a picture.

Thank you Akito. I shall now (try to) send a screenshot of part of a particular newspaper item, and you will see at the left various icons for sending the link. The email link is the one I have used, but it hasn’t worked recently.

Hmm. This does not really help.
Seems this is part of the website itself?
Can you provide the link of the newspaper (or the respective site)?
So we can test it.

That looks like the UK newspaper
The guardian
So any news story will work

On left of screen

Just tried it and appears to work fine no changes

Popup blocker or mailto (Tools > Options > Applications.) not activated would be my suggestions

I appreciate the help. Most UK newspapers seem to have this feature. You are right that the screenshot was from I have also used, and heaven help me, None work when I tick the email box. I have just tried once again, with all add-ons disabled, and the result is the same. I wish I had your luck, Callpaul.

Can confirm. FF 76.0.1 works fine with the mailto link.
Do you use any kind of security add-on? Like NoScript (as I do):
I had to allow maaaaany scripts and f*ckery to send the mail. But it did.

Open Firefox and click on the hamburger menu. Go to Preference.

Search for Mailto option and make sure that you have set it to Gmail/YahooMail or any other email service you use.

I hope this helps.


Thanks once again. I appear to be jinxed. As I said earlier, I have disabled all add-ons, which include noscript, and still no luck. I have also done as you advise, Abhishek, and I am set to thunderbird, which is the service I use. I can’t understand why this suddenly stopped working. I am using a VPN, and have disconnected from that, with no effect.