Setting Firefox as default on KDE Neon Plasma 5.24.3 issue

For whatever reason, setting Firefox as default within the browser itself does not work.
Problem is choosing for 2 Firefox in “default applications” - none of which seem to hold as Firefox keeps asking to be default.

Otherwise, this updated version is spiffy! :slight_smile:
Shuts down in a flash (just as promised)!

Is firefox install as a snap package? If so that maybe the reason it’s not allowing to be default.

Don’t know about that.
Good idea tho!
It was there at installation.
What’s odd, is that even if clicking “default” within the browser itself, nothing happens to show that it was set.

Maybe i should remove it and see…

Not sure how to remove Firefox.
It’s not listed in Discover as installed.
Flatpak version is listed but not installed.

In Default apps is Firefox default? sudo apt remove firefox in terminal. Then install Synaptic package manager sudo apt install synaptic Install Firefox from in there.

@clatterfordslim - had previously installed Synaptic and checked there, and sure enough, it shows up as being installed with latest version.

Just can’t figure out why even clicking on making it default (as per browser request) and then checking in its settings, and it still doesn’t show as default.

Weird. I’ve always had a problem with KDE whether Neon or Kubuntu. Swear they go down the same trail as normal Ubuntu does, waiting for patches? Don’t quote me on that, but always find niggles with those two, crashes mostly with whole system freezing for no apparent reason. The best KDE environment I ever used was Manjaro’s. Everything works out of the bag, no niggles nothing. I’m not saying move to Arch or anything, but wish that developers would test their OSES thoroughly before releasing them? Or at least test with different scenarios like you have with Firefox. I’m going to see if I can replicate your situation in VirtualBox. What version Kernel are you running?

OS KDE neon User - 5.24 x86_64
Host: Latitude E5430 non-vPro 01
Kernel: 5.13.0-35-generic
Shell: bash 5.0.17
Resolution: 1600x900, 1440x900
DE: Plasma
WM: KWin
Theme: [Plasma], Breeze [GTK2/3]
Icons: [Plasma], breeze-dark [GTK2/3]
CPU: Intel i5-3210M (4) @ 3.100GHz
GPU: Intel 3rd Gen Core processor Graphics Co
Memory: 1787MiB / 7856MiB

Never experienced this before with various KDE desktops, even NEON.

But a search on the internet proves that it has been an issue.

Yes definitely, got it running in VirtualBox and it keeps asking to make Firefox default.


Will look deeper into this weirdness and see if Kubuntu and Manjaro KDE has the same problems or not??

What I have noticed is the icon is missing in favorites list for Firefox I went into properties after right clicking the paper icon, opened the permissions tab and it seems to be owned by me. not having that default sign coming up anymore, left Click the icon window in properties searched for Firefox chose it, removed Firefox off of task manager then added it back from Favorites menu and default sign has gone. Though it’s weird why it thinks I am the owner of Firefox?


First of all right click Firefox in favorites menu


With this version it’s been placed in home/.local/applications folder. This script is still reading the bin file from original installation.


Make it executable then add it to your taskbar and it’ll open without the default sign coming up.
The only problem is, is now we have two Firefox’s running, one when right clicking an option to open with Firefox Browser, which will show the make default sign and this one which will not show the sign.

FireFox is installed on newer Ubuntu/Kubuntu Systems as a snap package. Snap packages do not show up as regular packages on the package manager and must be install and uninstalled via snap in a terminal. This page will explain it a little bit.
The long and short of it is FF runs in a sand boxed session and may not respond to system settings.
I would remove the snap package and download the file from FF make it exicutable and add it to the menu. Think you’ll find the problem your having will disappear.
Also this page will give some ideas of how to install FF outside of snap.
Good luck.

It is a deb file that’s installed, not Snaps. After uninstalling and deleting the two instances of Firefox that is set in /usr/.local/share/applications I installed synaptic package manager and reinstalled Firefox now the set as Default has gone but left with two instances of Firefox again. Even though asked to autoremove after apt update and upgrade. KDE as bad as normal Ubuntu with this bug showing two instances of the same app.


The Icon theme is my go to icon theme Sardi Ghost Flexible cannot stand these bright icon themes anymore. Old before my time. Why they can’t release stuff till it is bug free is beyond me?

1 Like

And Manjaro doesn’t have this issue?

Problem is, i always experience issues with Manjaro at some point or another…

Maybe I’ll just wait for Feren OS to upload its snapshot 'n see.

No as far as I know it doesn’t, will test the latest Manjaro KDE out in VirtualBox. Though because they have a different package manager all together, as this bug is Debian based and only in Ubuntu based system. Neon and I think Kubuntu. Give me some time and I shall let you know. The issues for me have gone in Manjaro as the community only send out updates when they have been tested properly. That’s why I love Manjaro so much, they have dedicated community who are on the ball.

Manjaro and Kubuntu do not have this problem only Neon seems to. Kubuntu does not have VirtualBox drivers out of the bag, also it did not like my password. Yet all the other KDE desktops excepted my password. I even uninstalled Snapd to make sure that Firefox wasn’t a Snap Package, though Firefox takes ages to open, so my suspicions are it’s a Flatpak maybe? Manjaro is lightning fast and like I said before I have not had any problems with updates from Manjaro, because the team there test updates before releasing them.

No it’s a Deb file and no issues, though have not added plasma add on yet. Too many screen effects causing Firefox to open slower? Manjaro and Neon open quicker with the same amount of screen effects on. Weird.

From what i’ve read on the web thus far…
Definitely a KDE Neon issue.

@clatterfordslim - definitely a KDE Neon issue.

Had tried their latest .iso and it was just as before.

Presently running Manjaro’s latest with KDE, non-existent there.