Shift thunderbird to another partition

Hi all, :wave:

the application that takes up most of the space on my (somewhat limited) home partition is thunderbird with its 6.1 GB.

I´d like to move the folder /home/rosika/.thunderbird to my 3rd (data-) partition where there is plenty of space available. :blush:

The path in my case could be e.g.:


Copying the .thunderbird folder to the new location shouldn´t be the problem. However I somehow have to configure thunderbird to use the new location.

I know there´s something like a profile manager for firefox, so there should be a similar help for thunderbird as well… :thinking:

Or is there another way of accomplishing the task :question:

Many thanks in advance and many greetings from Rosika :slightly_smiling_face:

Hi Rosika,

I do not use thunderbird, but I found this on the internet. I hope it might help you.


Open the Thunderbird folder, then open the Profiles folder. Linux: Profile folders are located in ~/. thunderbird//.Oct 27, 2021

And here is te link to the page.
How to Find Your Mozilla Thunderbird Profile Directory.

Kind Regards,


Hi Howard, :wave:

thanks a lot for your quick reply. :heart:

Most of the things the lifewire link told me I already knew.
I know where the thunderbird profile is on my home partition. That´s no problem.
Neither is copying it to my third partition, like I said.

I also followed the steps from here: How to Move Your Mozilla Thunderbird Profile .

The critical step seems to be:

Update the Profile Folder Location in Thunderbird

It says:

Open profiles.ini in a text editor. You’ll find it at /Users/[your username]/Library/Thunderbird/.

But this seems to refer to MACs. I need it for Linux. :neutral_face:

Thanks a lot, Howard.

Cheers from Rosika :slightly_smiling_face:

1 Like

Hi Rosika,
I use Thunderbird, but I’m not at home at the moment. I can check as soon as I get home.


1 Like

IMHO there is no need to modify the profiles.ini. I have just verified, that it works with a link.

  • Move the entire ~/.thunderbird folder to the new location.
  • Create a link: ln -s /new/tb/location ~/.thunderbird

I didn’t see any problem, but this was not a deep testing.


Hi Rosi!

Look in



Hi @abu,
welcome to the forum.

I’m sorry for only replying now: I had a lot of traffic getting home.
In my opinion, @abu and Mina’s answers are both valid, but I would use symlink as @abu mentioned because Thunderbird uses Profiles, like Firefox, and they are all inside the ~/.thunderbird folder.
If you symlink the directory, any new profiles that are created and the crash reports themselves will be saved to your data partition.

This is my ~/.thunderbird folder:

My profiles.ini:

And these are my settings seen in Thunderbird: menu → Edit → Settings → Thunderbird Settings → Config Editor and searching for the word “directory”:



Hi Rosika,
You can use a soft link
Call the link .thunderbird
place it where the original .thunderbird directory was
and point it to the new location
Then you dont have to change anything in Thunderbird, it will follow the link.

You can do the same thing if you wanted, for example, to move your /home directory,

Soryy I just noticed @abu gave the same method


Hi all, :wave:

thanks so much for your replies. :heart:

general remark:

The soft link method seems pretty good.
Initially I was of the opinion I could use the profile manager which pops up before thunderbird actually starts:


Doesn´t seem that way. Oh well…

@abu :

Welcome to the forum. :heart:

Thanks for your suggestion.

That´s great. Yet my ultimate goal was to delete the original TB folder on my home partition so that I can regain space.
If I delete ~/.thunderbird it´ll be re-created as a link, right :question:

@Mina :

Thanks Mina

it looks like this with me:

cat profiles.ini




@Tech_JA :

Hi Jorge,

No need to apologize at all. I´m glad for your reply.

Yes, that´s sounds good indeed.
I think my best bet is to go for that.

@nevj :

Thanks to you as well, Neville. :heart:

So symlinking seems to be the best method. I´ll do just that.

Once again: many thanks to all of you kind folks for your help.
I´ll give it a try and report back.

Many greetings from Rosika :slightly_smiling_face:


I forgot to ask:

As far as copying the .thunderbird folder to the new location on my 3rd partition is concerned…

I guess all permissions have to be be preserved.

So what might be the best way to initiate the copying process, cp or rsync :question:

  • cp -r ~/.thunderbird /media/rosika/f14a27c2-0b49-4607-94ea-2e56bbf76fe1/new_TB
  • rsync -r -a --info=progress2 ~/.thunderbird /media/rosika/f14a27c2-0b49-4607-94ea-2e56bbf76fe1/new_TB
1 Like

Only a few bytes for the link ~/.thunderbird remain on the old ($HOME) location.


Nothing special about that. Just own it yourself…
If there’s any doubt, something like:
chown rosika:rosika newthunderbirdlocation -R
will set correct permissions for Thunderbird.


Hi again, :wave:

@abu :

Thanks so much, Alfred, for the confirmation.
I can cartainly spare those few bytes for the link. :wink:

@kovacslt :

Thanks a lot, László.

Great to know, just in case it might be needed. :+1:

So I can use either command, cp or rsync for the purpose of copying.

I like rsync -r -a --info=progress2 because I can see the progress there…

Thanks again to all of you and cheers from Rosika :slightly_smiling_face:

1 Like

You obviously have to delete or rename ~/.thunderbird, before you can create a symbolic link of the same name.

The link will not appear automatically, you have to manually create it.

cp - rp
you want to preserve permissions


Hi Neville, :wave:

Right. That was my understanding as well.
I´ll go for renaming it first, as I might want to keep it a bit longer to see if everything works out right:

mv ~/.thunderbird ~/.thunderbird.bak

Then I´m planning to delete it to get some space back. :wink:

I just finished copying TB´s folder to the new partition with rsync. It took 9 min 48sec for those 6.1 GB.

Thanks again and cheers from Rosika :slightly_smiling_face:


Oh, thanks, Neville. But now I´ve already used the command

rsync -r -a --info=progress2 ~/.thunderbird /media/rosika/f14a27c2-0b49-4607-94ea-2e56bbf76fe1/thunderbird_neu/

Let´s see if it worked out well.
But it´s good to know about the -p option for future use.


Oh dear, it doesn´t seem to have worked the way it should have… :frowning_face:

Creating the symbolic link was successful however.
I get the same results when comparing the contents:

rosika@rosika-Lenovo-H520e ~>  yy .thunderbird
drwxrwxr-x   - rosika rosika 22 Sep 17:19 Crash Reports
drwxrwxr-x   - rosika rosika 22 Sep 17:40 d2heyby0.von_rosalia
.rw-rw-r--  58 rosika rosika 16 Jan 14:34 installs.ini
drwxrwxr-x   - rosika rosika 16 Jan 17:37 Pending Pings
.rw-rw-r-- 187 rosika rosika 16 Jan 14:34 profiles.ini

rosika@rosika-Lenovo-H520e ~>  yy .thunderbird.bak/
drwxrwxr-x   - rosika rosika 22 Sep 17:19 Crash Reports
drwxrwxr-x   - rosika rosika 22 Sep 17:40 d2heyby0.von_rosalia
.rw-rw-r--  58 rosika rosika 16 Jan 14:34 installs.ini
drwxrwxr-x   - rosika rosika 16 Jan 17:37 Pending Pings
.rw-rw-r-- 187 rosika rosika 16 Jan 14:34 profiles.ini

(yy is just an alias for env EXA_COLORS=da=33:di=35 exa -lg' --description 'alias yy=env EXA_COLORS=da=33:di=35 exa -lg )


when starting thunderbird I got an empty chooser:


Cheers from Rosika :slightly_smiling_face:


Hang on, I got it:

Normally I use the command firejail thunderbird to get TB running within the firejail sandbox.

I suppose the thunderbird.profile (location: /etc/firejail/thunderbird.profile) won´t let me access it as per default because it´s on another partition now.
I may have to re-write TB´s profile to grant access to it.

Starting just thunderbird works as expected. :+1:

Thanks so much to all of you for your help. :heart:

1 Like

I dont get it.
It should be able to access the link pointer… what else might it need?

rsync -a -r should be fine here
but if you move something more complicated , like a whole OS, use
rsync -aAXvH


Hi Neville, :wave:

Yes, you´re right. And I don´t think that´s the problem because running the command thunderbird outside the sandbox works as expected. :+1:

The thing is: the access permissions (amongst other things) are defined in thunderbird.profile. Now that TB´s profile folder has shifted the sandbox seems to lack the permissions to access it.


I seem to have solved it now:

No need to modify TB´s profile. I just need a new command:

firejail --private=/media/rosika/f14a27c2-0b49-4607-94ea-2e56bbf76fe1/thunderbird_neu thunderbird

This defines TB´s new place as the working directory for thunderbird (within the sandbox).
Now I get my initial login back:


and everything can be accessed as it used to be. :smile:

Thanks again for your help, Neville.

Many greetings from Rosika :slightly_smiling_face:


Thanks a lot for the info, Neville. :heart:


Hi all, :wave:

it may be a bit off-topic, so excuse me for posting this additional info.
I guess most of you know it already but perhaps there´s still some newcomer around who doesn´t and may find it useful.

@nevj ´s command

looks intriguing. To learn what all the options mean one would normally consult rsync´s man pages.
An that´s fine if just one or two options (or parameters) are concerned.

For something more elaborate like Neville´s example it´s nice that the explainshell site is around. :blush:

To take Neville´s example: - rsync -aAXvH .

I´ve encountered some few commands that don´t seem to be covered by the site.
For many cases, however, explainshell is certainly worth bookmarking.

Cheers from Rosika :slightly_smiling_face:


I use the symlink (soft) method with nearly all of my stuff… But I don’t use a fat client for email…

e.g. ~/Documents, ~/Pictures, ~/Music, are all symlinks to stuff on my cloud sync folder, as is ~/bin and ~/.ssh/config … ~/Videos contains symlinks to storage on my NAS…

This is why I would never choose to use FAT or exFAT filesystems 'cause they don’t support symbolic links…

I also use rsync nearly everyday - I’ve replaced using “cp -r” or “cp -x” with rsync, but pretty much just :


If I need to get more complex (e.g. carefully using the --delete option to remove stuff that doesn’t exist in $SOURCE, but is in $DEST - I usually script it after I’ve tested thoroughly)…


Very well said.
rsync with - - delete is like a loose cannon.