[Solved] Audio on Linux: Pipewire/Pulseeffects issue

Greetings Friends,

Trust all are doing well.

[As always, I’m no coder/linux expert, but can run simple commands, GUI actions etc.]

Facing a strange issue. So I discovered that there is something called Sound Server in Linux and it is generally pulseaudio or alsa. I’ve been using pulseaudio and was not happy so installed pulseeffects. Didn’t like it either and learned about Easyeffects/pipewire.

I installed easyeffects but it simply doesn’t load/open. Curiously, when I uninstall pulseeffects from Synaptic or command line, the process completes successfully and yet I see pulseeffects in the start menu! It is as if uninstalling does nothing to it.

I just want to switch over to pipewire/easyeffects from pulseeffects. Please help. I’m on MX Linux.

PS: I cannot thank this community enough! Life saver for those with minimalist/budget lifestyle. More power to itsfoss! :clap:t4: :clap:t4: :pray:t4: :pray:t4:



Hi Rohit,
If it does not run you did not install it properly
What sort of an install was it? Was it an MX package?

Neville! Glad to see you!

Umm…I ran some commands I found online, don’t remember which one…

Would you like me to run some other commands and post the results here, for diagnostic purposes?

Just to clarify, I do see the easyeffects icon in the start menu, but clicking on it does nothing (except that processing wheel icon and then…nothing).

sounds like there are some missing dependencies. Always a risk when you install from outside the package system
If you can find where the binary is, do
ldd nameofbinary
It will tell you which libraries it needs

I don’t know how to do that…
Easyeffects was not listed in the MX linux package/software installation tools…so I ran that command…

OTOH, could you advise on how to uninstall pulseeeffects. At least that should work. Because this OS didn’t come with pulseeffects, I installed it, but seems impossible to uninstall it – odd.

I’m fine even if we’ve to remove all audio related stuff (drivers/engines/whatever) and do a fresh install.

if it is a package
apt-get purge packagdname
if it is not a package but has an icon
right click on the icon and you should get an uninstall option
you have to find its install script, and if you are lucky it may have an uninstall option
and if all else fails
track where it is in the filesystem and use rm

Not an easy business


Sigh…yes. True. Not an easy business at all.

I’ve tried that purge command; saw it somewhere. Purged pulseeffects using it and yet it is there.

But let me try more. Thx.


If everything fails to remove the software / changes you may to your system, you may have 2 other choices.
1 - Select a Timeshift restore point before the software was installed.
2 - Restore your OS from your last full system backup.

Good Luck.


@Rohit - just installed on MX 23R3 XFCE and with recommended packages and it works just fine!

Thanks for the tip! Didn’t know about this app. :slight_smile:

Audio: Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel bus-ID: 1-9.1:6 v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl chip-ID: 046d:0a8f class-ID: 0300 bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403 Device-2: Logitech H390 headset with microphone type: USB driver: hid-generic,snd-usb-audio,usbhid API: ALSA v: k6.1.0-10-amd64 status: kernel-api tools: alsamixer,amixer Server-1: PipeWire v: 0.3.65 status: active with: 1: pipewire-pulse status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl

1 Like

Thank you. Yes, this might work.


Oh! Wonderful.

a. How do you rate the audio quality on Pipewire/easyeffects? Most say it is noticeably better. Others don’t see much difference.

b. Most people are not so bothered about the audio quality and more about the 0.5 second lag between video and audio on a bluetooth headset/speaker, on pulseaudio/pulseeffects. How does Pipewire perform?

Update: Let me try MX Linux 23 now. It has wireplumber and pipewire by default. Great!


@Rohit - tough ones to answer!

Take a shot at your first question.

Given that i mostly listen to things via Firefox (or other browsers), with “Audio Equalizer” extension disabled: sound quality is good for music and talk videos. Would even say “improved” as same audio quality is equally heard in other browsers.

Will pass on second question.

Hope you found what you were looking for with MX Installer.

1 Like

Ladies and Gentlemen, I am glad to announce that my quest for a Linux OS with top notch audio quality has finally come to an end!!!

After @danielson made a post about MX 23 RC3 above, I learned that MX 23 is now officially available and comes bundled with Pipewire, Wireplumber.

I replaced the existing MX21 ahs with MX 23 ahs (officially released yesterday, 31-Jul-23) and checked for audio/playback quality on both firefox and VLC (with the compression settings for movies). I must say I am impressed and (never thought I would write this about a Linux OS!) the quality is a rank ABOVE Windows – it is unbelievable!

Connected my moderate budget 2.1 system with this laptop (via both 3.5 mm wired and bluetooth) and this is the best audio quality–even without using any equalizers–I’ve ever heard on a Linux machine. Looks like MX team/volunteers did a thorough job on this one. In fact, now I am not going to use easyeffects or any other equalizers. Highs, mids and lows are perfectly optimized just in tune with my taste.

Bluetooth has no lag/latency whatsoever! The channel separation and clarity is unmatched! Just wow! I’m hearing notes/instruments I had never heard so clearly before. :clap:t4: :clap:t4: :clap:t4: :partying_face:

Let me also share this news on other related threads. Thank you all @Daniel @nevj @easyt50

I tried it with Pop OS! too but somehow it didn’t have similar output.

Please do give MX 23 a try if you’re an audiophile.

[Tangentially, mutliple good news today; perhaps my days–rather years–of depression will finally come to an end; hope for the best]


Sounds like I need to do the same upgrade. … unless there are inline upgrade instructions.

Good on you Rohit


Had to look up that phrase; now I know the context/background better.


1 Like

Oh no, my Aussie slang is getting me into trouble again.
Cheers Neville

1 Like

Probably gets even more confusing when it’s contracted down to “onya!”…


@daniel.m.tripp Indeed – it is like you’re trying a new outfit and it looks good on you:slightly_smiling_face:

[Curiously, lots of great Aussie movies are rather easy to understan; Hmm… :thinking: ; on an even more tangential note, yesterday I was reading about the Westall UFO case near Melbourne – they landed beside a school in 1966! :alien: ]

Mods/Admin: How does one mark a thread as “[Solved]”? If you can, please do this one.

The owner of the topic can do it. You will find it in the … tools

On a related note, what does this mean?


Happens when I try to enable the option for loading easyeffects at the startup.

Should I run some command to eliminate this?