[SOLVED] Mint 19 GRUB Installation keeps failing


#1

Hey there,

I’m trying to install Mint 19 on my home theater PC with a 120GB SSD. It had WIndows 10 on it before and I wanted to wipe Windows completely and just have Mint 19 on it. I selected to erase disk and install Linux, but every time, it gets to the end I pops up the GRUB installation failed message. It doesn’t matter what I do, I cannot get this to work.

I tried pulling the SSD out, plugging it into my laptop with a USB enclosure. I then used GParted to erase all existing partitions and re-formatted the whole thing. Put it back in the other PC and tried installing. Again, GRUB installation failed. Don’t understand why this is happening… I’ve had Linux installed on this same PC before without issues (Ubuntu 17.04).

Any suggestions?

Thanks in advance.

System specs:
i3-4150
Intel HD graphics
4gb 1333 ram
120GB AData SP600 SSD
Gigabyte H87N-wifi mITX motherboard


#2

After attaching the SSD, run

sudo fdisk -l | grep -A 7 /dev/sd 

and post the output here.


#3

This happens every time I post a thread asking for help: I try all kinds of solutions, nothing works. I post a help thread and the very next thing I try works. Of course… -_-

lol, sorry. Admins can delete this thread or mark it solved.

I used this solution and it worked:


#4

Thanks for the reply, but I got it to work, finally.


#5

last time i asked, there was no official way for admins to mark a thread solved, (is that still so @abhishek?) but i think you can edit the title and just add or the like :slight_smile:


#6

i have totally done that too. tried all kinds of askubuntu answers and unleashed my limited terminal-fu only to have everything solved by a simple reboot :smiley:


#7

Yes, it’s still the same, unfortunately :frowning:


#8

no worries as far as i can tell. changing the title works too :slight_smile:


#9

Thanks everyone. Title updated. :wink: