(solved) No sound ! ! Ugh!

pulseaudio

#1

Was into binge watching “The Expanse” when half way thru S-2 E 6,
NO SOUND! UGH ! Went thru all the settings , deleted and reinstalled “alsus”, checked the wiring to the powered speakers…
All were good. I even did a restore from “Timeshift” from a day before this happened. System sees the sound card, but it just doesn’t emit sound. I ordered a sound card from ebay… will arrive 2/25…
Just have to wait it out…
Charlie


#2

not to be overly simplistic, but did you try to reboot? i had a similar issue with ubuntu mate once upon a time (i think that was with 16.04). not that rebooting every time is a great option, but it may point to some issue other than sound card.


#3

@cordx As a matter of fact, yes… Several reboots once each
for the deletion, and reinstall of “alsa”
a few times in-between, after changing sound parameter settings, and Timeshift did it once all by itself.
Rebooting… is in my blood!

Don’t know if you’ve ever seen it, but there was a British Comedy
called “The IT Crowd”(2006 -2013) about the trials and tribulations of a “Geek” squad of 2 (Chris Dowd, and Richard Ayoade) with a female IT Dept. manager (Katherine Parkinson) who knew only, how to turn on a PC.

One of the lines used for every pone call rec. was
“Hello, IT Dept. Turn off your machine. turn it back on then,
and CALL ME BACK”. Never giving the caller a chance to speak.
Being in IT for almost 14 years, This was such a kick for me!

If you’ve not seen the show…
The IT Crowd


#4

Hi does your sound switch to head phones, rather than system speakers ? Mine does after I’ve been viewing a video for example. It usually returns after a reboot. I am sorry I don’t know the answer to this, but it has been reported as a bug (as far as I know). I could not find any specific information on it anywhere. As I have a similar problem then I continue to look. It is less of a problem with 19.1 and usually the sounds usually return fairly quickly. As @cordx has said the only solution at the moment seem to reboot. Oh an OT, funnily enough I was watching the IT Crowd just recently on YouTube


#5

i did try the first few couple of episodes if i recall correctly, but the humor just missed me somehow. the turn it off and on definitely resonated with me because of my dear mom who would inevitably call in a panic about her phone or computer or tv and that method had a fairly healthy 90% solve rate.

i admit that i used to be better about rebooting myself as a windows user, but feel like linux (i use an ubuntu variant[-ish?] as well) deals with not doing so much better. i keep the uptime line in my ever-present htop window just to remind me when it gets past a few days.

a while back there was a thread about sound coming and going. if i recall correctly that was in ubuntu and was when i learned that pulseaudio interacts with alsa. again, i’m not a mint user and am on my phone so i can’t do as much research as i normally would before posting. i just wanted to add the bit about pulseaudio in case that is similar in mint.

in the thread i mentioned for whatever reason the solve was switching de’s. op had tried some different methods of working with alsa and pulse to no avail. after live booting a few different versions they found kubuntu did the trick.


#6

curiosity got the better of me and i did another search. the first link is about pulseaudio and mint. it is a bit dated (from 2015) but would seem to suggest that mint does also have pulseaudio in the mix with alsa. the second is an itsfoss article that offers some possible solutions.

https://forums.linuxmint.com/viewtopic.php?t=197204


#7

Nope! ** “Forcing an unexpected reboot” does not help…

** It Crowd solution"


#8

Well Here’s a good one… Today, I find the Volume icon missing from the task bar… Now, I cannot even check the sound preferences!

After reading the info on Pulse Audio [Thanks @cordx]
I said " Aww What the hey!"
and on a hunch, I reinstalled Pulse Audio, via Terminal. :fearful:
A reboot, and Voila! the icon returned…:innocent:

Bonus points : I now have sound again!

Still don’t know how / why, it disappeared, as I was just viewing an episode of The Expanse, when it happened. :woozy_face:
So now…I have an extra sound card to keep me company,
as I sit quietly facing the corner with this pointy hat…

Dunce


#9

once upon a time i was using audacity (an audio manipulation program) to do what i can’t remember and it froze my desktop. tried it again. same frozen desktop. mentioned it in the support forum (after promptly uninstalling and purging it from my system) and one of the developers (a musician) said he uses it all the time with no issue. sometimes i think it comes down to weird background library interactions. somehow something just gets wonky and we’re off to the races trying to get our stuff back in working order.

so as far as your extra sound card goes, we should start a collection with the new wifi adapter (a slight upgrade) i bought last year because all the online documentation i could find told me it would work in my machine. boot up to see something along the lines of “that’s not the wifi card you are supposed to have. make it go away!” and the os wouldn’t load.

we do the best we can with the information we have at the time. no shame in that as far as i can see :slight_smile:


#10

HAHA! that’s funny…
I too am a musician… Classic rock, Hammond Organ.

The funny part is I too, used “Audacity” and did it in Mint 18.3, recording our rehearsals, on a digital recorder, and playing back the mistakes, converted to an MP3, ( fewer arguments) attached to an email along with the musical corrections, for band members.
Retired from the scene, I haven’t played in a year and a half now…


#11

Yeah, No shame felt… this crap happens… But it’s funny after the fact,
even so!