[Solved] Stuck Item on Desktop Won't Delete


#1

There is an item that I cannot delete from my desktop that reads “voucher.jpg.crdownload.” I have tried to remove it, including direct action using the terminal, but it doesn’t show in the directory under terminal.

I am running Mint 19 Mate.

Can anyone clue me in as to how to remove this annoyance from my system?

Many thanks,

Steve


#2

This is a partial download from Google Chrome browser. Are you still downloading something with Google Chrome?


#3

No. I tried to download something that failed and this artifact was left afterwards.


#4

Could you go into more detail on

  1. what the error message is when you try to delete the file
  2. why/how it does not show up in the directory when using the terminal

?


#5

The error details are as follows: Error when getting information for file “/home/sfarber/Desktop/voucher.jpg.crdownload”: No such file or directory.

As to how it exists on the Desktop without an entry in the Desktop directory, your guess is as good as mine.


#6

Go to your Desktop, right click and select an option that should be called something like “Refresh Desktop”. On KDE Plasma this also works by pressing the F5 key.


#7

Thank you, Akito! The F5 key made it disappear.

I’d never seen this sort of thing before, and frankly, never hope to again. LOL!

Cheers!


#8

The terminal wasn’t lying, as it usually does not. GUI on the other hand… … …
The problem was that it looked like something was there, but it wasn’t. Kind of like a ghost. This can happen if something doesn’t refresh correctly. Probably it didn’t do that, because the download was interrupted unexpectedly, which lead to the absence of triggering e.g. any refresh.


#9

Your explanation sounds dead-on. The item became an artifact because “it fell through the cracks” as it were.

Your prompt assistance is most appreciated.

All the best!

 - Steve

#10

I have a similar issue.

Mint 18.3 MATE.

There is a folder on an external drive that I can not delete. I can go into it, make files there, which then exist and behave as expected, but can’t delete, rename, or move the directory…

Attempting to delete, rename, or move it gives me a “No such file or directory” error.

The permissions are 777 according to the terminal and I’m using sudo just to be sure.
chown and chmod fail silently as root, in that no error is thrown but no changes are made according to the terminal.

Any ideas?


#11

You should create a new thread for your issue, since it seems to be a different one.