Somethings's wrong with Steam install Ubuntu 22.04

Recent install of Kubuntu 22.04 single OS (no grub)
Computer Specs:
Operating System: Kubuntu 22.04
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.3
Kernel Version: 5.15.0-41-generic (64-bit)
Graphics Platform: X11
Processors: 16 × Intel® Core™ i9-9900K CPU @ 3.60GHz
Memory: 15.5 GiB of RAM
Graphics Processor: NV166

  • Software title | Steam
  • Software version |

I have tried unsuccessfully to install Steam 3x now. Resulting issue is I only have access to my library; all other options like STORE are greyed out and not working. Thought maybe the 1st time it was because I used the flatpak. Uninstalled/reinstalled with same effect after updating system.

Because there are 2 versions in Discovery I tried the other one. Same thing. Finally went into terminal and completely removed Steam, except logs. Tried using steam-installer in Terminal: would not install stating “manual installation” chosen. Tried choosing the installer from Dash and got message it was not a valid program. So I removed all of steam again (in terminal) and went back to the software center and chose the one that was not a flatpak. It installed–with the same issue: only library is available. After again removing it, I downloaded directly from steam and used the software installer QApt to install from the downloaded .deb file. Same thing.

I can select install/play games and it works fine. Just cannot do anything other than use my library. I can do account-related things from the upper right but cannot view notifications (greyed out) and the upper leftmost menus work, but they do not include the store.

I have used this game manager for years and have never had an issue with installing and certainly I can go to the store and purchase games from within the manager in Ubuntu.

Anything you need to help me resolve this conundrum let me know what and how to get it. I have a screen recording to show the issue in the current install of steam game manager currently running
Steam issue Kubuntu 22.04

Sorry - can’t help… I don’t use Kubuntu - but - my Ubuntu (Gnome 42) fresh install about 5 weeks ago - Steam just works, out of the box. I’ve got about half my library insalled to my SSD…

I never use software centre or whatever you call it - I do ALL my installs from the CLI - in this case I just went “sudo apt install steam” and it worked - I didn’t need to install anything or download anything extra. Sorry - can’t be of further assistance. I’ve nearly ALWAYS installed Steam this way… I remember some time ago it wasn’t part of the default APT repositories, and I’d download the DEB file from Steam, I nearly always hit snags then, mostly with some 32 bit libraries missing… But NEVER had issues in the last ~5 years or so by just going “sudo apt install steam”…

Thanks for trying, but after a completely fresh install, I figured it out: if you have family view set (with a pin setup to get out of it) it will not show the store. Stumbled upon this fix by going to “store settings” and it asked for my pin and VOILA–the store and other menu items went from greyed out to active. Sheesh, who knew. Reason this had never happened before is because I just set that option a couple of weeks ago for when grandkids are here and I have some games for them in Steam.

1 Like