Sony Bluetooth Stereo Headset


#1

So - one of my favourite bands is the US outfit Tool… so someone in a Facebook fan group asked for a recommendation for wireless “cup” over ear stereo headphones…

Someone recommended Sony MDR-XB650BT - I had a look at local retailers (Perth WestOz doesn’t have a lot of choice) and sure enough - JB-HiFi have them in stock… grabbed them (only $149)…

Only took ~4 hours to charge 'em up (and allegedly get 30 hours playback! My previous headset - Logitech H800 lucky to get 4 hours!) - and the sound was awesome compared to the Logitech headset on my Android phone (Galaxy Note 3.0 running Android 5.1.x)!

So - I tried 'em out on Ubuntu (18.04.1/2) - less than ideal fidelity! In fact pretty horrible! Watched a TV show last night, lotsa choppiness… Anyway - I’m working from home today - and the missus is watching that hideous Ellen Degeneres show (I don’t mind her [she’s great as Dory in the Nemo movies] - but I HATE the show, I hate chat shows and reality TV - and I detest the sound of her audience screaming hysterically - it actually physically nauseates me) - so I needed to drown it out - so paired the phones up again - and played some Tool - and it was coming out MONO! Now somethings sound okay in mono, if they were intended that was (e.g. some Beatles and Beach Boys)… Doh!

Did a bit of searching and found this URL :

Most of everything in there I already had… headset was pairing seemingly okay…

I just had to “sudo apt install blueman”, then “pulseaudio --k” (did it twice)… this unpaired the headset, then I clicked on connect in the Bluetooth applet/whatsit and now I got massive stereo bass imploding in my ears! Heaven!

(I really actually play a FLAC version through Sayonara Player :wink:)


#2

Have you checked itsFoss, I think there was an article on Bluetooth connection problems on there some time back. Sorry can’t remember when exactly.


#3

I couldn’t find anything about bluetooth audio on here, found few other posts about bluetooth - however my initial problem wasn’t necessarily bluetooth, as everything else was working, the headset was pairing, but giving awful audio quality - and - anyway - the gist of my post is that I had a problem, and a couple of simple commands fixed it VOILA! :smile:


#4

Thanks for the update. I have marked you post as solved as I saw it had not been done, saves you from doing so :smiley:


#5

I wrote that post “too soon”… it’s not quite solved…

Bit of a kludge / workaround…

Have to put the headset into Pairing Mode (keep holding power button down when powering them up) - then go into the Bluetooth “settings” and if they’ve already been paired, click on “Connect” several times till they connect - then they’re in Stereo mode… otherwise get choppy playback in mono only…

Just tested this on Ubuntu 18.10 on my work laptop - and the "kludge "works…

I think installing blueman and running “pulseaudio --k” were probably unnecessary and pointless, and it kinda looks like I’ve may have sorta “broken” bluetooth on my 18.04 laptop at home (few anomalies - and it created an additional app-indicator for Bluetooth - as well as the default one you get with Bionic)… Might just wipe it anyway and install a fresh 18.10, ready to go rolling release then upgrade to 19.04…


#6

Never mind, let us know how you get on. Sure you can’t that far away from the solution. Just a thought, it is just a pairing issue and have you tried the Sony Website help line? You probably have done the help line thingy, I mean, but in case you hadn’t might be worth a try.


#7

My most favourite band since ever.


#8

Mine too probably (Tool - Discourse removed my quote from @Akito) , I probably play them more than any other artist… my younger brother (deceased) was also a huge fan… He had his Harley’s license plate “46AND2” :smiley: . Only caught them live once (2011 Big Day Out). Catching up with mutual friend of my brother’s tonight, who’s also a huge Tool fan…

Anyway - as mentioned in my previous update - I have screwed up bluetooth on my home 18.04 laptop - tried removing blueman, but now I’m getting “bluez” errors… tried purging blueman (sudo apt purge blueman). I always kinda hate how sucky bluetooth can be in Linux… seemed to take ages to get proper pairing with BLE devices to work - and it was one of the reasons that made me jump back to Ubuntu from dabbling in elementary… might be different now that Juno is Ubuntu 18.04 - but last time I tried it (Juno - about 3-4 months ago, then again about 6 weeks ago) - I found it too limiting and nazi controlled :smiley:

So - anyway - I found this fix (which probably would have worked on my home 18.04 if I hadn’t install blueman) and successfully did it on my work 18.10 laptop : https://gist.github.com/pylover/d68be364adac5f946887b85e6ed6e7ae

e.g. :

[[ ! -d ~/tmp ]] && mkdir ~/tmp
cd ~/tmp
git clone https://gist.github.com/pylover/d68be364adac5f946887b85e6ed6e7ae
cd d68be364adac5f946887b85e6ed6e7ae
cp ./a2dp.py ~/bin/.
cp ./fix-bt.py ~/bin/.
cp ./fix-bt.service ~/.config/systemd/users/.

There’s no “how to” info (there’s no proper reader friendly readme.md either) - but lots of comments with snippets of how to deploy this solution.

So I put/copied the a2dp.py file in my ~/bin (which is on my $PATH). I also put the “fix-bt.py” in the same dir.

Run the a2dp.py script and pair your headset (note the MAC address).

Then I copied the fix-bt.service file into ~/.config/systemd/users.

The fix-bt.py and the fix-bt.service file require a teensy bit of tweaking.

fix-bt.py
Point the A2DP variable at the location of the a2dp.py script
e.g :
A2DP = '/home/x/bin/a2dp.py'
(where “x” is my username)

Point the DEV_IDS variable at the MAC address of your device :
e.g. :
DEV_IDS = ['00:18:09:D4:44:D9']
(MAC address of my Sony device)

Edit fix-bt.service
Set location of fix-bt.py script :
ExecStart=/home/x/bin/fix-bt.py

Set “WantedBy” to :
WantedBy=default.target
(so it can run as a “user” systemd service)

Then enable the service :
systemctl --user enable fix-bt.service

Then start the service :
systemctl --user start fix-bt.service

Now I just power up the headset - and pairs, everytime, in Stereo!

Also - super cool feature with these headphones - the track controls button works with Sayonara (doesn’t work with my Logitech headset, or el cheapo “QUDO” or my ancient Motorola S305 BT headset).


#9

i had for the most part written bluetooth off (my distro is ubuntu-based as well) because neither blueman nor bluez ever worked very well at all. i have just kept my speaker plugged in. i can’t imagine that would be as acceptable a solution with headphones. i may give this method a go. thanks for sharing your research.

do you want to (or mind if i do) switch the solution marker to this last post since the one above didn’t last?