System hangs at reboot/shutdown

#1

Hi altogether,

after performing a clean install of Lubuntu 18.04.2 LTS, 64 bit, I experience shutdown/reboot problems. The system hangs at a specific point.

After deactivating plymouth (“noplymouth” instead of “quiet splash”) I was able to find out where the system hangs.
The last entries are as follows:

systemd-shutdow [1]: 12 output lines suppressed due to rate limiting
systemd-shutdown [1]: Syncing filesytems and block devices
systemd-shutdown [1]: Sending SIGTERM to remaining processes
systemd-journald [284]: Received SIGTERM from PID 1 (systemd-shutdown)
systemd-shutdown [1]: Sendig SIKILL to remaining processes …
systemd-shutdown [1]: Unmountig file systems
EXT4-fs (sdc1): re-mounted. Opts: block_validity,barrier,user-xattr,acl,errors=remount-ro
systemd-shutdown [1]: All filesystems unmounted
systemd-shutdown [1]: Deactivating swaps
systemd-shutdown [1]: All swaps deactivated
systemd-shutdown [1]: Deactivating loop devices
systemd-shutdown [1]: All loop devices detached
systemd-shutdown [1]: Detaching DM devices
kvm: exiting hardware virtualization

So the kvm thing seems to be the culprit.

Does anyone know what to do?

The whole thing is a bit odd as I have a pristine system and everything should work perfectly.

Greetings.
Rosika :neutral_face:

1 Like
#2

@Rosika,
I don’t know how to help you but this might be the bug you are getting?
kvm: exiting hardware virtualization" on AMD servers with DVD

1 Like
#3

@ Tech_JA
Hi,
tnx a lot and sorry for the belated answer.
Yes, the link you provided refers to the very phenomeneon I encounter.

In the meantime I use the command
shutdown -H -P +0
to power down my system. This at least works without any difficulties.

Greetings.
Rosika :wink:

2 Likes
#4

Hi Rosika
Have you tried the repair option when you reboot? if you get the advance options and try a repair from there. I am almost certain I saw this on its Foss by @abhishek as I learnt how to do it from it although I use mint it worked

1 Like
#5

Hi,

Have you tried the repair option when you reboot?

Not sure how to do that. Sorry.

Rosika

1 Like
#6

When you re-boot make sure you have your USB or CD in (whatever you used to install) then press f2 and boot from that. Rather than install, go to the 2nd second option down and press to enter it -

this shows 18.3 but don’t worry it is the same thing. When it has done it’s job all being well it should be okay for you. If not come back and we’ll see what else you can do

1 Like
#7

Thanks for the explanation.
So if I understand you correctly I have to boot from my installation medium and then select the second option (compatibility mode).
Yet I´m not sure as how this does anything to my installed system.

Greetings.
Rosika

#8

Rosika
What it does it checks that is installed correctly shows everything is okay or has a problem. Please don’t quote me on this, if you know understand that what that means. By using this method I have in the past and have found any problems have been corrected as a result. You could also take a look here to see if anything here helps. https://easylinuxtipsproject.blogspot.com/p/1.html
As I have to repeat I have used the above and in my personal experience it has worked. The main advice that I always give because it is works is once your Mint is set up then do a TimeShift which is similar to a system restore, because if you have a problem then you can always take it back to the time before it happened

#9

Thanks for the explanation.

Yes, good advice. Although I prefer clonezilla for backup purposes. In fact I perform a system-backup once a month. But I think that´s rather a matter of personal taste. :wink:

Thanks also for the link you provided. I´ll look into that.

Greetings.
Rosika

2 Likes
#10

Probably some incompatibilitie with the kernel
and your hardware.
Make a shell script with: shutdown -H -P +0
for shutdown your PC.

1 Like
#11

@76ron:
Thanks for the suggestion. Sounds good.

Greetings
Rosika

1 Like