ThinkPad X220 install (Solved)


#1

Hi, I’m new,

I met Ross (ASULUG) at HeatSyncLabs party and he suggested a ThinkPad X220 because its easy for hardware and has an open source bios. He also said many people had one, so naturally that was the convincing reason I bought it. People with experience! :slight_smile:

I just got mine and Im wanting to install Ubuntu 18.10 from a flash drive.

F12 give me 2 options but neither is flash. However maybe I can use the PCI LAN option,
but I’m unfamiliar with how to do that. Is there an article/archive that I’ve missed that might tell me how to do that?

Or how do I fix the bios to give me the option in the bios for flash device bootup?

Here are my specs:

Lenovo ThinkPad X220 Tablet Intel i7-2620M 2.70Ghz 8GB RAM 128GB SSD

F12 gives me:

ATA HDD0: SAMSUNG SSD PM830 2.5" 7MM 128GB
PCI LAN: IBA GE Slot 00C8 v1366

I really appreciate the help,

Steve


#2

have you tried going in to your bios and changing the boot order so it just boots the usb first and you can avoid f12? i had a computer earlier that just kept ignoring f12 and that option helped :slight_smile:


#3

Oh, I thought f12 was taking me into the bios.
F12 gives me the boot order options, but flash drive is not one of them.

I’ll look into how to open the ThinkPad bios. Maybe I’m only opening the boot loading order. :roll_eyes:


#4

f12 for my thinkpad just takes me to the boot order screen. i have to hit enter (i know it is different on other machines) to get into my bios. my older thinkpad has a conspicuous blue “ThinkVantage” button that i use :slight_smile:


#5

if i have the right model, this one says you press f1 to get into what they call ThinkPad Setup:


#6

Yep, F1 got me into the bios, however when i move into the startup menu, the option of:
‘Boot device List F12 Option’ only allows me to disable or enable it. What I want is to have a Flash Drive option added to the only two options in there currently, which are:

ATA HDD0: SAMSUNG SSD PM830 2.5" 7MM 128GB
PCI LAN: IBA GE Slot 00C8 v1366

So I’m not sure if thats even possible at this point. :roll_eyes:

Thank you for the pdf I’ll look that over.


#7

according to that pdf, you select “Boot”. then press enter. that should give you a Boot submenu that lists all of your possible boot devices. on my thinkpad, usb hdd is like number 5 or 6. i have to use the arrow keys to get down to it and then it is highlighted (white text on my machine). i then use the + key (above =) to move that to the top of the list.


#8

Is it UEFI or BIOS?


#9

Entering what I think is the bios via F1, and then going into the startup menu, the second option down is UEFI/Legacy Boot which is set to Both. I could also set that to UEFI Only or Legacy Only.
The third option is UEFI/Legacy Boot Priority which is set to Legacy First.


#10

Is the HDD you want to install Ubuntu on, GPT-enabled?


#11

I have no idea, I just got it from newegg. How could I check?


#12

in Config menu there is a Serial ATA (SATA) which is set to Compatibility but could be set to AHCI. Other than that I can not find a place in the bios to set that specific option.


#13

WOOT! I got it.

Turns out if you in the startup menu, the second option down is UEFI/Legacy Boot which is set to Both and when I changed it to Legacy only, and then restarted and hit F12, I was then given the option to boot from the flash drive. ISSUE SOLVED, thank you for your help!!!

Steve


#14

That doesn’t make sense. If “Both” were enabled, then everything should show up, not only the UEFI devices. Well, at least this is another point for how buggy CSM is.


#15

Well I would have to agree with you on that. It doesn’t make sense, but right after I pointed it out in the office my most senior developer told me he remembered that, that was a problem years ago, with these older machines, so ya, bug. Ugh, but at least we figured it out, and now it’s here to be part of the archives so others may not have to go through the same amount of time trying to solve it. Again, thank you for helping me with it, i have to give you credit because I just started trying things after your UEFI question. So now on to the next linux stumper! :rofl:


#16

congratulations on the solve :slight_smile: i know it isn’t the best idea to change a whole lot of bios settings all at once, but i have learned that one of the best ways to figure out what they do is to change one to see how it affects your machine.


#17

also agreed, but i have read in other threads or comments that this particular bios setting doesn’t always act like it should. i think until all machines are strictly uefi, there will be this need for workarounds and whatnot :slight_smile: