Top bar too small, chrome and firefox render mismatch

I consider myself a n00b in Linux and have recently moved to Ubuntu 18.04.2 LTS. I have integrated Intel graphics on my machine. My Ubuntu top-bar and its fonts are extremely small when compared to regular window titles and rest of the system fonts. I have install gnome-tweaks and have the fonts at size 11 which is normal, as well as have the scaling factor at 1.0, again normal. I have a feeling I may have messed up my graphics settings and have no idea how to fix it, any help or guidance is really appreciated. Please help. This is really annoying me as fonts are too big on Firefox and the power button on the top bar is too small to even look at for the normal eye.

A few relevant settings for context: Please do ask me or enlighten what else to look for to debug this issue better.

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Desktop)

$ xrandr --listproviders Providers: number : 1 Provider 0: id: 0x4a cap: 0x9, Source Output, Sink Offload crtcs: 4 outputs: 7 associated providers: 0 name:Intel

$ xrandr -q
Screen 0: minimum 8 x 8, current 5120 x 1440, maximum 32767 x 32767
DP1 connected primary 2560x1440+2560+0 (normal left inverted right x axis y axis) 550mm x 310mm
   2560x1440     59.95*+
   2048x1080     60.00    24.00  
   1920x1080     60.00    50.00    59.94  
   1920x1080i    60.00    50.00    59.94  
   1600x1200     60.00  
   1280x1024     75.02    60.02  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08  
DP2 connected 2560x1440+0+0 (normal left inverted right x axis y axis) 550mm x 310mm
   2560x1440     59.95*+
   2048x1080     60.00    24.00  
   1920x1080     60.00    50.00    59.94  
   1920x1080i    60.00    50.00    59.94  
   1600x1200     60.00  
   1280x1024     75.02    60.02  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08  

$ lshw | grep -A5 "Motherboard" 
description: 
  Motherboard product: 00CV7F
  vendor: Dell Inc.
  physical id: 0
  version: A00
  serial: /6KN6BT2/CNFCW008BS00KQ/
2 Likes

i don’t have ubuntu proper, but use ubuntu mate and with mate the top bar is called the panel. i think the link below may help. there is a section about changing the panel appearance. i believe you will get a menu if you right-click on the panel itself and somewhere in that menu should be an option to change the physical size.

https://www.techotopia.com/index.php/Configuring_the_Ubuntu_Desktop_Panels

3 Likes

I’m Assuming your using gnome desktop with Ubuntu if you are thenthis link will help.

3 Likes

your link points back to this page :slight_smile:

1 Like

Thanks cordx corrected :slight_smile:

2 Likes

@cordx & @kc1di I have already tried installing the gnome tweaks tool, but everything seems normal to me there: Window title (Ubuntu 11) Interface (Ubuntu Regular 11). Also the scaling factor seems to be nominal at 1.0. But still the top bar is way too small. Any other thoughts ? Would a bad graphics driver cause this ? or bad X window settings ?

2 Likes

did you try right-clicking on the top bar (panel)?

1 Like

Yes, I did and it doesnt give me any menu to choose from. I am running Bionic with Advaita-dark theme.

2 Likes

Hi @pufl and firstly welcome to our community. I don’t have any direct experience with Ubuntu as I use Mint so really can’t help with this. However I had a thought that you might find something here that might be able to answer your question for you. https://easylinuxtipsproject.blogspot.com/p/every-distro.html

The only other suggestion I really have is to search the It’s Foss site or maybe @abhishek has an answer for you. Sorry I can’t help further

2 Likes

have you tried changing the scaling factor? the only difference between the two screenshots below is changing the scaling factor from 1.0 in the first to 1.75 in the second and the top bar is quite a bit easier to see at 1.75. at least for this old man’s eyes :face_with_monocle:

2 Likes

I did try that, but increasing the scaling factor is increasing the font size across the board which is not desirable for my situation. Also what doesnt make sense to me is that Firefox and Chrome running on the same host render themselves very differently. I am attachign a few screenshots for reference

1 Like

More context of how small it is:

i realized that once i restarted firefox. many things were just too big. normally i have to increase page sizes individually, but with that scaling i had to decrease them.

for what it’s worth, i don’t believe you messed anything up or that your native settings are a problem. i spent over an hour poking around ubuntu on a live usb as well as running various web searches for answers and couldn’t get much done with that particular setting.

i have a couple more thoughts. the first may yield similar results to changing the scaling but is quickest to check out. ARandR is a gui front-end for xrandr and can change your screen settings to see if that may be of help.

one of the reasons that i mention this is that on my regular laptop (running bodhi linux 5.0 which is based on ubuntu 18.04) the settings are 1600x900 60 and everything is easy enough to see, but i had to do a lot more adjusting with fonts and scaling to get things there. on my 32-bit laptop (also running bodhi 5.0) the resolution is 1024x768 60 and things are just easier to see.

the other thought is checking out @abhishek’s post about customizing gnome. it also mentions gnome extensions like @kc1di did above. i did notice that many images on the itsfoss post have a top bar that looks tiny like yours.

2 Likes

Let’s try and solve one problem at a time.

From what I see in the xrandr output, you have two WQHD monitors connected. Do note that HiDPI support on Linux is still not mature and this is why you are having this much of trouble.

You can do a few things here.

First Method:

First is to rely on the fractional scaling. For now, you can only have 100% or 200% scaling and they are not going to help. Since X display server is default in Ubuntu 18.04, you cannot enable fractional scaling.

What you can do is to change the display server to Wayland. Log out and on the log in screen, click the user and then click the gear sign. You should see an option of “Ubuntu on Wayland”. Select this and log in to your system.

Once you are using Wayland display server, you can use this quick hack to enable fractional scaling. I believe a scaling factor of 1.25 should be good.

Second Method:

The other way is to use GNOME Tweaks and change the font size. It’s not the best way but it does make things a little bit better.

Restart your system after making the changes in both cases.

Once you are satisfied with the system wide display, we can discuss the browser render problem afterwards.

3 Likes

Hello @abhishek, thanks for the reply. I now am running Wayland and is at 1.5 scaling factor, which is satisfactory. I say satisfactory because the 1.5 scaling factor makes my chrome default resolution to make the font look too big to my taste, so I had to default back to 80% zoom than 100% to stay at a font size that I am comfortable with.

That said, the scaling factor made my top bar font look better visible to the normal naked eye.

This still doesnt solve my Firefox vs Chrome render issue as you’ve mentioned in your closing reply. Please guide me on what to look for and what might be causing the mis-match. Also something odd that I have noticed is that I also dont seem to be missing system icons to basic services like Terminal (it shows me the purple gear icon) which I thought might be worth mentioning.

1 Like

Sorry for my late response. I typed my reply the other day and my network disconnected and later I switched off my computer and then it skipped me for I have been busy.

So, the font size mismatch could be because you have tweaked way too many things. I wonder if you would reset things and then enable fractional scaling again.

Here’s how to reset GNOME: https://www.omgubuntu.co.uk/2017/10/how-to-reset-ubuntu-desktop-to-default

And then later on, enable fractional scaling once again. If the fonts are still of different size, maybe you can change the font settings in both the browsers individually. Not the cleanest fix but if it works, why not.

3 Likes

@pufl Instead of adjusting the page zoom in Chrome, you can go into the settings and adjust font sizing separately. Perhaps adjusting this in combination with using 1.5 scaling factor might do the trick?

2 Likes

@abhishek @MikeREM That did it. There is still a very slight mismatch between chrome and firefox, but very subtle…I can live with that, thanks a lot for all the help :slight_smile: really appreciate it!

3 Likes

I am glad it’s finally in an acceptable condition now :slight_smile:

Thanks @MikeREM for your help.

2 Likes

Glad we could help. :slight_smile:

1 Like