Trouble writing OS img to SD card

#1

Hey all,

So I’m attempting to install Manjaro LXQT ARM on my Pinebook using the “dd” command to write the .img to a microSD card. It appears to work, say’s X MB of data written, but then when I check the SD card using Gparted, it shows the partition/volume as “unknown”. And when I reboot the device, it does not boot to the SD card as it should if the img was written properly.

I’m not sure what the issue is. The SD card is large enough (8GB), though I need to buy a new one now as I’m pretty sure I bricked the card (won’t format anymore).

After some searching, I’ve only found some conflicting information as to how the card should or should not be formatted prior to writing. I successfully wrote to this SD card just recently when I installed DietPi on my Pi2B not long ago, so I’m not sure why it’s not working.

Thanks in advance for any help/suggestions.

0 Likes

#2

Ok, well, I’m an idiot… :expressionless:

The img file I downloaded is an .img.xz which I did not know nor realize was a zipped file. I unzipped it using the “unxz” command and will give this another try with a new SD card. (fingers crossed).

This might have seemed obvious and simple to many, but I’m still learning… lol :flushed:

4 Likes

#3

Experience is the best teacher, Mike :slight_smile:

4 Likes

#4

Ok, it’s still giving me grief. New SD card, tried writing the proper (unzipped) img to the card and it took a bit longer this time. I assumed that meant it was maybe working this time. Nope.

In Gparted the SD card shows up as “unknown” partition/volume, after the write process, and the device is not recognizing it as bootable…

I’m following the installation instructions outlined here: https://forum.manjaro.org/t/manjaro-arm-19-03-for-pinebook-released/79440 except I’m using dd in CLI instead of etcher, but it’s not working for some reason. I’m not sure what to try next…

Will keep searching for solutions.

0 Likes

#5

I might have figured it out… Crossing my fingers…

0 Likes

#6
  1. Use a new or definitely working SD card. Recommending Transcend. 1 microSD card sized 32GB costs about ~$8 (probably less) and its the best you can get. Recommending against SanDisk.

  2. Use Etcher. This is the best for this specific operation. It was specifically made for this and if you don’t fiddle around with dd, as you seemed to not have done, then Etcher is definitely better.

1 Like

#7

Thanks for the advice/tips. I’ve used dd successfully before (when writing dietpi to an SD), so I expected it to work here as well.

One mistake I fixed was I was writing to /dev/mmcblk1p1 when I instead should have been writing to /dev/mmcblk1. After trying that, I got some success; it actually booted from the SD. problem is there were issues and errors popped up stating there were things missing and it wouldn’t go any further.

I re-downloaded the img.xz and ran the sha256sum check to confirm it was good and it is. I’m trying again using dd now and if it fails again, I will try using etcher as you suggested. I didn’t know there was a version for Linux, thought it was only Windows for some reason… Always learning. :wink:

1 Like

#8

Yes, dd is usually used to write to the entire drive instead of just a partition. Especially, when writing images.

0 Likes

#9

Success! I got it to install properly. Only problem is I accidentally selected spanish language locale instead of canada/english. So now I have to re-write to the SD again and re-install. Hopefully it works again.

I tried resetting the locale, but it didn’t keep the changes after a reboot and I’m not sure I even did it right as I can’t read spanish (barely), lol.

What a fun learning experience this has been, lol. :stuck_out_tongue:

2 Likes

#10

Might have to step away from this for a day or so before I pull my hair out… This should be a relatively simple procedure from what I understand.

After re-writing to the SD, it now hangs during boot and the screen goes black with no response.

I then decided to try etcher and use my laptop to write the img to the SD (there is no ARM version of etcher). Downloaded etcher and figured out how to install the etcher AppImage (there’s no instructions for this that I could find on etcher’s website). The application runs and opens, but then crashes when I click the “select img” button. Returns some kind of gtk error message, which when I tried a workaround solution I found for that, it still doesn’t work.

Tried writing using dd from the laptop, same thing; Pinebook starts to boot from the SD, screen goes black, no response. The checksum was good on that downloaded img as well. So there shouldn’t be any issue.

So I’m back to trying dd with the pinebook to the SD as I had more success with that previously. Glad these microSD cards are cheap, in case I brick another… :pensive:

Question; do I have to reformat the SD after each attempt, or can I just try re-writing without formatting, and it will just overwrite the current data on the SD?

0 Likes

#11

Finally, it’s working!!! :slight_smile: Now to figure out why I can’t edit network/wifi settings/connections…

1 Like

#12

The reason why dd and its derivatives are so famous is because they clone an image or file bit by bit. (This is also the reason why it is specifically called cloning instead of copying.) Therefore, it doesn’t matter how the image is formatted or what data it contains, because dd will just overwrite every bit needed, without excuses.

0 Likes

#13

Ah, good to know. Thanks. That will save me some time if I have to do this again (and I will, knowing my distro-hopping tendencies, lol). :wink:

0 Likes

#14

When using dd command, not format the partition
and yes the dispositive such: /dev/mmcblk1p1
p1 is a partition ( not correct ) !!
/dev/mmcblk1 ( now is correct ) as your friend Akito spoken. :roll_eyes:

1 Like