TTY gives invalid login (Work around found)

#1

Greetings!
When using Ctrl-Alt-F1 to get a tty1 screen, my login/password comes up invalid.
I had this problem several releases ago and fixed it but I can’t remember how.
I’m currently running Linux Mint 19.1.
Any ideas?
Thank you!
Jim

1 Like
#2

I don’t know if these suggestions here will help at all. https://forums.linuxmint.com/viewtopic.php?t=264982 - If I run into such problems I usually just do the repair option which works most of the time. I have seen this problem with Ubuntu mentioned (not that I use it as I use Mint 19.1 now) so it might be worth checking on their forum to see if there is answer you can use, taking that Mint has a Ubuntu base.

2 Likes
#3

Thanks Ellan.
I didn’t see what I needed there. I’ve done the usual Google searches but couldn’t find where to set/reset the login and password for tty mode.
(I don’t even want to use tty mode. My PC hung and was relatively unresponsive so I did the CNTL-ALT-F1 to get to a terminal where I could reboot or run a kill. I got to tty mode and couldn’t login.)
Thanks for looking at it!
Jim

1 Like
#4

ps. I found this https://www.wikihow.com/Change-the-Root-Password-in-Linux which describes using ‘passwd’ in the terminal for setting the UNIX password but it still didn’t work.

1 Like
#5

Just seen this - it might help. It was written for Ubuntu, but as I said earlier Mint in based on that and so it should work https://www.ostechnix.com/how-to-fix-broken-ubuntu-os-without-reinstalling-it/

1 Like
#6

Those instructions have you go to a tty (terminal) and login to issue commands. My problem is that I can’t login. Actually, after rebooting my system seems fine and I don’t want to restore anything. The fix I once used to be able to login to a tty is so far back (as far as releases) that I don’t want to restore.
Thanks for looking!
Jim

2 Likes
#7

Do you have different keyboard languages or layouts? If so, try toggling through those. I have three and had login problems that were solved by doing that.

2 Likes
#8

Just English. That language is hard enough for me. :wink:
Thanks Cliff.

1 Like
#9

I have no problem with my password using a ‘regular’ terminal. It’s just the tty terminal logins.

#10

Actually Cliff, your suggestion helped find my problem! I tried switching to tty and, at the login prompt, I keyed my password (which contains numbers) instead of my user-id. I did this so that I could see my password displayed. I always use the numberpad on my keyboard (with the Num-Lock on). The numbers showed up as ‘funny characters’ - like control characters - instead of numbers. When I use the ‘regular’ numbers on the keyboard, the numbers show up correctly and I was able to login!
I then tried switching to tty and, even though the Num-Lock was on (and lit up), I turned it off and on again. Now I was able to login using the numberpad! Weird! I guess switching to tty mode doesn’t recognize the current state of the Num-Lock and then mis-interprets the numbers as things like 'PgUp", arrow keys or whatever.
(Don’t know that it’s an actual ‘solved’ problem but, as long as I remember what to do, it works. Guess I’ll mark it solved since there is a work around.)

THANKS TO ALL OF YOU FOR YOUR HELP! Jim

1 Like
#11

That’s an ancient bug persistent between distributions. If you have Numlock enabled on desktop and switch to console only, you have to press Numlock 3 times, to activate it properly again to be used in console only. I already anticipated this issue and wrote the first reply explaining that before I had to leave the computer and now I notice that I forgot to press the reply button. Well.

3 Likes
#12

Thanks Akito!
I was sure that the last time it came up I had found a real fix but…
Now the problem will only be getting my ancient brain to remember the ‘3 times’ the next time it happens. :wink:
Jim

2 Likes