Tweaks in elementary 6

I tried to install tweaks in my Elementary 6 OS. However, it couldn’t be installed. The result is given below.

anupammitra@VirtualBox-0b432532:~$ sudo apt install pantheon-tweaks
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt –fix-broken install’ to correct these.
The following packages have unmet dependencies:
elementary-tweaks : Depends: libgranite5 (>= 0.2.0) but it is not going to be installed
E: Unmet dependencies. Try ‘apt –fix-broken install’ with no packages (or specify a solution).

Kindly advise the next course of action. In absence of Tweaks, I can’t minimize the screen.

Dumb question, but : did you do what it suggested ???


sudo apt --fix-broken install

sometimes the answer is punching you in the face, and you still don’t see it…

And how does elementary tweaks help you minimise the screen anyway? Which screen? You’re running it in VirtualBox right? Are you sure it’s tweaks you need, and not VirtualBox guest additions?

1 Like

I guess, @daniel.m.tripp is right.

Thanks for your reply. Yes, I did what was suggested. The command was given with root.
Yes, I’m running Elementary in VirtualBox and VirtualBox Guest Additions has also been installed rightly. I need Twekas because minimizing of windows is not available in Elementary by default. I only see a button to close a window and one to change the size. In Elementary 5 I fixed it through Tweaks. But in this new version of Elementary, I failed to install Tweaks/Pantheon Tweaks. The outcome of fixing broken is given below.

anupammitra@VirtualBox-0b432532:~$ sudo apt --fix-broken install
[sudo] password for anupammitra:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Correcting dependencies… Done
The following additional packages will be installed:
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/167 kB of archives.
After this operation, 650 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database … 119889 files and directories currently installed.)
Preparing to unpack …/libgranite5_5.3.0-1_amd64.deb …
Unpacking libgranite5:amd64 (5.3.0-1) …
dpkg: error processing archive /var/cache/apt/archives/libgranit
e5_5.3.0-1_amd64.deb (–unpack):
trying to overwrite ‘/usr/share/metainfo/granite.appdata.xml’,
which is also in package libgranite-common 6.1.0+r2071+pkg119~ub
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Did you ever hit this page :

(different PPA in odin than in previous eOS releases)

Yes I did it yesterday. I have communicated the difficulties, which I faced, to Abhishek Prakash, creator of It’s FOSS, for his knowledge and support.