Ubunto boot stuck

Dear All,

The ubunto 20.04 LTS gets stuck at the start up. I was trying to install R Studio and the installation was complaining about the missing libcrypto.* I tried to install R-studio and missing dependencies but ended up in a boot stuck.

Error Message: /sbin/init: /lib/x86_64-linux-gnu/libc.so.6: version GLIBC_2.33 not found (required by /libx86_64-linux-gnu/libcyrpto.so.1.1

Any help would be appreciated.

Welcome Khan,
The message means that libc is a dependency of libcrypto and that your Ubuntu20.04 does not have the right version of libc… it has to be version 2.33 or greater.

The easiest way to get a more recent version would be to upgrade your Ubuntu to Ubuntu22.

I use R, but not Rstudio.
One question… were you trying to install Rstudio using the package system of Ubuntu20? That would be the safest way to do it, and you should get a version of Rstudio which is compatable with the libraries provided in Ubuntu20.
If you download and install some app like Rstudio outside of the package system, then you are always likely to incompatabilities with library versions. The package system protects you from that.


1 Like

Hi Neville,

The problem is that the kernel is stuck and I don’t have any access to the terminal. Should I update it via live Ubunto 22 USB? Is there any way to jump start the system with Ubunto_20 bootable USB?

I was trying to install it using the *.deb downloaded from the RStudio wepage.

You can boot it with any live USB. Trouble is what to do then. You could mount the root filesystem, for example, but knowing what to delete is difficult. Before you do anything make a backup of any important user files that you would not want to lose,
The error message comes from init so it is past the kernel stage and starting processes… probably starting Rstudio.
So we want to try and stop it starting Rstudio. Here are 3 guesses at what might work

  • find where Rstudio binary is installed and delete it (or more safely rename it).
  • go to /etc/init and delete anything related to Rstudio
  • does Rstudio have a daemon? It must if init is starting it.
    here is some info
During installation RStudio is automatically registered as a daemon which starts along with the rest of the system. The exact nature of this will depend on the init system in use on your system:

    On systems using systemd (such as Debian 7, Ubuntu 15, and RedHat/CentOS 7), this registration is performed as a systemd script at /etc/systemd/system/rstudio-server.service.

So the daemon is called rstudio-server. See if you can find that in /etc/init and delete it

The whole idea is to get rid of this attempt by init to start Rstudio.
Then it should boot.
Then when it boots you can uninstall Rstudio with dpkg --purge Rstudio

I was trying to install it using the *.deb downloaded from the RStudio wepage.

Dont do it that way again. Use the Ubuntu package system to install Rstudio. Then it will be compatable with Ubuntu20

If all this fails, I would do a backup of your important user files, then do a fresh install of Ubuntu22.


You might try booting it in recovery mode. Then you could login as root, and just uninstall Rstudio with dpkg --purge Rstudio


What I would try now here, to boot from a live USB. Then mount system partition to /mnt for example. Then chroot into it.
Would try to purge (remove) rstudio, then do an autoremove.

Exit from chroot, unmount, and try to reboot.
I bet @Khan dowloaded R-studio for Ubuntu 22. The correct version -I think- would be to downlad R-studio for Ubuntu18+/Debian10+.


That should work on Ubuntu 20.04.

1 Like

@Khan ,
Try what @kovacslt advises.
I think it is a better option than what I put forward.

Thank you @nevj and @kovacslt for your help and valuable suggestions.

@kovacslt: I downloaded the R-Studio for Ubunto-20 i.e. for Ubunto18+/Debian10+. I just had a look from grub prompt in the /Download directory, I have this *2022.07.2-576-amd64.deb file present in the downloads.

Okay. Let me try this proposal and I will come back to you.

@nevj: How can I create a backup, I don’t have access to the command prompt? No? The boot loader is stuck, right after the start up.

1 Like

Are you sure?
Note, that the filename is the same for Ubuntu 22:

The download URL differs, note the “bionic” in my link, and “jammy” here.
The .deb packages are different. Based just on the filename it’s impossible to tell which version you really downloaded. Also checking the hash would tell surely, which you have, the filesize gives a hint too.
But no problem if I’m wrong, it’s not unusal :smiley:

But get back your problem.
There are some practices, youprobably don’t know yet.
If you did not use a filesystem encryption, accessing your data on your damaged Linux installation is fairly easy.
First, boot up live USB!
You will get a fully working environment, you’ll be able to mount partitions, disks on your system. You can use the filemanager of the liveUSB to mount any partition on your computer, be it on the on the built-in SSD/HDD, or on a just attached external HDD.
Just browse the contents of the folders, do copy/paste (preferably from source to destination :slight_smile: ).
Your data you might want to backup is stored in your home folder. That’s something like /home/your_username/, so look for a derictory called your_username under a “home” diretory.
So backing up your data is not more difficult, than copy files and dirs from a disk to another. Just substitute your_username with your actual login name on your installed system.

Maybe this video shows some of the basic ideas

Regarding making your system bootable, as I mentioned, I’d chroot into it.
Now I try to give some hints to that:
you have your liveUSB booted up.
If you mounted some partitions, disks using the filemanager, unmount them.
Start a terminal (ctrl-alt-T usually does this).
Get root, to avoid to having to type too many ‘sudo’ commands, I’m awfully lazy, so I always do this. So in the terminal:
sudo su
I assume, you already know where’s your system installed. I mean disk and partition. For the simplicity let’s say it’s sda1. It’s the first partition of the sda disk.
I would mount it to /mnt, so in the terminal:
mount /dev/sda1 /mnt
So if you know cd to /mnt, you’ll see the contents of your system partitions.
If you have it on a different disk or partition, substitute /dev/sda1 with your actual values.
I’d try to chroot into that installed system, that basically means, any commands do things on the installed system, changes made via apt remove affect that installed system. So in the terminal:
chroot /mnt
You’ll get a root shell, and whatever you now, you do it with your installed system.
I’d try to remove rstudio packages:

apt purge rstudio* 
apt autoremove --purge 

Both commands will ask you for a confirmation wether you really want to remove those packages.

Exit from chroot, unmount your partition and reboot:

umount /mnt

See, if your system works?

Thanks a lot for your detailed reply. Might be you are right I downloaded the different version of Rstudio, whatever version it was it screwed many things :smile: The steps taken are:

  1. root@ubuntu:/# sudo su
  2. root@ubuntu:/# mount /dev/nvme0n1p1 /mnt
  3. root@ubuntu:/# chroot /mnt
  4. root@ubuntu:/# apt list | grep rstudio

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

r-cran-rstudioapi/focal,focal 0.11-1 all
rstudio-server/now 2022.07.2+576 amd64 [installed,local]
rstudio/now 2022.07.1+554 amd64 [installed,local]

  1. root@ubuntu:/# apt purge rstudio*
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Note, selecting ‘rstudio’ for glob ‘rstudio*’
    Note, selecting ‘rstudio-server’ for glob ‘rstudio*’
    You might want to run ‘apt --fix-broken install’ to correct these.
    The following packages have unmet dependencies:
    libssl-dev : Depends: libssl1.1 (= 1.1.1f-1ubuntu2.16) but 1.1.1o-1 is to be installed
    libssl1.1 : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.9 is to be installed
    E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).

So far so good, how to fix these issues without messing with other things. I am just a little too conscious that I don’t loose useful things I had in my computer :smile:

Once again thanks a lot for your help.

1 Like

You can use clonezilla booted from a dvd or a USB drive.

If you dont have Clonezilla, just use any live Linux USB drive, mount the Ubuntu root filesystem , and use rsync or cp to copy all your home directory files to an external disk or a flash drive.

1 Like


Repeat the steps as before to get in chroot, but this time, before issuing chroot /mnt do this too:

mount -o bind /run /mnt/run

So you’ll have a working name resolve in chroot environment, and it allows apt to look for indexes, download packages, etc. As apt install -f may require such an operation. So:
Do the chroot, and try to remove the offending rstudio packages via dpkg:

chroot /mnt
dpkg -r rstudio
dpkg -r rstudio-server

Let’s try to fix-broken install:

apt install -f

See if things got better?

The worst that can happen, that your system got damaged to a level, where such remote repair is too hard, and a reinstall is quicker and easyer. Just be careful, upon reinstall not to format your partition which has your home folder with your precious data :wink:
A backup is always a good idea.

Very important.
A backup is still possible, if @Khan follows my previous reply .

Thanks for helping with this @kovacslt .
I initially made the mistake of thinking Rstudio was available from the Ubuntu repo. It is not. One has to use the hazardous download method.

1 Like

Thank to you @nevj. I will follow your suggestion to backup things.

dpkg -r rstudio was successful and it seems it removed the rstudio. However,
dpkg -r rstudio-server

is giving error or the execution is not successful with the error

Error, do this: mount -t proc proc /proc

I executed the command mount -t proc proc /proc and than issued the command dpkg -r rstudio-server It gives me a warning and recommends to use --purge i.e.,

dpkg: warning: ignoring request to remove rstudio-server, only the config files of which are on the system; use --purge to remove them too.

I don’t understand how should I use –purge here!

sorry, dpkg --purge rstudio-server successfully removed the rstudo also but issuing apt install -f still complains about the following missing / unmatched dependencies

libssl-dev : Depends: libssl1.1 (= 1.1.1f-1ubuntu2.16) but 1.1.1o-1 is to be installed
libssl1.1 : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.9 is to be installed

How can I safely upgrade these dependencies without effecting any other thing?

Does it boot now?

I think if it boots, I would now try a normal
apt update
apt upgrade
and see if that sorts out those last 2 missing dependencies

And, apologies for suggesting you should have used an install from the repo. I did not realize Rstudio is not in the repo.


Hi @nevj no the boot is still not successful unfortunately. I booted it via live USB but apt upgrade complains the same about those two notorious lib.

1 Like

I did a search and found, that libcrypto.so.1.1 is provided by package “libssl1.1”.
So, can you try to chroot again, and do
apt install --reinstall libssl1.1=1.1.1f-1ubuntu2.16 libssl-dev=1.1.1f-1ubuntu2.16

Theoretically this command reinstalls those packages, but forcing the version Ubuntu provides anyway.
Let me know how it went, and is your system bootable?

What happens if you issue command:
apt --fix-broken install

1 Like

Hi @kovacslt,

I don’t know why but apt was giving me the same error as reported earlier. I tried the following in addition to what was suggested earlier and this worked perfectly well.

dpkg --force-all --configure -a
dpkg --purge --force-depends libssl1.1
sudo apt-get update
sudo apt-get install libssl1.1

worked well in the end and now I have everything updated and things seems to work pretty much fine. Haven’t checked all the packages / tools but they should be fine.

So, thank you very much for your help and valuable suggestions, I learnt the concept of jailed environment while keep your development or test environments isolated. Very useful indeed.


Now you can install the correct version of R-studio :wink:
But before that, think about to start using Timeshift, or Systemback. It’s very convenient just “undo” an installation, which went wrong :smiley:


I second that.
@Khan It does not matter which backup software you choose to adopt. The ones recommended above are fine, especially if you want rollback. Clonezilla is more for protection against total failure of a disk.
Nice to see you have recovered your OS.