Ubuntu 18.04 LTS ASUS RT-AC68U Router - Merlin firmware - NordVPN OpenVPN leaks DNS


#1

My setup is this:
Desktop PC - Ubuntu 18.04 LTS -> Ethernet to Asus RT-AC68U Modem with Merlin installed and NordVPN openvpn client installed -> Ethernet to Asus DSL-AC88U Modem connected to wall socket. Recently, my ISP allocated IP/DNS address began leaking.

I use the Asus router to connect other devices, so for convenience, the router has NordVPN installed to protect all devices. I also have two other VPN services installed in this router, both of which do not leak IP/DNS.

Should I run NordVPN from a terminal or Network manager on Ubuntu desktop, no IP/DNS leaks are detected either with the router VPN client enabled or not enabled.

I have tried all sorts of suggestions gleaned from the web and from advice provided by NordVPN tech team, all to no avail other than trashing my networking a couple of times.

Has anyone, any idea or link to a fix which will work?


#2

why not use one of the services that is not leaking?


#3

Because the NordVPN servers are closer to me. I am located 1300km from the NordVPN servers closest location, whereas, I am located 2050 km from the closest servers provided by the other two VPN services. It is a matter of speed and convenience for streaming.


#4

How do you know?




#5

Because https://ipx.ac/ and https://dnsleaktest.com/ and https://ipleak.net/ tests tell me so.


#6

Okay my thoughts are close to @Akito, how do you know that it is leaking ? I personally have found that many of these testers give false positives and if your router is up to date you should have no problems with. I take it from this that you have a static address rather than a dynamic address in which case it is to pick up. Even then it doesn’t mean that there is a leak only that your address is showing up.


#7

I am certain of the validity of these leaks as all the sites for testing were recommended by the VPN service providers themselves. They most certainly would not recommend these sites if there was any chance of false outcomes which have the potential to denigrate their reputation. If you have a leak testing site you are confident with and would suggest, please feel free to do so and I will try it out. My understanding is due to recent changes to Linux networking setup, this issue has arisen and is proving most difficult to resolve for my NordVPN service.

Also, speedtest.net and speedtest-cli reveal my ISP assigned IP address.


#8

I wouldn’t worry too much about the speedtest.test it has to have that to perform the test. If you are certain of the validity of the tests then that is fair enough. I can’t see any answers elsewhere, at the moment. I am pretty sure we might have someone here that has more knowledge and can help, as this is as far as I can go. My only other thought is that it may be an IPv6 thing that is causing the leaks. You may have already looked at that.


#9

I have just now, resolved this problem.

The issue lay within the settings of the VPN Client in Merlin. Under ‘Redirect Internet Traffic’ set this to ‘All’ and DNS leak gone. Mine was set to ‘Policy Rules’. Once this was changed, all was good, no IP/DNS leaks from any of the test sites and speedtest.net indicated the VPN address, not my ISP assigned IP address.


#10

Thanks for letting us know and giving your solution. It will help our community if others have similar problems. :+1:


#11

I use a different VPN (Private Internet Access), and I get no DNS leaks with most of the distros I’ve used, or even with Windoze, but I did get a leak with Arch. Apparently it was a known issue with how OpenVPN works on Arch. I haven’t checked back to see if it has been resolved, or whether the issue applies to all of the Arch-based distros.


#12

since the issue ended up being contained within the router vpn client, i am thinking it would be a good idea to move this over to the hardware category. it also seems like a change in the title will also be helpful for someone who might run into this issue in the future. i was thinking something like: ASUS RT-AC68U Router Merlin VPN client leaks DNS.

i understand that you added the ubuntu version along with category and other vpn’s initially when you were looking for help, but feel like these two changes will help. feel free to let me know what you think :slight_smile:


#13

If this issue were contained within a hardware issues section, I would never had discovered a solution, as all my searches were centered upon Ubuntu DNS leaks from NordVPN whilst my other VPN services were not leaking. Food for thought?


#14

It’s probably a good idea to select the category that primarily applies to the issue at hand while adding tags that specify the category use in more detail.


#15

i am not following the train of thought here as your solution points to an issue with the vpn client in merlin, but that’s ok. you have a fix for your system and that is a good thing.


#16

How do I move this topic to hardware?


#17

thank you for your consideration :slight_smile:

looks like someone beat us to the move. in case it comes up in the future, there is a pencil icon to the right of the title of the original post. clicking that allows you to change the title or category or add new tags.