Ubuntu 20.04.1 - EXT4-fs error

Bug Link

Ubuntu 20.04.1
Kernel: 5.4.0-42-generic

After updating my ubuntu last week my computer gets freeze after some time and then showing this below error continuously…

EXT-fs error (device nvme0n1p6): __extf4_find_entry:1531 inode #6439215: comm main: reading directory Iblock 0

your bug report is the only thing that shows up in a search for that particular error. anything that freezes your system and involves the fs would have me backing up my personal files offline and seriously considering a re-install.

do you have a backup that you can roll back to?

failing that, you could try to dig around in logs with dmesg and journalctl or check what specifically was updated in the dpkg log but all the while i would be worried about the freeze coming on.

1 Like

this error sequence shows up multiple times in the dmesg file you added to your bug report. it is most often (but not always) associated with some kind of wireless adapter activity (similar to what is stated in the second link below):

[ 280.980948] pcieport 0000:00:1c.5: AER: Corrected error received: 0000:00:1c.5
[ 280.980962] pcieport 0000:00:1c.5: AER: PCIe Bus Error: severity=Corrected, type=Physical Layer, (Receiver ID)
[ 280.980973] pcieport 0000:00:1c.5: AER: device [8086:9d15] error status/mask=00000001/00002000
[ 280.980981] pcieport 0000:00:1c.5: AER: [ 0] RxErr

i found a couple of older pages that list boot parameter fixes, but don’t have a clue if that would cause your system to freeze or a fs error: page 1, page 2.

1 Like

apologies for the multi-post, but i kept reading and this bug report is very similar to yours including the frozen screen and dmesg errors on an hp system from less than two weeks ago with some suggested steps to follow in comment 2. the person who filed that report doesn’t seem to have answered back, but maybe adding the info to your report will help speed things along.

1 Like

Thanks for sharing man… I attached my links to the comment let’s see what next…

1 Like

it was nice to see someone was able to get back to you so quickly. hopefully a re-install does the trick and you don’t end up losing the drive. good luck.

!!! Error is still there !!!
I deleted my partition and reinstall Ubuntu 20.04 again and after using half an hour same error shows up … my system is dual boot when I am using windows no error it’s working fine. Maybe there are some issues with the new Ubuntu only…

have you tried running any tests on the disk? i believe windows has one called crystaldisk that does pretty much the same as gsmartcontrol does on linux. if you wanted to try gsmartcontrol, you could probably do so from a live usb. i have never run it on an nvme drive, but it seems to read my ssd’s just fine so i figure it might be an option.

or trying a different distro? to see if the problem is indeed ubuntu specific.

1 Like

Yeah, i tried some commands of file system like (fsck) but all looks fine. OK, thanks for sharing i will check my system again and let you know…and there are some logs and one crash file in my system (_usr_bin_gnome-shell.1000.crashScreenshot from 2020-07-30 21-57-41 ).

fsck checks your file system which is helpful if you think unbuntu is the problem. something like gsmartcontrol will check the physical hard drive to make sure it isn’t the problem. my understanding from reading what was posted on your bug report was the person who looked at your screenshot with the errors believed it was a disk problem.

i understand you are saying that windows isn’t showing the same problems, but it is written to a different physical place on the disk than where you have written ubuntu.

These are my partitions and I am using this INTEL SSDPEKKF256G7H hardrive 256GB.
Two ext4 partitions where I install my ubuntu system.

exactly. since they are on a distinctly different part of your disk from windows, it is entirely possible that windows could run without error while you are having so much trouble with ubuntu. a test like gsmartcontrol would help you possibly come to a better understanding if that part of your system was sound or not.

1 Like

Even though they are written to different area’s of ‘disc’, doesn’t an SSD write to any unused portion rather than in a circle as on a ‘spinning’ drive?
I thought SSD didn’t overwrite stuff ‘all the time’ in same area but sequentially used all available space so drive lasts longer (where an old style spinning disc would start at middle and work outwards.) This should mean any bad sections will automatically be skipped? A bad area may be small but may show up as a smaller capacity drive?
Being paranoid, I think it’s NSA plot ;o)

1 Like

my understanding is that within its own partition, an os will do just as you have described. i don’t use windows often, but the last time i looked my ext4 partition wasn’t listed in the disk management program. i think i read once that there were some windows tools to write or read some linux file systems, but i don’t believe it does so natively. the idea of a partition table is that addresses 1 through 50 are set aside for os1 and 51 through whatever for os2 etc.

if my second partition is ext4 and a third is as well, that second may run fstrim on the third if it is mounted at the time and have some interaction like you suggest but i doubt that there is anything like that going between windows and a foreign (ie not ntfs, fat or exfat) file system.

that is one of the things the smart tools look at. how many bad spots are there and how many maybe-bad spots are pending? enough bad spots or necessary file system info written to maybe-bad spot that have yet to be recovered and the os can’t do what it needs to operate properly.

Yes. That is pretty much the case.

1 Like


1 Like

I am unable to perform test with GSmartControl. I also tried with live Ubuntu but its not working.

sudo journalctl --verify

Concluding everything said here, it is unfortunately rather likely, that the sorage medium experiences a hardware fault.

The more random the errors are, the more likely it is a hardware fault. Especially with random file corruptions all over the place, without reason. Usually software related issues like that get resolved at least by a full clean upgrade or reinstallation.

You probably need to replace your current sorage medium with a newer, working one. If you have still warranty on this one available, you should make use of that.

You could try using the badblocks utility, however I am not sure how effective it is for solid state drives.

I just read through the bug thread on launchpad and discovered, that the guy says pretty much the same as I do: