Ubuntu 20.04 LTS Crashed on Software upgrade

My Ubuntu 20.04 LTS desktop machine crashed while in installing a software upgrade. It was basically unusable after that. I tried re-booting but it would randomly boot up and then crash or not boot up and come up with hundreds of error messages. Ubuntu is installed on a 120gb SSD and the home directory is on a 1TB hard drive. All my files are intact on the 1TB hard drive. I created an Ubuntu startup USB drive and tried to re-install Ubuntu. I selected the option to erase the disk and re-install Ubuntu. It the comes up with an error message “The ext4 file system creation in partition #2 of /dev/sda failedn”. Any suggestions or ideas on this?

Thanks in advance

Hi @moki
There is a sequence of steps to solve this

  1. Back up your good 1Tb HDD
  2. See if you can repair the filesystem on SSD with fsck. The disk will need to be unmounted.
  3. If 2 fails write a new ext4 filesystem to /dev/sda.
    You can use mkfs command or you can use gparted for this.
    There might be a gparted in Ubuntu, if not you can download a .iso file and make a live gparted DVD or usb drive.
  4. If 3 fails, repartition the SSD disk ( commonly known as reformatting)
    You need gparted for this. Be careful, if you repartition the wrong disk you destroy all data on it. If this works , redo step 3, then try another install.
  5. If 4 fails , sorry, you need a new SSD

Regards
Neville

Start up on the usb you created

Run the disk checking tool and inspect the ssd using the smart disk tool

Think your problem is hard disk based (ssd) but without all the errors only educated guess

Thanks for your responses. Much appreciated! Turns out the SSD is shot. I tried everything, kept getting the same errors. Wouldn’t even re-format! I installed another 120gb Lexar ssd and reinstalled Ubuntu. Working 100%. All my data is still intact on the other 1tb home drive. The only thing I cannot get to work is my canon printer. It scans, can clean the print heads but won’t print. Says printing test page, then print complete but does not print.

Hi @moki ,
I have Canon printer with same problem
I tried removing the print head and cleaning it . Improved but not good enough. Canon have very fine print nozzles which block easily.
Unless you really need a photoprinter, I would not buy another Canon.
Regards
Neville

Thank you Neville
. I want to buy another printer. Which printer works best with Ubuntu? The printer I have is a canon Pixma G2411. It worked until my ssd crashed. As I mention previously when I try and print a test page it says printing and then print complete, but the printer does nothing. It doesn’t even try to print.So i don’t think its print head related. The little LED on the printer will flash if there is any kind of error or problem. I think its driver related. According to the canon website, there is no linux support for this printer. I am looking at the canon TR4540 which has linux drivers on the canon website. The Pantum printers also have drivers for Ubuntu. I don’t know of any others.

Regards

Hi @moki ,
It sounds like you dont have any drivers setup
Did you remember to redo the printer setup after you re-installed linux?
You can probably use foomatic drivers. I do that with my Canon ip5000.
I assume you know how to use CUPS to install a printer.
Just check CUPS setup before you waste money on a new printer.
Regards
Neville