Ubuntu 21.10 not reawakening from sleep

so, delighted with the new update…until I left the laptop unattended for some time and it would not re-awake. Nothing seems to work. Interestingly when I initially touched the keyboard the login screen briefly flashed then disappeared again and I could not get anything.
When I rebooted it went back to the same blank screen (the keyboard is lit up and clearly the screen is working as it is ‘glowing’ on, but nothing is showing. The screen is not the issue) and I could not get any response.

I’m stuck. any advice appreciated.

1 Like

So, what exactly is working and what doesn’t? Tried to attach an external monitor for testing purposes?

I wouldn’t yet exclude the possibility, that the screen has an issue. Last time one of my screens showed this symptom, it actually was broken. It also came out of nothing, on a sunny day, when nobody excepted something like this, at all.

Sorry, should have said, I dual boot with Windows - which I’m writing this on - as well as easily able to run live distros without problems. I am positive its not the screen

Similar happened to me too, with Ubuntu 21.04 on a Lenovo Thinkpad E495… I did a few things (can’t remember exactly what) and it mostly stopped happening, but still happened sometimes (e.g. wouldn’t wake up properly in the morning after shutting the lid and turning off the HDMI monitor)…

Doesn’t happen to me on 20.04 on the same hardware (i.e. I formatted and re-installed 20.04 on the laptop).

I’ll be sticking with Gnome 3.8 on Ubuntu 20.04.x LTS until ALL the gotchas are ironed out of Ubuntu 22.04.2 or later LTS - the main bugbear being how 21.04 (and I’m assuming Canonical will push this substandard BULLSHIT feature into subsequent releases) forces an update when it thinks it needs it, after grub has loaded your boot and it runs the updates BEFORE you can even use your system and says “Your system is updating, please do not turn off your computer…” - methinks Canonical have been spending too much time in bed with Microsoft…

1 Like

Okay, then it’s clearly not the screen. Then it’s probably some graphics driver, or whatever flows into that direction, error. Probably something got “activated” which never was activated before, and now it acts up, because it actually never worked in the first place, but the user couldn’t notice, because it just activated, just like a time bomb, now, when nobody was expecting it.

I’m not that familiar with that area regarding solutions, but I have lots of experience with looking at black screens. Linux acted up often with graphics issues, at least in my experience. Never could get my graphics card to work 100% well with Linux. Often it did not even work at all, i.e. I wasn’t able to get it to work in a reasonable and acceptable time frame.

think you could be right. Hopefully someone recognises what this is and how i can fix it. I have tried reinstalling U 21.10 in case it was just an install glitch, but as soon as it went to sleep again it refuses to re-awake - even after a re-boot

Watched this video today and I totally agree with him.

1 Like

I just installed it in a VM this morning, and there’s already critical updates… I’m guessing they didn’t test it as widely as it needed perhaps?

Mostly so I can see if it does the hideous “Updating, do not turn off your computer…” in post grub bootup again… So I can see if there’s a way to disable that… it’s a f–king joke really! What happens if you’re running some software on Ubuntu that only works on X version of library, but on boot up Ubuntu arbitrarily decides to update that library? Sure - you shouldn’t run mission critical software on “beta” releases (I consider Ubuntu non-LTS to be essentially “beta” platforms) - but to me its a VERY ILL CONCEIVED notion, and could actually push people BACK to Windows again, which apparently can now update “in the background”… I know pretty much for a fact, quite a few people switched to Linux after one too many forced Windows updates…

Serious f–k this shit…

Gonna nuke this 21.10 VM and avoid using VirtualBox on this desktop system…

A while back, I ran into dkms issues when updating anything, I’d installed VirtualBox via “apt get” - and somehow it got its knickers in a twist and it start annoying me (i.e. I could still install new stuff or update, but EVERY time I’d get the error message about virtualbox dkms kernel shit) - so I removed virtualbox and some other stuff it had installed…

So I downloaded it from Oracle’s website, with the extention pack… installed it…

Seems mostly okay - EXCEPT :

  1. Firefox on my ubuntu 21.10 VM REFUSES to connect to the chrome-gnome-shell extension, which is F–KING WELL installed! I see others have had this issue in the past (i.e. on 19,20,21.x etc)… none of the fixes from a google-fu worked or weren’t applicable.
  2. I cannot share my FUCKING clipboard with my VM’s even though BI-DIRECTIONAL is explicitly enabled… That’s FUCKING annoying and it’s a show stopper for me… I AINT TYPING SHIT OUT AGAIN!*

Speaking of which - last week, some SHITHEAD I used to work with 20+ years ago, is now working for one of my “customers”, I needed him to reset my AD password because his JOKE of a system won’t let you change it yourself - and this “person”, who I would no longer consider a “friend”, I don’t befriend SADISTS, created a password with a RANDOM string of 51 FUCKING characters and symbols and shit - i.e. something I COULD NEVER EVER type correctly and - their SHIT system will not let you paste in if you try use the clipboard! i.e. I can paste that SHITTY password into Remmina to connect to their RDP jumpboxes and get a session, but I CANNOT paste it into the password change dialog box I bring up with CTRL+ALT (+DEL on the OSK.exe windows virtual keyboard)… This bloke is a SCHMUCK, probably has NO FUCKING IDEA what it’s like to get a call at 3:00 am and have type a long fucking password out… fuck that shit - that’s 1990’s tech! NOBODY types passwords out!

Sorry about the ranting thread hijack!

I just uninstalled the extension pack from VBox and then re-installed it - and all good… While I was there I already remembered to set the VM’s NIC to Bridged Adaptor on my gigabit ethernet NIC, installed of NAT… everything’s working in VirtualBox now…

Although that f–king ANNOYING shit with Firefox is still there :

I just wanna try out removing ubuntu-dock and replacing with floating dock extension which has been tested and is working on gnome 4…

1 Like

My fix :
(enable floating dock in 21.10)

enable sshd (sudo apt install openssh-server - why CAN’T THEY JUST LET THIS THING RUN ??? it’s my biggest gripe with desktop Linux, it’s still a server OS, why not by default enable SSH ??? )

From another Linux machine :

That version of Firefox ESR has the plugin / extension working an enabled…

I tried doing it manually by unzipping the content of the floating dock.zip file into a folder, and then copying that folder to ~/.local/share/gnome-shell/extensions/. , but it never showed up in the extensions app (note - they’ve now REMOVED the “extensions” tab/page from the gnome tweak tool).

I couldn’t remove/disable ubuntu dock until I’d installed the floating dock (by “couldn’t” I mean, I didn’t want to, I like having a dock with my favourite shit plastered all over it).

21.10 cooking with gas :

Where “extensions” tab used to be on gnome tweaks on Ubuntu 20.04 :

That tab is dead going forward, may it RIP…

Easy enough to just run “extensions”, a standalone app…

Upgrading to 21.10 on my RPi4 right now…

I’ll probably regret it… fingers crossed I don’t :slight_smile:

Prophetic or what? 'course I regret it!!!

IT’s f–ked… that’s what it is… I f–ked up a perfectly good Pi… that’s what I did… as we might say in Austallia, it’s ROOTED! (and in this context, “root” doesn’t bear any link to root on UNIX, or “rooting” Android - in Australia, this is another term for “F–KED”!).

Synergy 1.14.1 for arm64 makes it freeze / lockup (i.e. not only does Synergy “not work” it causes the whole desktop to freeze / lock up)… those nongs over at Symless compiled the arm64 version specifically for Debian on arm64, not Ubuntu…

I was kinda hoping the barrier client might talk to a Synergy server… But no… I don’t really wanna go “the whole hog” and move everything over to barrier, because I think there’s probably a slightly better chance of Synergy running on Wayland, than Barrier…

1 Like


I have been using 21.04 in a VM 6.1.26 without any major problems.

The one problem was getting desktop launchers to work initially.
I had to use and old tool apt-get install pcmanfm to help.
From the cli type pcmanfm. You will get 1 error.
Click on edit then preferences then check
“don’t ask options on launch executable files” exit pcmanfm
right click desktop icon and set “Allow Launching”
Reboot when done

Are you saying to move up to 21.10 is not a good idea?


On Raspberry Pi (4B with 8 GB RAM) in my case, it was a bad idea :smiley: … it seems perfectly happy so long as I don’t run Synergy KVM… but I’m not having a separate keyboard and mouse pair on my desk just so I can use the Pi… So without Synergy, it’s a deal breaker… and I paid for a pro license.

It was mostly working perfectly okay on Ubuntu 21.04 on RPi 4… but firing it up (I’ve removed and installed several times) now makes the whole thing “hang / crash”…

I’ve already got a ticket open with Symless (icon disappears on the server instance, even though the daemon/service is still running), but I may log another one, see if they can maybe build a binary for Ubuntu 21.x on arm64???

YMMV : i.e. your case is probably different to mine…
(your mileage may vary)

1 Like

Thanks and good luck…

Ubuntu 21.10 NVIDIA 470/510 nv_restore_user_channels bug + workaround: 18.04 Screen remains blank after wake up from suspend - Ask Ubuntu

update : still happening occasionally to me, on my Thinkpad E495 running Ubuntu 20.04 (latest default with Gnome 3.8x with latest updates)
It happens so infrequently - I can’t establish a pattern… When I hit the fartsack (Aussie slang for going to bed) I turn off the external monitor, close the laptop lid… Then 8-12 hours later, I emerge from hibernation, with a steaming hot cup of black coffee (very sweet), turn on the monitor and open the laptop lid, and it’s hunky-dory - but - maybe 1 or 2 times in 9, or 12, or 18 (does that mean only on prime numbers? No because I can’t guarantee it doesn’t happen on day 11 [never mind every 6.5th day] - and generally, in physics, electrons and quarks and shit don’t generally give a flying fuck about human scale numbering systems) - so we might as well call this symptom “still exists”…

I had some sleep issues with a laptop, and I fixed it by editing logind.conf
See the topic Recovering ubuntu 18.04 system password

I could not be sure this is the same problem. Mine was intermittent sleeps during boot and during shutdown.