Ubuntu 22.04.1 LTS "remove" is not working

Hello mates,

As you can see in screenshot;

1- i don’t have any idea why it happened but there are lots of same entry. looks like “remove” option is not working because when I select one (i.e. 1st in pic.) and press “remove”, nothing happens. how can I remove entries from the list?

2- looks like the list is not up to date by the way. for example, kodachi stands 1st in boot actually, but here in software it is not.

thanks in advance,


What was the last distro you installed? Have you done an Ubuntu 22 upgrade? As far as I know, they don’t support Grub Customizer anymore. It could be sitting in your system corrupted.

Thank you very much for your answer.

Have you done an Ubuntu 22 upgrade?

What was the last distro you installed?
Last one is Kodachi. So I realised I need to revise grub con. from Kodachi.

1- Can I install grub-customizer to Kodachi easily? It looks like it needs lots of libraries and other pre-apps before install.

2- I tried to manage grub-customizer from ubuntu by “change environment” to kodachi. ok it worked somehow. but;

a) I couldn’t change names .
b) inactive entries still visible on grub.

Any idea or advise?

Thanks in advance,


Well, I know nothing about Kodachi, except it’s Debian (?).
What repository does it use? Debian? You can check if GC is in there, and install it. Or you can try it’s PPA version.
Change Grub Boot Order and Make Windows Default.
Grub Customizer is a “hated” app by many guys who know a lot about Linux, once you have it, you are stock with it, or do a fresh install to get rid of it. There is no way just to remove it.
You can maybe try to install from Ubuntu-Focal Fossa archive, it would give you an older version, but it would still work, or an older Debian repository?
Sorry, I’m out of any more ideas, but good luck to you.
Easy Linux Tips Project: Avoid 10 Fatal Mistakes in Linux Mint and Ubuntu