Ubuntu 22.04.1 No External Sound To Headphones

My laptop is Dell Inspiron 15 5000, about 2 years old. System profile:

Problem Assumption: Inside the last 24 hours, I performed: 1. Installing KDE Connect on my laptop to sync with my Android; the sync agreement took a couple of hours to come together, but it’s working well on the phone and computer; 2. Went to Keyboard Layout Preferences and deleted “Ancient Hebrew Font Keyboard Layout” from the Preferences Layout dropdown list. There’s a possibility (I’m not a tech or guru) that one of those actions may have disabled the headphone jack audio, which was fine before and during KDE. Did I do something wrong? I would appreciate any possible solutions or feedback, thank you for sharing.

And allow me to add my system audio profile:

I use KDE connect on my Ryzen 7 desktop machine running Ubuntu 22.04.1. Never had any issues - your situation doesn’t sound like either of those things would cause issues with using the audio output jack. I’ve also used KDE connect on Dell (older) laptops in the past, running Ubuntu 18 and 20.04, never had any issues there.

Surprised it took your sync to take so long to sync KDEConnect - mine worked almost instantly (“stock” Samsung Galaxy S9+ running latest updates).

Anyway - never seen anything interfere with my audio - however - I will state this - I don’t use the audio jacks on my motherboard (see my screenshot - I mostly use USB headphones). Very occasionally I will plug a 3.5 mm headphone jack into my Logitech 5.1 speakers that are connected via 5.1 cables to my motherboard’s sound card (haven’t tried that in ages so can’t confirm). When I do use a Linux laptop and play audio, it’s usually bluetooth…

Your “sound preferences” looks NOTHING like mine, it doesn’t even look like Gnome 3.6.x, let alone my Gnome 42. Are you running Kubuntu or KDE on Ubuntu?

P.S. Note : update : edit :

Just tried to get sound from the 3.5 mm jack on my Logitech 5.1 speaker setup, and got nothing… I didn’t try “very hard” - but either way - I got bupkiss out of them (tried two different analog headsets)… Too hard basket to pull the 3 x 5.1 jacks out of the back of my mobo jacks…

P.P,.S Note : update

Got it working - turns out my 5.1 speakers weren’t actually plugged into the mobo! I’d unplugged them and used one of those RCA to 5.1 dongles that Logitech supply with their speakers…


Summary - upshot : My Ubuntu 22.04.1 system (running a reasonably “vanilla” Gnome 42) with KDE connect installed (and I have no Hebrew character sets installed!) - analog sound works out of my desktop PC via headphone jack (by way of my Logitech 5.1 speaker setup - it’s passive - i.e. the actual speakers are powered off).

One thing I might recommend, I’ve found pavucontrol much more detailed and configurable when I’ve had trouble with gnomes default Sound configuration tool. Should be available as simply as “sudo apt install pavucontrol” - I don’t have it installed currently, as I don’t need it with my current setup - everything just works i.e. all my sound “sinks” work :

1.Logitech USB headset.
2. Razer BlackShare V2 (via USB dongle)
3. Bluetooth to Sony WBX headphones
4. Digital Out via motherboard soundcard “Starship / Matisse”
5. Analog out via motherboard soundcard

I haven’t tried hooking up speakers to my HDMI or DP monitors, so can’t verify that’s working.

Note : another - I don’t know if this was ever fixed, but certain chipsets for Intel CPU mainboards, sound drivers won’t work - e.g. on my Gigabyte Brix “NUC” - running any version of Ubuntu between 18 and 20, no sound - whatsoever… Only showed “dummy device”. I now run that Brix NUC as a “headless” RHEL 8 machine…