Ubuntu 23.04 released / ubuntu.com down?

I was reading the newsletter from Linux Handbook and saw Ubuntu 23.04 was released. I had forgotten it was getting close to the date. So I went to https://ubuntu.com and it only partially loaded and then gave an error. Same after a refresh. A minute or two later I tried with Firefox rather than Edge and it loaded normally.

I wonder if they had a spike it usage due to the release of 23.04?

Maybe not. I went back and tried both Edge and Firefox again and still get an error with Edge, but not with Firefox. Hmmm.

@pdecker

Hi, :wave:

Did you also try it with wget?

I just took a look at it using the spider-option and it seems to be available (3.6 GB)

firejail wget --spider "https://cdimage.ubuntu.com/releases/lunar/release/ubuntu-23.04-desktop-legacy-amd64.iso"
Spider mode enabled. Check if remote file exists.
--2023-04-20 17:25:41--  https://cdimage.ubuntu.com/releases/lunar/release/ubuntu-23.04-desktop-legacy-amd64.iso
Resolving cdimage.ubuntu.com (cdimage.ubuntu.com)... 2001:67c:1562::28, 2620:2d:4000:1::1a, 2620:2d:4000:1::17, ...
Connecting to cdimage.ubuntu.com (cdimage.ubuntu.com)|2001:67c:1562::28|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3908573184 (3,6G) [application/x-iso9660-image]
Remote file exists.

With wget you can resume interrupted downloads as well, so I think it might be worth a try… :blush:

Many greetings
Rosika :slightly_smiling_face:

1 Like

I wasn’t trying to download the ISO at this point. It’s the homepage that fails to load in Edge. I’ve been using Edge as default for months now and the Ubuntu homepage has always loaded for me in the past.

I disabled uBlock Origin and Disconnect extensions. Still will not load. Very odd.

I don’t have Chromium installed, but maybe I’ll try that and see what happens.

Hi @pdecker, :wave:

Oh, sorry then. I probably misunderstood what you were trying to achieve. :frowning_face:

Hmm, I cannot help you with Edge as I haven´t installed it.
I just looked at the respective homepage with firefox and here it seems to work well.

Perhaps there´s someone else with Edge knowledge who can help.

Many greetings from Rosika :slightly_smiling_face:

1 Like

Update. I tried Chromium and the Ubuntu homepage is fine. I installed Edge Dev and it also works fine there. It is just a problem on Edge Version 112.0.1722.54 (Official build) (64-bit) on Pop!_OS 22.04 LTS with all updates applied.

I cleared my cache too, but same issue.

Oh well. I will live.

1 Like

No issues here from downunder, despite my ISP providing yoyo internet servers most of yesterday (coincidentally about 15 minutes after the solar eclipse)…

Touch wood (does chipboard count?) - it’s okay today - it’s been mirrored to aarnet so I’m grabbing a copy now… I’ll probably stick with Pop!_OS on my main systems for the time being - but I might plonk 23.04 alongside Windows 10 on my Dell 7270 (which I barely ever use)…

And everything’s a shitload easier now I’m using Ventoy…

2 Likes

Speaking of Ventoy, I just got a Samsung 128GB USB3.1 FIT stick (it promises 400 MB/second), and I installed Ventoy on it so now I can very easily try out live versions of new releases at neat to bare metal performance speeds (all I have to do is copy the .iso image file to the Ventoy drive). I’ll have to get the new Ubuntu release and give it a try.

I tested Ventoy on an old USB2 drive and I liked how well it works (even with Secure Boot enabled), so when I saw the 128 GB Samsung drive for about $30.00 (US), I decided to get it so I could use it that way too for the better performance. I’ve tested it out with Fedora-Cinnamon 38 and ZorinOS 16.1 so far, ant they both work very much as if they have already been installed. As far as I’m concerned, my new Samsung drive has been well worth the price :slight_smile: )

3 Likes

I just checked Amazon and see it for $17.99. Maybe I haven’t looked at USB sticks lately, but that seems like a pretty good deal.

1 Like

It looks as if they are coming down in price (for now). I just looked at my Amazon order, and my total bill was $19.38 (US). I am a Prime member (for now). Since these can serve a variety of purposes, and they are available in three sizes (from 64 GB to 256 GB), you may want one for Ventoy and at least another to expand storage capacity on a laptop. Such versatility, and at such reasonable prices!

Interestingly, based on the currently advertised pricing (from the image above), cost per GB goes up with capacity (64GB costs about $5.82/GB, 128GB costs about $7.115/GB, and 256GB costs about $8.26/GB). All prices are in US dollars. To get these numbers, I divided capacity by cost.

1 Like

While we’re still talking about Ventoy - despite my singing it’s praises earlier - I tried THREE times to get Ubuntu 23.04 live boot to “boot” - NO GO! Via Ventoy…

Zorin 16 booted first time, off the same Ventoy stick… when I can be arsed, I’m going to burn a Ubuntu 23.04 stick and see if it boots… Dell Latitute 7270, 8 GB DDR4, 512 GB SSD (M2?).

Half the disk is allocated to Windows 10, which I never use, but it’s there if I even need Win10 for something…


definitely some issue with Ubuntu and Ventoy not playing well together… Just shows the post grub boot splash ad nauseam (literally for hours) - whether I use any of the three different options from Ventoy…

Dedicated Ubuntu stick boots straight into Ubuntu, same hardware, with a stock Ubuntu 23.04 boot stick (prepared with dd)…

1 Like

To get cost per GB you need to divide the cost by the capacity and not capacity by cost.

It looks like the cost goes down slightly for each larger USB drive.

image

1 Like

Oops! I got the math backwards. That’s not like me. I guess I’m getting old (or maybe I rushed my post too much) :slight_smile: Thank you for noticing my error, and correcting me!

Ernie

The math is OK, you should have called it Gb per $. Got the units wrong.

I heartily agree! :slight_smile: (Agreed! was too short to post - posts minimum length is 20 characters+???)

Finally got it booting and installing (23.04) in dual boot with Windows 10 on a Dell Latitude 7270…

Confirmed - save / open dialog boxes now let you pick icon view and it can display thumbnails - I can’t believe they pulled this feature for a whole bunch of Gnome 3.3x and 4.x releases! Why? Was it too hard?

Don’t know how long we gotta wait (if ever) to see this feature in Pop!_OS…

This page :

seems to infer this is possible, and a feature, of Pop!_OS…

So - if/when System76 do a Pop!_OS 23.04 or 23.10 or even a 24.04 - I’ll be jumping…

1 Like

I just updated MS Edge from 112 to 113 and now https://ubuntu.com is just fine again.

I dont get it, how could any browser have a problem with downloads?. It is so basic.
Are you sure you did not have some inadverdant setting in Edge?

1 Like

It wasn’t even downloads. It was the home page. It started to load and showed some of the background and the ‘accept cookies’ button. But then it would just stop. Even when I would use Firefox to navigate to the Ubuntu blog and then copy and paste that URL into Edge (avoiding the home page), it would still lock up.

I tried clearing cache, safe mode, no extensions, rebooting, etc. It just wouldn’t work.

So I downloaded a DEV version of Edge. Main was 112 and DEV was 114. The 114 version worked when the 112 version didn’t with all the same extensions.

It has worked for years for Ubuntu.com, but just quit a day or two before my first post. Yesterday a newer version of main was released (113) and now Ubuntu.com loads normally again.

1 Like