Ubuntu booting problem

Hello. Yesterday, I installed Ubuntu 20.04 and it worked normally. But today, it is not booting.
When I open the bios menu, there is an option for ubuntu but selecting it loads the dell system checker. Bios pretends that I have no ubuntu installed.
I had previously installed Lubuntu on a usb. So, I booted it and ran commands “os-prober” and “update-grub” in the terminal. It successfully detected my new installed ubuntu. So, I can boot into it now, but everytime I have to use grub of Lubuntu installed on usb.

sounds like a situation where boot repair might help: https://help.ubuntu.com/community/Boot-Repair

Aready done. But it doesn’t solve the problem.

what is it that is done?

I think he means he’s already tried Boot repair?


I booted into my Ubuntu 20.04 using Lubuntu Grub menu.
Then I added the ppa for downloading “boot-repair”.
Then I ran “sudo apt update” and then “sudo apt install boot-repair”.
Then I launched the “boot-repair” form terminal and chose the recommended option there.
It showed a successful repair. This is the paste from boot-repair.

did you do this part:

Please do not forget to make your UEFI firmware boot on the The OS now in use - Ubuntu 20.04.1 LTS CurrentSession entry (sdb1/EFI/ubuntu/shimx64.efi file)

I don’t know how to do it. Can you please tell me?

i am fairly certain you would do that with efibootmgr. take a look at this man page:

if you are unsure or have any questions, feel free to post the output of
sudo efibootmgr
and we’ll see if we can get that worked out with you :slight_smile:


I created boot entry with command

sudo efibootmgr -c -L ubuntuefi -d /dev/sdb1

but didn’t work (maybe I didn’t do that correctly).
Output of sudo efibootmgr is:

BootCurrent: 0006
Timeout: 2 seconds
BootOrder: 0006,0003,0005
Boot0000* Fedora
Boot0001* gentoo
Boot0002* Windows Boot Manager
Boot0003* ubuntuefi
Boot0005* UEFI: SanDisk SD9SN8W128G1014, Partition 1
Boot0006* ubuntu

when you say “didn’t work” can you explain a bit more? after you created that entry what did you do?

i rebooted the system, selected ubuntuefi option and the dell system scan screen appeared

can you post the output of
sudo efibootmgr -v
so we can see where those two ubuntu entries are pointing?

Here it is:

BootCurrent: 0006
Timeout: 2 seconds
BootOrder: 0006,0003,0005
Boot0000* Fedora HD(1,GPT,0e1ab6cf-97b2-4e07-9dc5-f7f62530140e,0x800,0x12c000)/File(\EFI\fedora\shimx64.efi)
Boot0001* gentoo HD(2,GPT,61666d7b-3de4-4e2c-a409-ef89eaabbbd9,0x1800,0x40000)/File(\EFI\gentoo\grubx64.efi)
Boot0002* Windows Boot Manager HD(2,GPT,61666d7b-3de4-4e2c-a409-ef89eaabbbd9,0x1800,0x40000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS…x…B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}…a…
Boot0003* ubuntuefi HD(1,GPT,2813fbbc-1d22-4c84-bbaf-ff39ae30a7eb,0x800,0x100000)/File(\EFI\ubuntu\grub.efi)
Boot0005* UEFI: SanDisk SD9SN8W128G1014, Partition 1 HD(1,GPT,7dd82bda-620f-4731-9e70-cda9365d8fc3,0x800,0x100000)/File(\EFI\boot\bootx64.efi)…BO
Boot0006* ubuntu HD(1,GPT,2813fbbc-1d22-4c84-bbaf-ff39ae30a7eb,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)

looks like the one that boot repair said to point the firmware towards

let’s see if specifying that one with nextboot works. can you run:
sudo efibootmgr -n 6
and then reboot?

actually that is for the lubuntu usb.
Same problem again. ubuntu menu loads lubuntu grub menu.

i think this one may help us zero in on the correct partition:

this one has the same partuuid as listed in your boot repair log:

vfat     7A73-884E                            7dd82bda-620f-4731-9e70-cda9365d8fc3           EFI System Partition


sdb:128GB:scsi:512:512:gpt:ATA SanDisk SD9SN8W1:;
1:1049kB:538MB:537MB:fat32:EFI System Partition:boot, esp;
NAME   FSTYPE   UUID                                 PARTUUID                             LABEL     PARTLABEL
├─sdb1 vfat     7A73-884E                            7dd82bda-620f-4731-9e70-cda9365d8fc3           EFI System Partition
└─sdb2 ext4     ae84b73b-9bbf-489d-9385-3b9b04c2c186 717748c4-f98c-414b-b6eb-41b193dc7904

it doesn’t point to shimx64.efi, but i would still give nextbooting into 5 a try.

Yes. So, now I tried to boot from Boot0005 . And I noticed that the system gives a message for a fraction of a second, and then starts rebooting with the message showing everytime for a fraction of a second. I took picture of it in my phone. The message is:

System BootOrder not found. Initializing defaults.
Creating boot entry “Boot0004” with label “ubuntu” for file “\EFI\ubuntu\shimx64.efi”