Ubuntu freezes. Software or hardware issue, or both?

About two months ago, while still running Ubuntu 18.10 on my Lenovo ThinkCentre-M58p, dual booted with Windows 10 (which I have not opened in over a year), my system completely froze. The keyboard and mouse were unresponsive. I had to hard reboot the PC which took several tries. At first the machine would not shut down or restart but would make a series of beeps, three quick beeps four times in a row, and then either the hard drive or fan would rev up and run loudly and not stop until I attempted a hard reboot again. This process would repeat several times until finally the PC would restart.

This happened three times in about five days. I could not find any specific information online regarding solutions for this sequence of events but I did come across a post that said upgrading to Ubuntu 20.04 solved their freeze problems. As I had been meaning to upgrade I went ahead and did this.

20.04 worked great for about a month and then it froze twice within a couple of days, exactly the same sequence as the 18.10 freezes. Prior to attempting the hard reboot after the second freeze I opened up the PC and gave it a good long overdue cleaning and dusting (which I had not done for a longer time then when I last opened Windows 10). I figured that couldn’t hurt things.

After the cleaning 20.04 finally rebooted and worked fine for three weeks. Then yesterday, this time, when I attempted to start it back up from suspend, the PC would not come out of suspend mode but started the beeps/revving hard drive again. This would not stop happening even after five or six attempts to hard reboot. I thought the machine is now truly dead but I went and opened and dusted it again, why not? And sure enough at my next attempt to reboot it started back up and ran fine.

One common factor through all this is that Chrome has always been running when Ubuntu freezes although it was not open when the PC failed to wake up from suspend mode the last time. Also, after the first freeze in 18.10 I started looking at the system monitor and the CPU’s will often run at or near 100% for brief periods of time, or a few times 10 or 20 seconds straight, especially when I’m using YouTube or Facebook. The memory has never gone much above 60%.

I have not been able to find online any information specific or even close to my situation, so any thoughts, ideas or solutions will be greatly appreciated. My tech skills are beginner/intermediate, especially in regards to Linux so let me know if there’s more information needed. This PC is a refurbished machine over eight years old so perhaps it’s time has come to an end but I would like to try all other possibilities before getting a new computer.

Below are the specifications and error reports from the terminal. (Thanks ‘It’s FOSS’ for how to access this info!)

steven@steven-ThinkCentre-M58p:~$ inxi -Fxz
System:
  Kernel: 5.4.0-70-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Gnome 3.36.7 Distro: Ubuntu 20.04.2 LTS (Focal Fossa) 
Machine:
  Type: Desktop System: LENOVO product: 7220RY8 v: ThinkCentre M58p 
  serial: <filter> 
  Mobo: LENOVO model: LENOVO serial: <filter> BIOS: LENOVO v: 5CKT77AUS 
  date: 05/07/2012 
CPU:
  Topology: Dual Core model: Intel Core2 Duo E8500 bits: 64 type: MCP 
  arch: Penryn rev: A L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 12636 
  Speed: 1995 MHz min/max: 2000/3167 MHz Core speeds (MHz): 1: 1995 2: 1995 
Graphics:
  Device-1: Intel 4 Series Integrated Graphics 
  vendor: Lenovo ThinkCentre M6258 driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1440x900~60Hz, 1440x900~75Hz 
  OpenGL: renderer: Mesa DRI Intel Q45/Q43 (ELK) v: 2.1 Mesa 20.2.6 
  direct render: Yes 
Audio:
  Device-1: Intel 82801JD/DO HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k5.4.0-70-generic 
Network:
  Device-1: Intel 82567LM-3 Gigabit Network vendor: Lenovo driver: e1000e 
  v: 3.2.6-k port: 1820 bus ID: 00:19.0 
  IF: enp0s25 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 1.82 TiB used: 29.97 GiB (1.6%) 
  ID-1: /dev/sda vendor: Western Digital model: WD2003FYPS-27W9B0 
  size: 1.82 TiB 
Partition:
  ID-1: / size: 908.96 GiB used: 29.97 GiB (3.3%) fs: ext4 dev: /dev/sda5 
  ID-2: swap-1 size: 7.47 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6 
Sensors:
  System Temperatures: cpu: 48.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 238 Uptime: 8h 48m Memory: 7.25 GiB used: 3.73 GiB (51.5%) 
  Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.17 
  inxi: 3.0.38 

steven@steven-ThinkCentre-M58p:~$ dmesg --time-format iso -l err,crit,alert,emerg
2021-03-25T10:01:25,317630-04:00 ACPI BIOS Error (bug): Failure creating named object [\_SB.PCI0._OSC.CAPB], AE_ALREADY_EXISTS (20190816/dsfield-182)
2021-03-25T10:01:25,317637-04:00 ACPI Error: AE_ALREADY_EXISTS, CreateBufferField failure (20190816/dswload2-477)
2021-03-25T10:01:25,317664-04:00 ACPI Error: Aborting method \_SB.PCI0._OSC due to previous error (AE_ALREADY_EXISTS) (20190816/psparse-529)
2021-03-25T10:01:25,323655-04:00 platform INT0800:00: failed to claim resource 0: [mem 0xff800000-0xffffffff]
2021-03-25T10:01:25,323658-04:00 acpi INT0800:00: platform device creation failed: -16
2021-03-25T10:01:25,727517-04:00 ima: Error Communicating to TPM chip
2021-03-25T10:01:25,731689-04:00 ima: Error Communicating to TPM chip
2021-03-25T10:01:25,735859-04:00 ima: Error Communicating to TPM chip
2021-03-25T10:01:25,740029-04:00 ima: Error Communicating to TPM chip
2021-03-25T10:01:25,744192-04:00 ima: Error Communicating to TPM chip
2021-03-25T10:01:25,748180-04:00 ima: Error Communicating to TPM chip
2021-03-25T10:01:25,752180-04:00 ima: Error Communicating to TPM chip
2021-03-25T10:01:25,756182-04:00 ima: Error Communicating to TPM chip
steven@steven-ThinkCentre-M58p:~$

My guess: It’s a hardware issue.

Ubuntu should offer you a memory test right from the GRUB menu. That would be my first step.

If you don’t have a GRUB menu at boot because your installation lives all by itself on your computer, just boot from a USB device with e.g.

https://www.system-rescue.org/

or any other suitable live distribution.

2 Likes

General rule of thumb:

If you experience very random weird errors, especially during boot time, then the problem is most likely related to a hardware issue.

I would go even farther than what @Mina proposed, because you sometimes can’t even boot right. I think memory tests are more suitable for running systems that experience slight disruptions.

If I were you, I would remove a RAM stick next time the machine wouldn’t boot. I would repeat that process until it boots fine, without any beeping or whatever. It may be necessary to remove all RAM sticks at one point and temporarily replace them with different ones, that are sure to work.

If completely removing and perhaps replacing the RAM sticks did not work at all, i.e. the PC still has precisely the same boot issues, I would try to boot into a clean live medium of your choice and then doing basic hard drive checks.
If those passed, I would run a general CPU stress test.
If this passed as well, I would try removing ALL unnecessary peripherals and equipment from your computer, until it is as fresh as it gets.
If you can boot fine now, try adding the missing components one by one. As soon as the machine starts to complain again, then you probably found the component causing the issues.

In the worst case scenario, the CPU itself is broken, which means it wouldn’t be reasonable to replace it, except the CPU is accidentally 10 bucks or cheaper or the mainboard’s CPU socket allows such a cheap alternative CPU to run on that computer.
However, looking at the specs it barely makes sense to issue major repairs on this computer. It just wouldn’t be reasonable from a user perspective.

Actually, reading through the specs a bit more thoroughly, I noticed this CPU. It’s a pretty common and pretty cheap CPU. I think it’d be still fine to replace that one.

However, anything going beyond that, especially when we are talking about buying RAM for this computer, does not make sense at all. It would just make sense to buy a new(er) computer!

2 Likes

As you mentioned beeps

Most makes have a beep code system which tells you what is wrong before Windows or Linux starts up

https://support.lenovo.com/fr/en/solutions/ht505216-post-beep-symptoms-thinkcentre

When it goes again try to work out the sequence of beeps and check against set code to discover what the problem is.

1 Like

Usually with things like this I do stuff like disable hardware acceleration in Chrome / Chromium - and see if that fixes it…

Recently built PC (Ryzen 7 3700x with 40 GB RAM NVidia GTX1650) : VLC would lock up the whole PC in the middle of playing a video file (video would stop, but sound continue - whole PC unresponsive - can’t even Ctrl+Alt+F3,4,5 etc)… turned off hardware acceleration in VLC and it stopped happening…

I should try turning it back on I guess - but VLC doesn’t seem to skip a beat without hardware acceleration, or lag or slow down…

Do you have a manual for the mainboard? Most mainboards have LEDs that light up when there’s a hardware fault (like bad RAM etc)… The number of beeps should be listed in the manual for the mainboard too…

2 Likes

A friend of mine had a similar-sounding situation but with a desktop computer. He ultimately determined that the coin battery on the MB (the one that keeps the configuration data from evaporating when the machine is off) had run down. He replaced that battery and all was well. Maybe there’s a something like that wrong with your machine.

      Don
1 Like

In addition to the other suggestions, I would take a very hard look at the power supply or any power circuitry in a laptop… If a machine fails to finish “POST” (power on self test) it is NOT a problem with the O/S or software, as that is not loaded and running.

Given the probable age of a machine w/ that CPU, it is quite possible that you have issues with the capacitors in the power supply or elsewhere on the MOBO as they tend to age and break down over time. (Lenovo tends to use better grade components, but this can be a real issue w/ ‘bargain’ hardware) Allowing serious crap buildup inside can also cause problems due to added thermal stress on parts…

A flaky power supply can cause all sorts of weird issues as it may or may not be able to deliver the needed power / voltages at any given instant, but it is extra likely to be a problem when the power demand is high, like when booting, or doing high load processes like starting programs. It can also be a highly intermittent problem, which matches much of what the OP seems to be describing.

2 Likes

Thanks for this info. If it does turn out to be the CPU I’ll try replacing it. As you say they seem pretty reasonable for this model.

1 Like

It did make a series of beeps but as I wasn’t aware of their significance I did not pay close attention to their duration so I’m not sure which symptom it might be indicating. If this happens again I will pay more attention. Thanks for this info.

My hardware acceleration is disabled. Although when I checked chrome://gpu/ I got this info, not sure if any of this is relevant to my situation:

Problems Detected

  • Gpu compositing has been disabled, either via blocklist, about:flags or the command line. The browser will fall back to software compositing and hardware acceleration will be unavailable.
    Disabled Features: gpu_compositing
  • Accelerated video decode has been disabled, either via blocklist, about:flags or the command line.
    Disabled Features: video_decode
  • Raster is using a single thread.
    Disabled Features: multiple_raster_threads

Unfortunately I do not have a manual for this PC.

You should be able to download a PDF version of the system board (Lenovo right?)…

I don’t keep any hard copies of manuals - paperless all the way for me… try a google search on the system board value returned from “inxi -Fxz”… I’ve got a few Lenovo’s (ancient Thinkcentres I used to use as ESX servers) and I’ve been able to download system manuals from their support site…


just googled : "lenovo manual 7220RY8 thinkcentre "

and eventually got here :

Yeah - I know it’s almost an RTFM response - but that should be your first port of call - should tell you what all those beep counts mean…

2 Likes

From that manual: “Four sets of three beeps-DRAM memory error” That’s exactly the series of beeps I was getting! Thanks! It’s amazing the information one can find when one actually reads the manual… :grinning:

1 Like

Before going shopping for new RAM modules - let me suggest re-seating them - maybe even juggle them around - also how many banks? 4?

Make sure they’re all the same type model too… also - if they don’t match - e.g. you have 2 of type “a” and 2 of type “b” - make sure that all the same type in paired banks / channels…

e.g. your mileage may vary… some mother boards go :

Physical Bank : Channel :
1 : A
2 : A
3 : B
4 : B

But some others alternate :
Physical Bank : Channel :
1 : A
2 : B
3 : A
4 : B

I recently resolved what I thought was a bad RAM issue by trying incrementatally :
RAM in bank 1 only, then in both bank 1 and 2, then 1,2 and 3, and then 1, 2, 3, 4 - and - it all worked - I got bad DRAM lights on my motherboard and it wouldn’t go past POST (power on self test) and I assumed it was a bad module - but no - it was pretty much 100% just that at least one of them wasn’t properly seated!

1 Like

As this issue has not yet been reported resolved, and, if DRAM was not the problem, may I suggest checking the BIOS. I had a startup issue with an HP laptop in which the display never turned on, and the only clue I had were beep codes and keyboard light patterns. It turned out to be a corrupted CMOS. You could perform a search for “recover bios data in lenovo ThinkCentre-M58p” for information on restoring BIOS data with a corrupted CMOS. Good luck!

A very thorough and perhaps tedious alternative to that method would be to (assuming you have 4 RAM sticks and 4 RAM slots on the motherboard in total) put stick 1 onto slot 1, boot up and note if it works or not, then put stick 1 onto slot 2, boot up again etc., then put it into slot 3 etc. Then you repeat the whole process for the remaining 3 RAM sticks. This way you can determine precisely which part is faulted in which way.

In your specific case however, it might be necessary to repeat the above test a couple of times, since you said that sometimes it randomly works, even when it does not, most of the time. This would make the process even more tedious, but you would get the most accurate results and you would know exactly what is wrong, without question.

1 Like

I think I may have inadvertently re-seated the RAM modules when I opened it back up to clean it again and then set the PC itself horizontal rather than vertical, which it had always been! It’s been working fine since then.

I have digital manuals I found online for my car, AC, dehumidifier, microwave and many other things yet it never occurred to me to find an online manual for this old PC. So thanks again for the very valuable ‘RTFM’ advice and for actually finding the manual for me!

1 Like

Thanks for all the advice and suggestions everyone regarding this issue.

Although it may ending costing me time, effort and money down the road to fix or replace this PC if this issue happens again, I’m actually relieved that it’s most certainly a hardware issue and not a problem with Ubuntu. I rant and rave to any of my friends who will listen (and they’re very few) about the benefits of Linux over Windows so I’m relieved that my Ubuntu OS is as stable and reliable as ever. Coincidentally, today’s It’s FOSS weekly newsletter had the perfect cartoon about this!

2 Likes