Ubuntu installed on usb stick doesn't complete boot

I used a Ubuntu 22.04 installed on a USB stick for a while and it worked like a charm.
After a recent update to 23.04 it didn’t boot anymore. It would stop booting with a cursor on the top left corner of a black screen.
Today a went through the procedure again and reinstalled it (I’m referring to this great post: Install Ubuntu Linux on an External USB Drive).
It’s still not working. Same problem. Any suggestions?

1 Like

I’ve seen some weird stuff happening with 23.04 upgrades lately. I’m assuming you did the upgrade in place (from the command line?)

Only thing I can suggest without trying it myself is formatting the drive to ext4 manually (mkfs.ext4 /dev/xxx) and then try reinstalling on the clean drive.

I’m really tempted to try this just to see what happens though.

1 Like

Yes, I did all the updates and upgrades in place. Yesterday I “remade” the bootable usb from scratch and installed version 23.04 directly. Looks like there is something wrong with this version.

This morning I installed Ubuntu 23.04 on my laptop’s internal SSD by taking some storage away from my Windows 11 storage. Grub menu appears (booting from USB I don’t get the grub menu) but Ubuntu doesn’t boot!
I can get it to boot by choosing recovery mode on the grub menu and then just simply selecting “resume” on the recovery menu :smiley: !!!
Any ideas?

That may have something to do with the fact that Windows and linux are fighting for bootloader dominance so to speak. I’ll let someone more experienced wtih dual booting take it from here, because I’ve always just ran either Linux or Windows.

Check the grub config in /etc/default/grub
It may have some kernel boot parameter, … like acpi… set wrong

How new is the PC.? It may be a graphics driver issue

Can you boot it by hand with the grub> command prompt? Try with various kernel boot parameters.


The only non commented lines in /etc/default/grub in both the USB stick and the internal dual boot are the following:
GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian

The PC is a Acer 515-57G dated 2022, CPU is a Intel i7-1255U, Graphic card is an nVIDIA GeForce MX550.
With the USB stick I don’t get to the GRUB menu. After the ACER splash screen with the Ubuntu logo at the bottom, a non blinking cursor appear on the top left corner of a blank screen. I can’t even switch to the console to see what is going on…
Thanks for your help!

Actually, my goal is to fix the bootable USB stick. I installed a dual boot just to see if Ubuntu 23.04 could boot without any problems when starting from internal storage. Looks like it has problems there too, even though I managed to bypass them with the “recovery mode - resume boot”. But I can’t figure out where the problem is…

Those are all harmless
You could try adding some boot options

The PC is old enough . It is not likely to be graphic card driver issues, unlexs that nvidia card is special.

Some Linuxes, when they are the only OS on the disk, bypass the grub menu.

That does not leave us many options. I cant see what to do next, except maybe try a manual boot at the grub prompt. Its not easy, you need to read the grub manual.

Can you use dmesg to see what was going on when it went into recovery mode?
Some distros need sudo for dmesg