Ubuntu Mate 18.04 unable to access WD My Passport

my daily use distro is bodhi 5.0 which is based on ubuntu 18.04. my western digital my passport 259d works just fine with bodhi. i can acces, create and execute. i use it for clonezilla backups so it is also just fine working with that live (i believe clonezilla is debian-based) environment. the issue is that i am unable to access the files in ubuntu mate 18.04.

the screenshot below is the error message i get when i try and open the external in ubuntu mate. ls -l lists my user as owner and group. permissions are 777. i was able to cd into the directory and ls the contents, but there i ran into the input/output error: “ls: cannot access ‘bin’: Input/output error”. interestingly i get that same error here in the terminal in bodhi, but it doesn’t seem to affect file manager access :man_shrugging:t4:

also interesting is the fact that i finally thought to try accessing the drive on my debian 9 install and it is good to go there as well.

i could keep adding details, but as i have yet to understand the underlying issue i am not sure what to add that might be helpful so i will post and see if anyone else has any good ideas :slight_smile:

  1. What exactly is in that folder?
  2. What file system is the disk or partition of?

Terminal is what counts. So we count this as “it doesn’t work in either, Bodhi and mUbuntu”.

Good to go, meaning no error at all?

sudo fdisk -l | grep -A 7 /dev/sd   # find the device identifier here
sudo apt install -y smartmontools   # installing tools needed for the following command
sudo smartctl -x /dev/sdb           # assuming the disk in question is "/dev/sdb"

Print the output of the last command by appending it to your OP.

1 Like
  1. all manner of files. mostly the drive is my backup. it has the clonezilla image files for my two systems, personal files like photos, music and whatnot.
  2. the external is ntfs. bodhi and mubuntu are both ext4.

i don’t think i explained the terminal error in enough detail. the “ls: cannot access ‘bin’” error did not prevent the files and directories from being listed in either terminal. i didn’t drill down into any particular directory (i can do so in a bit) to see if further access was possible. i just thought the error message was something to note.

i can jump back in there in a bit to check. there was no error message when accessing through the file manager. i didn’t try terminal access in debian. just checked to see if i had the desired file manager rwx access which it did.

gotta head out for a while. will return to address the other questions/points.

That’s the issue right there. At first I thought we are talking about the bin folder you can’t access. But now what I get from what you are saying is that you are listing the directory above bin, getting the mentioned error.
If you back up stuff from Linux to NTFS, there can be I/O errors, that is “normal”. If it is e.g. a hard link sitting on NTFS, then I think the only thing fixing this would be reformatting the whole drive, which implies a deletion of all files on the disk. Don’t mix NTFS with Linux, especially not for system backups. The only thing Linux can reliably deal with when counting in NTFS are photos, videos and stuff like that. When it comes to system files, it just can’t handle that file system.

1 Like

Hi cordx

There a few reasons why these (seem like a great idea) external HDD’s are not suitable for Linux use.

  • They are designed either for M$ or Fruit use.
  • USB 3 connector to computer but a USB 1 or 2 connector to the disk (slow data transfer speed)
  • Can not format to Ext4
  • My cousin throw his 6TB WD in the bin when I pointed out the above flaws
  • Bodhi has 4.15 kernel, Debian has 4.09, thus won’t co-operate
  • Use back ports 4.19 Linux-image for Debian, might overcome this issue
  • Also add (Install) LVM2 & cryptsetup to Debian, may help.

I have heard it is possible to transfer Linux files to M$ file systems and vice versa, but I find that not to be the case, I have transferred original Linux generate video files between M$ and Linux, (especially during the weaning off with my old man). I did notice M$ had overwrite or corrupted the video file while in Linux.

If you need an external storage device: This I can recommend

or I have a CIT USB3 branded version, this example is USB2

:sunglasses:

1 Like

I had this problem some time ago, because they’re set up for windows. If you have access to windows it is a simple repair and you will be able to view everything again in Linux systems as well. I did it this way. 1. Plug in your external hard disk .
2. Open File Explorer by pressing the Windows keys button + E.
3. Go to This PC.
4. Right-click your external hard disk under Devices and drives .
5. Select Properties.
6. Go to Tools tab.
7. Under Error checking, click Check.
Let it do it’s job and then remove it and everything will be okay.

You totally resolve this from happening again, but only do this if you really have your files safe. (I have 4 back up drives) by formatting the drive so that will only accept linux files, think that EXT4 but check and then just use it for that. I have one that I just use for Mint. I did the above first then transferred the files I wanted to my laptop which had Mint on them and then transferred them back to external drive. It is a bit of a pain to do it, but I’ve not had problems with either since.

1 Like

Interesting, fix. That would leave me feeling unclean, BBrrrrrrrrrr…!

Why I purchase OS agnostic hardware, to avoid such a need for windies to come to my aid.

That’s why I formatted the drive afterwards so I don’t have to do so anymore and surprise, surprise I have not had any problems with it since

2 Likes

the results of sudo smartctl -x /dev/sdb:

Summary
Device Model:     WDC WD5000LPLX-08ZNTT0
Serial Number:    WD-WXP1E966LT6F
LU WWN Device Id: 5 0014ee 65c78b837
Firmware Version: 03.01A03
User Capacity:    500,107,862,016 bytes [500 GB]
Sector Sizes:     512 bytes logical, 4096 bytes physical
Rotation Rate:    7200 rpm
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   ACS-2, ACS-3 T13/2161-D revision 3b
SATA Version is:  SATA 3.1, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is:    Fri Feb 22 00:00:02 2019 CST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled
AAM feature is:   Unavailable
APM level is:     254 (maximum performance)
Rd look-ahead is: Enabled
Write cache is:   Enabled
ATA Security is:  Disabled, NOT FROZEN [SEC1]
Wt Cache Reorder: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status:  (0x82) Offline data collection activity
                                        was completed without error.
                                        Auto Offline Data Collection: Enabled.
Self-test execution status:      (   0) The previous self-test routine completed
                                        without error or no self-test has ever
                                        been run.
Total time to complete Offline
data collection:                ( 6960) seconds.
Offline data collection
capabilities:                    (0x7b) SMART execute Offline immediate.
                                        Auto Offline data collection on/off support.
                                        Suspend Offline collection upon new
                                        command.
                                        Offline surface scan supported.
                                        Self-test supported.
                                        Conveyance Self-test supported.
                                        Selective Self-test supported.
SMART capabilities:            (0x0003) Saves SMART data before entering
                                        power-saving mode.
                                        Supports SMART auto save timer.
Error logging capability:        (0x01) Error logging supported.
                                        General Purpose Logging supported.
Short self-test routine
recommended polling time:        (   2) minutes.
Extended self-test routine
recommended polling time:        (  82) minutes.
Conveyance self-test routine
recommended polling time:        (   5) minutes.
SCT capabilities:              (0x3035) SCT Status supported.
                                        SCT Feature Control supported.
                                        SCT Data Table supported.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAGS    VALUE WORST THRESH FAIL RAW_VALUE
  1 Raw_Read_Error_Rate     POSR-K   200   200   051    -    0
  3 Spin_Up_Time            POS--K   142   142   021    -    1883
  4 Start_Stop_Count        -O--CK   100   100   000    -    489
  5 Reallocated_Sector_Ct   PO--CK   200   200   140    -    0
  7 Seek_Error_Rate         POSR-K   200   200   051    -    0
  9 Power_On_Hours          -O--CK   099   099   000    -    1365
 10 Spin_Retry_Count        -O--CK   100   100   000    -    0
 11 Calibration_Retry_Count -O--CK   100   100   000    -    0
 12 Power_Cycle_Count       -O--CK   100   100   000    -    397
192 Power-Off_Retract_Count -O--CK   200   200   000    -    36
193 Load_Cycle_Count        -O--CK   200   200   000    -    732
194 Temperature_Celsius     -O---K   101   089   000    -    42
196 Reallocated_Event_Count -O--CK   200   200   000    -    0
197 Current_Pending_Sector  -O--CK   200   200   000    -    0
198 Offline_Uncorrectable   ----CK   200   200   000    -    0
199 UDMA_CRC_Error_Count    -O--CK   200   200   000    -    0
200 Multi_Zone_Error_Rate   ---R--   200   200   000    -    0
240 Head_Flying_Hours       -O--CK   099   099   000    -    1355
                            ||||||_ K auto-keep
                            |||||__ C event count
                            ||||___ R error rate
                            |||____ S speed/performance
                            ||_____ O updated online
                            |______ P prefailure warning

General Purpose Log Directory Version 1
SMART           Log Directory Version 1 [multi-sector log support]
Address    Access  R/W   Size  Description
0x00       GPL,SL  R/O      1  Log Directory
0x01           SL  R/O      1  Summary SMART error log
0x02           SL  R/O      5  Comprehensive SMART error log
0x03       GPL     R/O      6  Ext. Comprehensive SMART error log
0x06           SL  R/O      1  SMART self-test log
0x07       GPL     R/O      1  Extended self-test log
0x09           SL  R/W      1  Selective self-test log
0x10       GPL     R/O      1  SATA NCQ Queued Error log
0x11       GPL     R/O      1  SATA Phy Event Counters log
0x80-0x9f  GPL,SL  R/W     16  Host vendor specific log
0xa0-0xa7  GPL,SL  VS      16  Device vendor specific log
0xa8-0xb6  GPL,SL  VS       1  Device vendor specific log
0xb7       GPL,SL  VS      37  Device vendor specific log
0xbd       GPL,SL  VS       1  Device vendor specific log
0xc0       GPL,SL  VS       1  Device vendor specific log
0xc1       GPL     VS      93  Device vendor specific log
0xe0       GPL,SL  R/W      1  SCT Command/Status
0xe1       GPL,SL  R/W      1  SCT Data Transfer

SMART Extended Comprehensive Error Log Version: 1 (6 sectors)
No Errors Logged

SMART Extended Self-test Log Version: 1 (1 sectors)
Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error

1  Extended offline    Completed without error       00%      1155         -
2  Conveyance offline  Completed without error       00%      1153         -
3  Short offline       Completed without error       00%      1153         -
4  Extended offline    Completed without error       00%      1015         -
5  Conveyance offline  Completed without error       00%      1014         -
6  Short offline       Completed without error       00%      1014         -
7  Extended offline    Completed without error       00%       669         -
8  Extended offline    Completed without error       00%       495         -
9  Conveyance offline  Completed without error       00%       493         -
10  Short offline       Completed without error       00%       493         -
11  Short offline       Completed without error       00%        31         -
12  Conveyance offline  Completed without error       00%         6         -
13  Short offline       Completed without error       00%         6         -
14  Vendor (0x50)       Completed without error       00%         1         -
15  Short offline       Completed without error       00%         1         -

SMART Selective self-test log data structure revision number 1
 SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

SCT Status Version:                  3
SCT Version (vendor specific):       258 (0x0102)
SCT Support Level:                   1
Device State:                        Active (0)
Current Temperature:                    42 Celsius
Power Cycle Min/Max Temperature:     24/42 Celsius
Lifetime    Min/Max Temperature:     21/54 Celsius
Lifetime    Average Temperature:        39 Celsius
Under/Over Temperature Limit Count:   0/0
Vendor specific:
01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

SCT Temperature History Version:     2
Temperature Sampling Period:         1 minute
Temperature Logging Interval:        1 minute
Min/Max recommended Temperature:      0/60 Celsius
Min/Max Temperature Limit:           -41/85 Celsius
Temperature History Size (Index):    128 (87)

Index    Estimated Time   Temperature Celsius
  88    2019-02-21 21:53    37  ******************
  89    2019-02-21 21:54    37  ******************
  90    2019-02-21 21:55    37  ******************
  91    2019-02-21 21:56    38  *******************
 ...    ..(  5 skipped).    ..  *******************
  97    2019-02-21 22:02    38  *******************
  98    2019-02-21 22:03    39  ********************
 ...    ..(  8 skipped).    ..  ********************
 107    2019-02-21 22:12    39  ********************
 108    2019-02-21 22:13    40  *********************
 ...    ..(  2 skipped).    ..  *********************
 111    2019-02-21 22:16    40  *********************
 112    2019-02-21 22:17    41  **********************
 ...    ..(100 skipped).    ..  **********************
  85    2019-02-21 23:58    41  **********************
  86    2019-02-21 23:59    42  ***********************
  87    2019-02-22 00:00    42  ***********************

SCT Error Recovery Control command not supported

Device Statistics (GP/SMART Log 0x04) not supported

SATA Phy Event Counters (GP Log 0x11)
ID      Size     Value  Description
0x0001  2            0  Command failed due to ICRC error
0x0002  2            0  R_ERR response for data FIS
0x0003  2            0  R_ERR response for device-to-host data FIS
0x0004  2            0  R_ERR response for host-to-device data FIS
0x0005  2            0  R_ERR response for non-data FIS
0x0006  2            0  R_ERR response for device-to-host non-data FIS
0x0007  2            0  R_ERR response for host-to-device non-data FIS
0x0008  2            0  Device-to-host non-data FIS retries
0x0009  2            1  Transition from drive PhyRdy to drive PhyNRdy
0x000a  2            1  Device-to-host register FISes sent due to a COMRESET
0x000b  2            0  CRC errors within host-to-device FIS
0x000f  2            0  R_ERR response for host-to-device data FIS, CRC
0x0012  2            0  R_ERR response for host-to-device non-data FIS, CRC
0x8000  4         9215  Vendor specific
1 Like

i believe i read this question incorrectly because i was incorrectly interpreting what i was seeing in the initial error. i thought the error was indicating that there was a bin (as in linux binary file) error. i was confused as to why that would be an issue with accessing an ntfs drive.

because that was just some random file on the drive and it is generally buried below the folder icons that i normally work with, i had no idea it was even there. now i feel a bit silly for posting that error. it is just a corrupted file that can’t be deleted or read.

adding the solution at the top (explanation below): i switched file managers from caja (the one installed with ubuntu mate) to pcmanfm (the one i use in bodhi and debian lxde) and was able to access the drive as usual.

aaaaand the culprit is…caja, mubuntu’s stock file manager. after reading through Akito’s first few questions again, i wanted to check in mubuntu to see if i could access subdirectories in the terminal. for whatever reason that got me thinking forward just a bit to doing the same in debian next. that train of thought made a brief (mostly non-sequitur) stop in a station apparently labeled “doesn’t debian use pcmanfm like bodhi?”

a quick install later, i was able to access my wd external as i normally do in bodhi. for whatever reason after caja runs into that corrupt bin file, it throws a popup window error and either can’t access (even after i close the popup) the other files on the external or gets caught in a loop as the loading circle just keeps spinning away.

i appreciate everyone who stopped by to offer helpful thoughts and tips. for budgetary reasons i will be sticking with the externals i have for the time being. i will consider reformatting at some point (if that is possible), but as ElectricDandySlider mentioned i will have to juggle some stuff as i don’t have any other externals with that much space.

edit: for whatever reason i am not able to choose this (or any post in this thread) as the solution. any chance one of the other mods can if they see this? i looked in other threads and most (please introduce yourself also does not) have the solution checkbox as a choice. this one does not for me.

1 Like

@abhishek any thoughts on why this thread doesn’t have an option to choose a solution?

@cordx Because the category is of an informative type, not an inquiring one.

1 Like

thank you for the info :slight_smile:

1 Like

at first blush that answer seemed to make sense, but on further reflection i got to wondering, “are hardware issues not solvable?” i’m not sure i understand the distinction.

It is not an “issue” in the first place. That’s why. It is just “information” about hardware.

agree to disagree :slight_smile:

@cordx We don’t disagree, because I agree with you. I am just saying how the Discourse forum sees it. So we agree both and both disagree with Discourse.

I have enabled the ‘accept solution’ feature for this category now.

3 Likes

thank you kindly, sir :slight_smile: