Ubuntu Sound issues

Hi All,

I have Ubunti 20.04 LTS and my speakers do not have audio. I have followed a bunch of guides from various different websites and I cannot get them to work. They are working when I use my work laptop but with my personal computer.

While audio is being played the computer is recognizing this. The speakers are being recognized by the system but still no audio. I have Logitech speakers that are being plugged in via usb.

If you would like my Alsa information I have it below.


Please help

1 Like

it will be helpful to know what you have already tried to keep someone trying to help from wasting the time suggesting one of those same options. no need for an entire blow by blow breakdown of everything, but a brief description should prove useful.

i’m not sure i understand that statement. originally you said your speakers do not have audio, but this statement says at least one computer does. is this meant to show that the speakers do work on a different system? and is your personal computer a desktop model?

how are you determining this? are you seeing audio output in a different way?

thank you for posting that :slight_smile:


Does the audio/speaker USB device show in “lsusb” (from the CLI/terminal)?

Does it show up in “Settings” (Settings > Sound)

at “Output Device”?

This computer (the screenshot source) only has one possible output when clicking on the select list for “Output Device” - but my other computer can have several, my USB3 Hub/Soundcard, my HDMI/Displayport output from my NVidia PCIe GPU, or one of two other USB audio devices (Jabra headset, and or Logitech headset via USB tranceiver).

If it’s not showing up in Settings > Sound > Output Device, I’d suggest you’re out of luck and it’s not compatible with your Ubuntu 20.04 installation.

During all this covid19 working from home stuff - I do this about a dozen or more times a day (Settings > Sound > Output Device / Input Device), having to switch audio output device and microphone source for Teams or Skype or WebEx or Bluejean meetings… And today my family all went out - so I switched to the HDMI/Displayport output device, which is wired out from my Lenovo monitor to Logitech 5.1 speaker setup, so I could crank up some loud music, extra loud, @ “eleven” on the volume dial :smiley: …


as was intended by the gods of sound and fury.


I followed the following guides


to clarify the speakers have audio when plugged into a windows laptop. My personal computer is a desktop.

I have a video playing on youtube and the blue soundbar is fluctuating



the two easiest and quickest places to check are by running alsamixer and pavucontrol (not sure if ubuntu has that one installed by default) in the terminal to check and see if anything appears to be muted. i had a quick look at your alsa info the other day when you posted it and didn’t see anything muted, but it wouldn’t hurt to check.

if those don’t work, has audio ever worked on this system?

1 Like

Yea Audio was working fine. If I unplug the speakers from the power source and replug them in the speakers have sound for about a second then no sound.

1 Like


this is the pavucontrol

1 Like

Screenshot from 2020-07-04 07-53-52

It shows muted anytime I change the output device type. The sound for these headphones also does not work over bluethooth. I can use my bluethooth headphones and the sound works

1 Like

This is the alsamixer

1 Like

how long ago was that and did you make any system changes (updates or upgrades) between the time it did work and when it stopped?

some clarification here would probably be helpful as well. can you provide some info about the headphones (both sets). make and model should be a good start. while we’re at it some info on the gaming speakers might also be useful.

do you get any sound if you plug wired headphones (or earbuds, just something else wired) other than the gaming speakers you are currently having trouble with?

1 Like

I got it resolved. I reinstalled Ubuntu back to its stock 20.04 version. So far so good. Thanks for the help!

1 Like

i use timeshift to help me out with system settings/upgrade situations like that in case an option that doesn’t require a full reinstall is of interest.

thank you for letting us know you got it sorted and what the fix was as well.

1 Like

Waking this up - just lately - having used a Macbook Pro for a bit - I reallly REALLY REALLY F–KING hate everything about "sound’ in Linux… it’s rubbish… not ready for primetime… pitiful…

It’s fine for playing games, watching movies or TV - but - when I want to hear music, LOUD, in full definition - Linux sucks great fuzzy balls of “sucky-ness”… Its rubbish…

I play a song on my Linux desktop - and - it sounds like it’s missing something… there’s a bunch of “oomph” that it’s not oomfing…

e.g. I take the same “reasonable” pair of Sony headphones (via 3.5 mm jack) to my Macbook - and I get a “shit ton” (that’s in the ancient Australian system of measures and weights - it means “a lot”) better volume range, definition and BASS…

And - I bought this particular AMD motherboard after reading a few articles on Tom’s Hardare and Phoronix late last year that recommended an X570-A chipset motherboard for Ryzen - and guess what? When I first installed Ubuntu on this thing - it got a sound “sink” of the MSI motherboard, now? Nothing! Just the crappy HDMI/Displayport audio output… I reckon that’s half my problem - no motherboard drivers for my soundcard are active - but - they were, and worked, when I first installed linux on this piece of crap…

Yeah - what am I complaining about - I know - still better than running Windows… But - personally, I’d rather be running Mac OS on M1 everywhere and bugger Linux and x86_64…

Well how’d ya be?

Just took a look in pavucontrol (e.g. “sudo apt install pavucontrol”) - I’d actuall disabled : “AMD Starship/Matisse HD Audio”… maybe time I took advice of :

Slight improvement in audio fidelity - even so - Apple does it better…