Ubuntu VM through Virtual Box on Pop! OS

I recently installed Pop! OS onto a MacBook Air 11" mid-2012 (i7, 8GB).

The OS works great. No complaints.

I installed Virtual Box with no issues and had a Kali system up and running in no time.

I tried to get an Ubuntu 22.04LTS VM running and once installed it just crashes back to the login screen continuously.

Any help gratefully received.

Can you explain a bit more.
You boot Ubuntu, get a login screen, login, it runs, then drops back to the login screen, as if you had pressed the logout button ?
Login again, and it repeats
Is that right?

Or is it actually crashing and doing a reboot, which will also lead to the login screen?
That sounds more likely?

I login, it goes to the desk top then goes back to the login screen. In a loop.

That is weird. I cant think of what would cause that?
The login screen is started by a daemon… for gnome DTE the daemon is called gdm… for other DTEs it might be sddm, lightdm, or lxdm.
So how about you disable the daemon. Easy way to do that is find out its name, find where it is (eg /bin) , go there and change its name.
Then do a reboot, and you should get no login screen at all, just a terminal prompt. Login from that prompt, and see if you still get the looping.
The windpw manager will not start… because that is normally started by the login screen daemon. You can start it by hand ( eg startx command… but it may be something else depending on your window system)
That will test if the login screen daemon is the culprit.
What to do next depends on the result.

On the Login screen after clicking on the login name, a cog will show up on the bottom right of the screen. Click it and choose Xorg. Wayland does not play ball in VirtualBox.

That sounds like a solution, and it is also valuable to know

@st8547 , you should abandon what I was suggesting and try Mark’s idea first.