Unable to install Linux Mint

I just bought Lenovo Idea Pad S145-15API Processor AMD Ryzen 5 RAM 8 HDD 1TB SSD 240.I tried various versions of Linux and many solutions but unable to install Linux. One message which i get is
“Integrity: Problem loading X.509 Certificate.”
Please help me Thank you

That’s hardly enough information to go on.

  • What version/release of Mint?
  • Did you verify the integrity of the ISO (e.g. md5sum or sha256sum)
  • Did you boot into Live Mode and run the desktop before your installation attempt?

Are you able to boot to the “live distro” (I assume Mint has a live mode) and use the O/S and it only fails during the install?

Seriously - it’s a meme on social media, almost always, online someone will say they’re having trouble doing “blah” in Linux, and some other person will suggest using Mint… probably not the answer in your case.

I don’t use Mint, tried it once, didn’t gel with me so quickly went back to Ubuntu, to all the Mint users out there, does the ISO for Mint have a live mode you can test drive it on?


I tried Mint 20.2,Ubuntu 19.3 Mint Xfc and Linux Mate as well.

Checked integrity of ISO

Doesn’t work in live mode.


Surely YES. :smiley:
Whenever I installed Mint back in those days, it was a live session where I started the installer…

I installed quite a lot laptops for friends and so, and I’m quite sure I met this message long ago, but I’m not sure what the cure was?
Isn’t this something special setting with UEFI? :thinking:

Checksum of ISO was OK?
Dooesn’t it boot?
If you try to get into the live session, you get the same x.509 error?

Better try LTS versions of Ubuntu. 18.04, 20.04, 22.04 (well, after april of next year :laughing:)

@pahal, can you disable secure boot on that laptop?
Look at this:

1 Like

I’d recommend Ubuntu 20.04 on Ryzen CPU…

There’s some stuff in 20.04 that works better on AMD Zen architecture, than does on 18.04 (but that might have been addressed in 18.04.6 [pretty sure it’s 100% fixed])…

So : if you can’t boot

Ubuntu 18.04.6 (make sure it’s the latest)
Ubuntu 20.04.3 (i.e. make sure it’s the latest)

Then I’m not really sure how I can help you… Only just last week I went through a major distro-hop on my Lenovo Thinkpad E495 (Zen+)…

Kubuntu 20.04
Fedora 23
elementary 6
and some others too I think…

I’d been running 21.04 on it up till then and on power up, it forced an update that I didn’t ask for - so I thought - that’s it NO MORE UBUNTU for me…

And then in the end, I ended up back at Ubuntu 20.04.3 LTS and will stick with this for a while… Maybe I’ll figure out if it’s possible to prevent future releases (e.g. 21.04, 21.10, 22.04) from forcing an update on boot - but until then I’ll stick with 20.04 - I need it for work, and Ubuntu 18 and 20 are the only releases I know how to get Checkpoint’s HIDEOUS SNX / SSL VPN client working…

I think what the esteemed Mr Kovacs stated - verify you don’t have secure boot turned on… Turning that off is one of the first things I ever do with my own personal hardware…

1 Like

First disable secure boot in your bios Then tell us what grapics card is in the machine if it’s a Nvidia card you’ll have to take special steps to get it going. Give us as much information about the Laptop as you can Make, Model, Ram CPU etc. It hard to find solutions without this information.

Thanks. Ubuntu 20.4.3 got installed