Unable to open a web link in a PDF via Evince (ubuntu document viewer)


Approximately a month ago (probably after an Ubuntu update, but I can’t be sure), clicking a web link in a PDF document from within Evince stopped working. I’m not aware that I have changed any configuration options. Web links clicked from a LibreOffice Writer document do function correctly. The trouble seems limited to Evince. Any ideas?

Additional Information (if applicable)

  • Ubuntu 21.10 fully updated
  • Document Viewer 40.4
  • Brave 1.32.113

Steps to reproduce

  1. Open a PDF document with Evince (Document Viewer) that contains web links.
  2. Click on a web link

Expected behaviour

  • Browser opens to the URL linked in the PDF document

Actual behaviour

  1. Mouse pointer changes to a rotating wheel of sorts for about 10 seconds, than back to a standard pointer.
  2. Browser is not opened

Extra details

These error messages are found in dmesg:

[32979.539575] audit: type=1400 audit(1638841732.708:94): apparmor="DENIED" operation="exec" profile="/usr/bin/evince//sanitized_helper" name="/opt/brave.com/brave/chrome_crashpad_handler" pid=39499 comm="brave" requested_mask="x" denied_mask="x" fsuid=1000 ouid=0
[32979.539807] traps: brave[39499] trap int3 ip:5616e1a1c3c1 sp:7ffe260ee8a0 error:0 in brave[5616dd77b000+9d5e000]
1 Like

Try xreader which is now available in Ubuntu 20.04, it’s a PDF reader and just works. xapps are what Linux Mint team put together. Finally a PPA for Ubuntu 20.04.
Website below with instructions to install. I currently run Linux Mint and have installed these apps in other Ubuntu 20.04 derivatives, using this PPA.

@clatterfordslim, unfortunately, this is not yet compatible with 21.10 (Impish).

Sorry that was me not reading everything. Your document viewer evince, was it installed via Snap or deb file?? The reason why I ask is because in 21.10 a hell of a lot of stuff does not work properly installed as Snap package. I have just looked as I have 21.10 in VirtualBox, it is the deb file. Install synaptic via terminal, open Synaptic pop password in and search for Atril which is Ubuntu Mate’s PDF viewer, I have just done so in VirtualBox and it seems to work alright. Uninstall Evince altogether.

Ok. Atril worked, but does not theme well with Gnome. However, I solved the problem another way. I uninstalled Evince from the ubuntu-impish-main repo, and installed the flatpak. It now works as it did before this problem began. @clatterfordslim, thanks for sticking with me.