Unetbootin - Ubuntu Mate

I have Mate 15 on my laptop and need to update it.
I installed M15 with unetbootin but for the latest update Im unable to get it to work. It seems to write the files fine but when you go to boot from the USB I get an error saying Missing OS.

Any suggestions?

have you tried a different usb or live usb creator? i’ve never used 15, but am fairly certain i have seen a startup disk creator in 16 and 18.

1 Like

Yea. I just tried going to every port - just to make sure, tried several USB drives, I moved from Kubuntu (my main system) to Ubuntu and tried disk creator and that didnt work either. I get the same two errors:

isolinux.bin missing or corrupted
and / or
Missing operating system.

did you verify the image? i use dd for most of mine, but recently had trouble getting void to write to usb so i switched to cd.

I did and still downloaded again.
I have not used dd.

I found my thumb drive with mate 15 on it that I originally used to
install the OS so I know at least at that point unetbootin worked then.
I moved from kubuntu to ubuntu to use disk creator. That did not
work either.

Im getting three possible errors:
isolinux.bin missing or corrupt (been researching this one)
Missing operating system
and
Not a bootable drive.

The first one is the one Im seeing the most so Im
focusing on that one now.

i don’t have any experience with unetbootin so i can’t help try and troubleshoot that part.

if you are interested in trying dd, the command is fairly straightforward, but you definitely need to be careful. it would be something like:
sudo dd if=~/Downloads/name-of-distro.iso of=/dev/sdX status=progress
followed by sync

it is, however, imperative that you choose the correct partition to write to for the second half (of=) of the command because you can overwrite your presently mounted partition if you get that one letter wrong. just this week i was seconds away from wiping out my timeshift snapshots backup drive because i recycled a command from my history and didn’t check of= carefully enough. luckily it somehow caught my eye before i typed in my sudo password.

so this part bears repeating. if you choose to proceed, verify and then verify again :slight_smile:

i use lsblk in the same terminal that i am going to use dd so that the info is right above when i am typing. lsblk output looks similar to:

NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sda 8:0 0 223.6G 0 disk
├─sda1 8:1 0 46.6G 0 part /
├─sda2 8:2 0 289M 0 part /boot/efi
├─sda3 8:7 0 182G 0 part /media/user/data
└─sda4 8:8 0 11.2G 0 part [SWAP]
sdb 8:16 0 16G 0 disk
└─sdb1 8:17 0 16G 0 part /media/user/usb-label

i can tell /dev/sdb is my usb because of the size and it’s mount location in /media/user.

in the command if= is where your iso is located so if you need to change that to ~/Documents or /home/user/isos (~/isos) or wherever you store that, you will need to adjust accordingly. status=progress will give you a status bar indicating how far you are in the write progress and sync will make sure that the write is definitely finished before you take out the usb in case you do.

i use dd because i tried etcher and some other methods when i was first starting in linux and had more bad than good results. dd has gotten the job done nearly every time.

even so, i would recommend not using it if you don’t feel comfortable doing so and have a good backup handy.

just because it also exists, there is grub 2/iso boot if the usb ends up being the problem.

Ok… just to be 100% clear
ws1@ws:/media/ws$ sudo mkfs.vfat /dev/sdb -I

mkfs.fat 4.1 (2017-01-24)
attribute “partition” not found

ws1@ws:/media/ws$ if=~/Downloads/ubuntu-mate-18.04.3-desktop-i386(1).iso of=/dev/sdb status=progress sync

Correct?

ok… noticed sync was supposed to be on a different line.
But, it did not run. No errors. It does not start.

the dd command needs sudo dd in front. so your example would be:

sudo dd if=~/Downloads/ubuntu-mate-18.04.3-desktop-i386(1).iso of=/dev/sdb status=progress

then sync would be a separate command after that one is finished.

if you want sync in the same line , you could add && sync for:

sudo dd if=~/Downloads/ubuntu-mate-18.04.3-desktop-i386(1).iso of=/dev/sdb status=progress && sync

&& tells bash to run the second command only if the first completes successfully.

unless you were asking about the ‘attribute “partition” not found’ outupt? since i usually use gparted to make my partitions and file systems, i wasn’t familiar with that but it didn’t look like a good thing. this thread suggests you don’t need to worry (i never did bother doing so either. just wanted to see some written confirmation) about formatting the drive before dd.

Ok… it completed.
Inserted it and again ->
isolinux.bin missing or corrupt.
Operating System not found

ugh :frowning:

I was reading about a problem someone else had. There was a problem with the partition and it kept coming out as iso9660 instead of fat32. Opened gparted and wiped it, reformat as fat32 and Im running dd again. Post back in a bit…

hopefully that works. otherwise i was wondering if you had tried an entirely different iso like lu- or xubuntu just to check off that box.

Same problem.

Im going to have to do some more reading.
Yea, I might download one of the others just to see what the deal is.

Just looked in gparted and after dd writes to the drive the file system is iso9660 again. Now Im wondering… is that normal?

the mint 19 usb i created this week is also iso9660 in gparted. you might check the ubuntu 15 usb you said you found to see what it looks like.

this is the lsblk -f for my mint 19 usb though:

sdc iso9660 Linux Mint 19.1 Cinnamon 64-bit 2018-12-17-14-00-47-00
├─sdc1 iso9660 Linux Mint 19.1 Cinnamon 64-bit 2018-12-17-14-00-47-00 /media/user/Linux Mint 19.1 Cinnamon 64-bit
└─sdc2 vfat Linux Mint 19.1 Cinnamon 64-bit 044E-AC17

maybe this? (from the mint forum)

Try changing the boot-priority in the BIOS setup, so the USB is actually mapped as the-first-drive-in-the-system rather than the-first-drive-to-try-when-booting.

I have USB stick then USB hard drive 1 and 2 in the boot order and then when the computer boots I click F10 to get to the boot screen and choose USB - which it does seem to be hitting the usb each time because it is showing me those errors, otherwise it boots straight into Mate 15.

I would look but I messed up and over wrote it last night. I was trying several drives to be sure it wasnt a drive issue and I lost it :frowning:

I dont know if it is actually an issue after the fact though.

GOT IT!!!

Strange because Im not sure why.

I downloaded UM 64 bit … just to test. Same problems.
I was in bios and I made these changes:
Plug & Play O/S : changed to OTHER
Large Disk Access Mode: changed to OTHER
Quiet Boot Mode: changed to DISABLED
No Execute Mode Mem Protection: changed to DISABLED

… and with the 32bit back in- it booted!!
I have it installed and running.
I personally think 15 was faster than 18 but this
is what my client has so that is what I need.

i’m glad to hear you found what you needed :slight_smile: after seeing how many tries you had made to write the usb, i did a search for the error message as well and started to see some interesting bios settings that helped others.

if you don’t mind, i was thinking of adding this to the ubuntu category (or maybe general linux questions if you feel like it fits better) so that one of us can mark a solution. that way if someone finds the thread later they can make their way to a possible fix sooner.