Unetbootin - unrecoverable W10 and some linux version

#1

My sister-in-law just dropped her sons computer off. He was trying to use Unetbootin to dual boot (I think) Ubuntu and Windows 10. Ive been looking up errors similar to his " Minimal BASH like line editing is supported. For the first word, TAB lists possible command completions. anywhere else TAB lists possible device or file completions." … and ran into even more problems. Some have used boot-repair with success but I did not. Ive not tried to do this before (not wanted too either) but you cant access anything now and even F9 to access other drives is strange.

Anyone able to help attempt to recover this?

3 Likes

#2

FYI, it’s not an error, it is the introduction to using the GRUB rescue shell.

Direct Download to Boot Repair Disk

Definitely the best automated boot repair available. The only thing you need to know is which partition and disk GRUB is installed and should be installed.

2 Likes

#3

I found the article a talking about that and tried it out. It did not give me the options to fix the problem like it did in the article. I read through the report it gave though.

I decided he would just have to use ubuntu and suffer not having W10 :slight_smile:

2 Likes

#4

Thanks for the info on Boot Repair. I d/l a copy to play around with later.

2 Likes

#5

If he has no real need to have W10 then you have answered the question for yourself, get rid of it and do a complete fresh install of Ubuntu. My personal experience was that I kept Windows, because I thought I needed it and wouldn’t be able use things without it. Once I had discovered that, in my case Mint had everything I got rid of it and haven’t looked back.

Let us know how you get on with things as it is always nice to know.

2 Likes

#6

I was able to update grub to fix the boot for win 10. A little late for this :neutral_face: but if you want the details, I can post a link to where I got the info on how to perform the update.

2 Likes

#7

if you have a moment to share the details, that might be helpful for someone else that runs into this issue in the future :slight_smile:

1 Like

#8

Yes that would be very helpful to our community as I believe @cordx might have mentioned. Thank you

2 Likes

#9

The web page is “https://askubuntu.com/questions/661947/add-windows-10-to-grub-os-list”.
The details from that page that I used;

Sometimes os-prober is wrong.
Look at the UUID of your Windows 10 partition, for exemple:

sudo blkid /dev/sda2

Then edit /etc/grub.d/40_custom , and at the end of the file add:

menuentry "Windows 10" --class windows --class os {
   insmod ntfs
   search --no-floppy --set=root --fs-uuid $your_uuid_here$
   ntldr /bootmgr
}

Don’t forget to change the UUID.
And finally update your grub config file:

sudo update-grub"
--------------------------------------------
4 Likes

#10

Remained of my post.

For some reason after installing Linux Mint 18.3, my only boot option was Linux. I try it several times using both “Install by windows” and “Something else” during the install process. I would then restore my Windows partition and now the Linux option was gone and only Windows booted. Using the above procedure, both Linux and Windows is on the boot menu.

PS. For some reason the fonts keep changing on the posting and there was a limit on the length.

1 Like

#11

do you mind marking this as the solution? or i can. just so that it can be seen to have one from the outside and anyone looking will know where to find it :slight_smile:

1 Like

#12

Unetbootin is bad software, in my opinion.

1 Like

#13

He has a need - required for school. All their software is windows based but Im looking at other options.

1 Like

#14

I saw this from askubuntu. It did not work in this case.

1 Like

#15

Ive not used unetbootin so I cant say but from running through many many message boards before posting here - I can see whatever happened - it was not going to get fixed. Even through windows recovery - Unetbootin came up as the OS to fix. I thought … ??? >…??? Not happy with it.

1 Like

#16

You can make it as A solution but its def not THE solution. And it did not work in this instance. I have a laptop from a while back that has a similar problem (not mine but my nephews) so Im going to try several things to try to rescue it. Now I know why he wasnt using it.

1 Like

#17

Unetbootin never worked for me.Always some annoying bug.
My solution was to use Etcher software, ( make iso images ) and
works fine, no needs install.

3 Likes

#18

Unfortunately, educational establishments I know of have a MS licence that’s “free” to the pupils, who are obliged to use it for homework and planning. Depending which country you live in, that seems dubious from the point of view of trading laws, aggravating facts being the impostion of adverts and invitation to games every time you boot or come out of standby, and all those crashed drivers (see Epson scanners for example) at every update.

Furthermore, I think something should be done about the annexation by MS some years ago of everyone’s PC firmware (I’m not qualified to discuss the technical details, but it’s the cause of double-boot problems).

There seems to be some movement to getting a more unified approach to Linux as Windows rival, but there needs to be some trans-national governmental facilitaion.

2 Likes

#19

Welcome to capitalism. No child is left behind. In its principle, not much of a different story as with the Catholic Church, but at least capitalism doesn’t pretend to be ultimately good.

1 Like

#20

He took my laptop to school this week and used Calc. When the teacher looked at his screen she said she didnt understand how to help him. I told him this would happen and just to say - focus on what you want done - not the environment. Teacher made a big deal out of it and I made a bigger deal out of it talking to the school admin. That just totally stupid. He still did his work, got his grade, but his mom is getting another copy of Windows for him for his laptop.

1 Like