Update problems with Ubuntu 22.04

I installed several weeks ago Ubuntu 22.04 on a Samsung N150 Plus netbook. The older operation system was Ubuntu 20.04 which worked not perfectly but it worked. Now I don’t have anymore an internet connection, so it is impossible to contact for example the repositories to make necessary updates. in the meantime I have got a lot of messages e.g.:
Unable to install updates: status-code = 409
kinde = snap-change-conflict
message = snap “firefox” has “auto-refresh” change in progress
Unable to update “Snap Store”
(null: cannot refresh “snap-Store”: snap “snap-store” has running apps (ubuntu-software), pids: 2070
Unable to download updates:
E: The repository ‘cdrom://Ubuntu 20.04 LTS_Focal Fossa_-Release amd64 (20200123) focal Release’ does not have a Release file.
And so on …
That’s quite a mess which I can’t resolve. Is there anybody who can propose solution?

I think I would just reinstall Ubuntu.

Took that long to find out you did not have an internet connection?
Maybe you should restore your backup of 20.04.

Seriously? This is a weak sluggish underpowered ATOM CPU machine.

I have one - I’d NEVER run a 64 bit distro on it! Ever!

I’ve even boosted mine up to 2 GB RAM and a 64 GB SSD. The best experience I had on ti was Manjaro 17 32 bit - but Manjaro no longer do 32 bit… But it was surprisingly snappy running Manjaro 17.

I’d suggest Debian (32 bit) XFCE … You might, just “might”, be able to run Xubuntu or Lubuntu (I hate LXDE - so I’ve never tried this) THIRTY TWO bit on there - but give up any ambission to run a 64 bit distro on an Atom… Sure - it’s technically a 64 bit CPU, but 64 bit processing on these just slows the whole thing down…

I’m sure Debian will continue to have 32 bit releases in future - but - I reckon you might be just about ready to either :

  • be statisfied with Ubuntu 18.04 (32 bit)
  • dispose of it
    (I actually plan on keeping mine anyway - I don’t use it - but I’m a bit of a hoarder)

I just checked AARNET (Aussie mirror for most stuff) and the last 32 bit version of Ubuntu or Xubuntu was 18.04.

Debian 11.6 has ISO for download for 32 bit i386/i686…

What will happen with Debian install on here, however, will be that you will have to probably do some hunting around for WiFi drivers - as Debian won’t support the WiFi chip… You might be able to find a Debian 11.6 with “NonFree” additions ISO - I’d recommend that…

Dan’s probably right about a less-demanding distro. You might also try a clean install of a more current distro, like Xubuntu 22.10.

You cannot update system without internet.

Now, why don’t you have internet connection? That should be the problem we try and fix.

Just for a “thought exercise” I’m trying out AntiX in VirtualBox to see what it looks like…

I strongly recommend AGAINST x86_64 on Intel Atom platform - you’ll have a much better experience with 32 bit (i.e. i386 or i686) intel CPU distro… i.e. that pretty much rules out Ubuntu (and derivatives) 20.04 onwards - you can still get Xubuntu 18.04 in 32 bit (they never did a Ubuntu 18.04 for 32 bit).

If I can find the power brick to my N150 - I might even give it ago on that - if it seems okay in VirtualBox.
– – – update – – –
Meh! Don’t think I’ll spend much time on AntiX : “Hello the 1990’s called, they want their X Windowing system back!”…
– – – update – – –
I just checked out Emmabuntus (I think I first saw it mentioned by @Rosika on here?) 32 bit running in virtualbox (2 GB RAM, 2 cores, 18 GB storage) and it’s actually VERY SNAPPY and I’m very pleasantly surprised…

If I can find my N150 and its power brick I might give it a go!

Would also be pretty nice on a Raspberry Pi 3 or 4… but there doesn’t seem to be an option for that.

Sure - it looks kinda like MacOS OS X looked about 20 years ago - but hey, that was still prettier than KDE back then, or Windows XP or Vista!

I might see how well Cairo Dock performs on there - but - I noted maybe ~10 years ago, Cairo dock was WAY heavier and less reliable than simple Plank - I don’t use either now, I just use a dash 2 dock extension in gnome…

Running a fairly recent kernel too (5.18) :

VirtualBox virtual framebuffer won’t do N150 resolution 1024x600 - so the above is 1024x768 - still VERY usable with such restraints in mind…
– – update 3 – – –
Strike what I wrote above - Emmabuntus can’t even update - and this is meant for beginners? Mums and dads and senior citizens? Something is screwed up with DNS or ipv4 or something.

It’s running in VirtualBox with “Bridged Adaptor” (this is the point where most Kali numpties get stuck) and it SHOULD be able to DHCP like EVERY other VM I fire up with “Bridged Adaptor” - but it’s got an IPV6 address (which is bloody USELESS!)

Out of the box and its like this? I can’t be arsed trouble shooting (but I did anyway!)… And don’t get me started on the piece of crap Cairo Dock - it doesn’t even work as a task switcher and doesn’t have a dock item for terminal, and doesn’t show terminal even when it’s running! All stuff that Plank does out of the box - I’d rather an XFCE4 panel than Cairo Dock which is NOTHING like any Dock I’ve seen recently (Plank, MacOS, Gnome Dash2Dock).

“Advanced Network Configuration” enabled me to select manual IPV4 settings and I can now ping and DNS internet stuff - but - how can this pass muster when the intended market is for senior citizens? Noble effort but they didn’t test enough? What happens when Grampa Joe wants to add an icon onto the dock?

I suppose the idea is that the initial config is done by someone IT savvy before the legacy hardware is handed over to the user…

Apart from these niggles - I guess it’s okay… Once I fixed up its shonky DHCP (by setting IP address manually) I could DNS and apt update and apt install - installed plank in place of Cairo Dock - sure it don’t look as “purdy” but it’s WAY less of a systemload than Cairo Dock, and way more dynamic (knows when I’ve got a terminal running) and I can right click on an item and select “Keep In Dock” (kinda like on Windows) and if I want a less cluttered dock (Cairo Dock’s HIDEOUSLY cluttered in Emmabuntus) I can just drag and icon off it - and get a clever little “poof” of smoke as it disappears :slight_smile:

Enabled Compositor in “Window Manager Tweaks” and now I can do transparency in terminal, and Plank looks even betterer :

Revised estimation - it’s a nice Debian based XFCE4 (4.16) and runs pretty good in limited resource scenarios… But still some gotchas and caveats for the unwary.

3/5 stars :slight_smile:
– – – Note : I can’t find my N150 or the powerbrick - I suspect its in some storage crate at the bottom of a stack of storage crates…

1 Like