Updating Kernel

Hello, 20.04 LTS updated from kernel 5.8.0-48-generic to 5.8.0-50-generic. During the update I worked on the machine like ever. Update needed a restart. Just powered off at night and started this morning. Suddenly the machine starts as if 20.04 is newly installed. All adjustments are gone, like Brave/Dissenter etc. etc. How do I get them back without having to install them all over again?

This sounds extremely unusual, because a simple kernel update shouldn’t have an effect like that, in any case. Are you absolutely sure, you only upgraded the kernel and changed nothing else?

1 Like

I don’t want to be repetitive, but:

This is exactly what tools like timeshift were created for.

3 Likes

Hmmm.
I would say the same as @Akito said, a Kernel update does not have such effects (usually).

I have not experienced such a behaviour in the past upon Kernel updates so far.
I know this is not helpful, but maybe something other happened just coincedentely that caused this…

1 Like

This is weird, unless for some reason that Kernel has hidden all your installations and adjustments. At boot just before Ubuntu splash screen push shift, you’ll get into a boot menu, go down to advanced and choose the previous Kernel.

Also why are you using 5.8.0-50 Kernel, when I’m on 5.4.0-72 and only just updated to it a couple or three days ago, plus never lost anything??? Ubuntu 20.04 comes with the 5.4 Kernel series and I have found nothing wrong with this series of Kernels. Ubuntu 21.04 is coming with 5.11 series. Your 5.8 is end of life in November this year, where as the 5.4 is end of life in December 2023. My advice would be to install the 5.4 back, as there seems to be problems with Ubuntu running 5.8 on your hardware anyway.
At least stick with the recommended Kernel of 5.4.0-72 for Ubuntu 20.04.

I have four instances of 20.04 LTS on four different machines. Some are 5.8.0-whatever and some are 5.4.0-whatever. I have left kernel updates to the whim of the OS and cannot explain the difference.

I’ve never had settings vanish as a result of a kernel update. They do vanish as a result of a fresh install, though.

1 Like

Dear Akito,
Thank you for your answer. Yes it is extremely unusual, I work with Ubuntu since 2007 and did never have any problems like this. And no, I am sure I haven’t done anything else, I was to busy writing. Anyway, I took the advantage to change to PCLinuxOS2021. Something new to try. Thanks.

Dear Clatterfordslim,
Well indeed, it made me think. As I told Akito, I took the advantage to change to PCLinuxOS2021. Something else, something new. I did not loose much, my back-ups saved me. Thanks.

Dear Mina, that’s exactly what I use ;). So the damage wasn’t that bad in the end, but it takes a lot of work. It seems there isn’t a way to spare time. Just install all over, with a different kernel or like I did, shift to PCLinuxOS2021. Thanks!

Dear Don.Karon,

That’s what I did. Let the software decide when an update was needed. That always worked fine. Till now. Thanks for answering.

It’s weird because the new Zorin OS 16 Beta is using the same 5.8 Kernel. Whether or not on final release, whenever that’ll be? They’ll change it back to 5.4 I don’t know?

While it should have updated on whatever hard drive your using, just speculating, but, are downloads like this stored in RAM?
Powering off computer and not re-starting would mean anything in RAM would be ‘lost’ when the capacitors on mobo power down.
I’ve always gone for a restart after a kernel update and so far haven’t had any problems
As suggested, boot to an earlier kernel , see if everything is where you want it then try again

I’m running kernel 5.8.0.53.60, on Ubuntu 20.04.1… The two newer kernels in the 5.8 group I removed, as the length of the boot was simply too much. Plus, my video resolution, normally 2560x1440, changed to 1024x768. The running kernel was the last of the 3 kernels shown in the grub “advance options,” so it is the primary now.