USB BlueTooth Headphones used to switch to them when activated in KDE

But now I have to disconnect and reconnect to get them to switch to them instead of HDMI Speakers. How can I fix this?

So hotplugging the usb activates it?
I think you need to look at why a usb device does not activate if it is connected when you boot, but activates if you hotplug it.

I have had that behaviour with usb disks, and also the reverse… only activates if present at boot

Not sure where to look

PS It might be hardware. Try another usb port

1 Like

Something about grandmothers, and emptying an eggshell via some sort of mouth vacuum action : try another USB cable too! I LOATHE how some vendors ship CHARGE only USB cables - it costs nothing more to let them run data… they’re just stingy extortioniists…

Man - the dramas I’ve been through recently - TWICE - getting stuck - some computer or other won’t connect via ethernet, so, I try another port on the switch - no good… Try another switch, no good… jiggle it about… no good… try another cable? ALL GOOD! But - what did I do with the dodgy cable? I hung it up again with all my blue ethernet cables - AND - DID IT ALL AGAIN! (needless to say - 2nd time around - it went INTO THE BIN!).


Just been thru all that with our phone line and Telstra. Seriously considering fixed wireless for our phone and internet. We need someting better than copper wires runnig under flooded paddocks.

Do you remember SCSI cables?. They were always giving trouble.

I sure remember SCSI cables… I remember a SCSI multihost EMC Symmetrix (technically a SAN, because SCSI was a type of network, but I had an argument with an alleged “technical architect” who declared it NOT a SAN - I still think he was wrong the opinionated c-ckhead!)… Anyway - we decom’d it and replaced with an EMC CLARiiON (using fibre). Anyway - one of my jobs was to decom the MASSIVE (nearly an inch thick) rubber coated SCSI cables, they were like 30-40 metres long, each - and I took one look under the subfloor and decided I was LEAVING THEM THERE! Generally - that EMC Symmetrix was an ORDER of MAGNITUDE more reliable than the EMC CLARiiON (those things had fault tolerant “heads” which ran Windows NT 4.0 and - yeah - it would, and did, BLUESCREEN! They were very tolerant of bluescreen crashes anyway).

Long story short - I too am seriously considering fixed wireless… I’m on hybrid (I call it BASTARD) FTTN NBN - technically should be capable of 100 Mbit, paying for 50, and getting on average about 30 Mbit… For around the same price - (or maybe a tad more) I can get GUARANTEED 100 Mbit fixed wireless…

Good thing about Fixed Wireless, is I could connect, and use both - i.e. there’s no “cutover” like there would be if I switch ISP’s or whatever… The fixed wireless doohickey the ISP would supply is just an ethernet connection for my existing router (or a spare if I have one - I bought a wifi router years ago that billed itself as “NBN Ready” - but that was when NBN was going to be ETHERNET and FIBRE to the home!).

Sorry, my post is confusing. There is a button on KDE Plasma to disconnect and reconnect the headphones. That’s all I have to do as a work around. The bluetooth adapter is USB without a cable. The headset is bluetooth wifi. I just tried another usb port, same issue. The headset connects, but KDE neglects to make them the default output. It used to work as soon as I turned on my headset, they would connect AND KDE would make the headset default output.

Are you sure it’s bluetooth? Sounds more like 2.4 Ghz “wireless”.

I have a pair of Logitech “wireless” headphones, that do “both” - i.e. they can do BlueTooth to my phone or a PC, or, I can use the Logitech 2.4 Ghz dongle… Note : they were pretty much plug and play on Ubuntu with the dongle… I stopped using them 'cause they only have 3 hours battery life - compated to the Sony Bluetooth (only) headset with BASS boost that has 30 hours battery life…

I was using those logitech pair recently, because they have “boom” fold out microphone… but I ended up realising the the microphone on the Bluetooth Sony headphones is BETTER than the logitech one on my Mac…

OK. I was thinking a udev issue, but you say it connects but KDE doesnt route things properly. Sounds more like a KDE issue… Sorry , dont know much about KDE.

1 Like

Things to watch. Performance degrades in bad weather - not as bad as satellite but still an issue. Need line of sight access to tower.

We used to put external SCSI devices on PC’s and workstations … like USB today but the cabling was a nightmare.
Had to be daisy chained with devices in a particular order and terminated.

I’m sure it’s bluetooth

Thanks to everyone who responded. I will have to live with the workaround.

What happens if you boot another linux without kde? A live dvd would do, just to test it.

1 Like

I sort of tried a different OS when I loaded this last OS Opensuse Tumbleweed and it worked for a while until an update broke it. If I reinstall Tumbleweed, it should work at least until the first update. I came from KDE NEON.

There is your clue.
If you can track down what was in the update, might be able to blacklist something.
Or, the update may have changed config files. Have a browse around and see if you can see anything different in /etc or home directory dotfiles. You might fluke it.

ls -lt
will show me dates changed, but I didn’t learn about it till weeks after the update. I will reinstall Tumbleweed in the future and use the command above after each update and figure out which file breaks it and use timeshift to restore that file and keep a copy of it in a certain folder and set up a service script that will copy the fixed version of the file at boot up to the correct folder and never have the problem again. Thanks for the tip @nevj

1 Like

I need to learn about that. Thanks