Vlc player: cannot choose custom skins

Hi all, :wave:

I was just trying to use a custom skin in vlc player (3.0.16 Vetinari). For this I placed e.g. JVC-VLC3.vlt
in /home/rosika/.local/share/vlc/skins2 .
So in theory it should be available for selection by vlc.
But I didn´t get that far. :slightly_frowning_face:

The problem is: I cannot open (not even choose) the respective folder from within vlc:

vlc ---> Tools ---> Preferences ---> Interface --- > use custom skin ---> Choose.

It´s the last point “Choose” which seems to fail. Clicking on it doesn´t do anything. :thinking:

Does anyone have any ideas about what might be wrong here :question:

Thanks a lot in advance and any greetings.
Rosika :slightly_smiling_face:

Hi Rosika,
You added a file to a folder, and now VLC cannot access that folder?
File permissions maybe?
If you remove the file does VLC work?

Regards
Neville

1 Like

Hi Neville, :wave:

thanks for your answer.

No, it´s not that.
Upon clicking on “Choose” …

absolutely nothing happens. I cannot access any folder as no window for selecting anything opens up.
No idea why that is. :thinking:

Many greetings from Rosika :slightly_smiling_face:

Is the Choose button active, or is it greyed out?
If it is greyed out the option is not available for some reason… maybe could fix that
If it is active there is a bug in VLC … not easy to fix

Hi Neville, :wave:

thanks for your views on the matter.

O.K., it seems to be a bug then.

The “Choose” button is not greyed out and upon clicking on it I even get an optical feedback. But no effect is triggered off.

Opening additional windows for selecting a file is not a general problem though.

E.g.:

vlc ---> Tools ---> Preferences ---> Video ---> Video Snapshots ---> Directory ---> Browse
indeed opens a new window for selection.

It´s just the customs skins path which is problematic.
In Lubuntu there was no problem with that. But I guess there was another version of vlc on it.

Well, it seems there´s not much that can be done right now. Thanks a lot, Neville, for providing your opinion.

Many greetings
Rosika :slightly_smiling_face:

Unless you can find another version of VLC you are stuck

It is a bit unusual… VLC has been around for years. Do you get anything googling for VLC errors?

1 Like

Hi Neville, :wave:

Couldn´t find anything.
Perhaps I should post it on the VLC forum.

They say on Report bugs - VideoLAN Wiki :

If you find any bugs, or if you experience any crashes, then we would very much like to hear about the issue.

I´ll have to create an account first though.

But thanks a lot, Neville. :heart:

Many greetings
Rosika :slightly_smiling_face:

Just out of curiosity, Is it a snap package?

Hi @JoelA, :slight_smile:

no, I´m glad to say it isn´t a snap package.

Linux Lite comes with no snaps and snapd isn´t even installed. :smiley:

Many greetings from Rosika :slightly_smiling_face:

Hi all, :wave:

I could finally solve the problem. :smile:

Rémi Denis-Courmont from videolan suggested

Did you install the skin engine module at all?

That was it. LL came with vlc preinstalled but without the skins2-plugin.

Here I saw another user once had the same problem.
The solution was:

sudo apt-get install vlc-plugin-skins2

and after the installation I get:

vlc --list | grep skins2
VLC media player 3.0.16 Vetinari (revision 3.0.13-8-g41878ff4f2)
  skins2                 Skinnable Interface
  skins2                 Skinnable Interface

(vlc --list: print a list of available modules )

Now the respective folder can be opened and the .vlt file selected via GUI. :+1:

O.K., that´s it.

Thanks so much to all of you and many greetings.

Rosika :slightly_smiling_face:

1 Like

Hi Rosika
There is still one puzzling detail here
If the plugin was missing, the button should have been greyed out.
You said it was inactive, but not greyed.
That is still a bug

Regards
Neville

1 Like

Hi Neville, :wave:

You´re perfectly right, Neville.

Not only was it not greyed out before the installation of the plugin but it also gave an optical feedback when clicking on it. Apart from that feedback nothing happened of course.

Thanks for your comment.

Many greetings from Rosika :slightly_smiling_face:

2 Likes