VMWare machines and failed Gnome displays

I have three VMWare machines hosted in a Windows partition. I have had Pop! and Debian for nearly 2 years, and recently installed GhostBSD (thanks, Neville!).

Just this week, a similar problem hit both Pop! and Debian. The screen is blank, the cursor shimmers between a pointed finger and an arrow, and the keyboard does little. In both cases, I tried recovery, booting to different kernels, etc.

Debian seems to jam at the Gnome Display Manager; it freezes for about 20 seconds and the letters on display flicker. I cannot figure out Pop! but since the behavior is nearly identical and both are running Gnome DE, this seems the likely problem.

I thought the kernel might be the issue, I recently updated the Neon kernel to 6.2 on a partition (no problems) and both Debian and Pop! are at 6.6, but the recovery lists older kernels that don’t help.

Can an installation in a VMWare machine be fixed from the ISO? Is there a better way to revert to a previous kernel? Since these machines are just for geeky fun, I don’t mind deleting them and trying again (or other distros).

I have almost exactly the same issue with Pop!_OS on bare metal - and - VirtualBox VM (hosted on the same Pop!_OS desktop machine).

In both cases - I couldn’t figure it out - the login screen never appears… So I disabled GDM (sudo systemctl disable gdm ; sudo systemctl stop gdm) login to the virtual TTY (they’re damn tricky to get to when virtualized) e.g. ctrl+alt+F3, F4, F5 - then login via console TTY session (i.e. text mode login to CLI / bash) then once in bash “startx” gets me my desktop…

This happened to me also - nearly the same time as it started happing on my desktop machine (AMD) in Ubuntu 22 or 23.04 on my AMD Thinkpad - but getting a TTY was even trickier - and I just had to wait and see, and wait some more - then login to TTY and run “startx”. Gave up on it and installed Pop!_OS 22.04 on it - so far, so good, not holding my breath or nothing though…

So it’s not only me then, no closer to resolving it, but at least I’m not alone :smiley:

I don’t actually expect a timely resolution for my desktop machine - I’ll probably just re-install from scratch using the latest Pop!_OS ISO image (which I used to build this AMD Thinkpad I’m typing on now) - but I can live with my work-around - logging into TTY and running “startx” doesn’t bother me in the least… I built this system in March 2023 - and - 10 months is a long time for my desktops to travel without a complete fresh re-install - what I can’t be arsed with is re-installing all my Steam library again - because - all my important data and configs is stored on my self hosted cloud solution (Resilio Sync)…

1 Like

I take it that Ghostbsd is OK.
So the issue really revolves around a recent update to Pop and Debian.
If you reinstall from your original iso, then dont update, the issue will probably not appear… but that is hardly a solution.
You then wait for a new release, and hope that fixes it… that is a long wait with Debian.

So why not try some non-debian distro in the meantime…
suggestions would be OpenSUSE, Arch or a derivative, Solus, Void, Gentoo.
There is plenty of choice, but going away from Debian is a learning curve because the package managers are all different.

If the issue is a display manager problem, it is possible to
edit the filesystem of say Debian from outside ( that is difficult with a VM), disable the display manager ( eg rename
/usr/bin/gdm ) then boot and you should get a console login prompt. You can then either start X11 with startx or you can install a different display manager, eg lightdm.
That is roughly equivalent to what @daniel.m.tripp did.

Display managers are notoriously troublesome.

Another thought , do you have to have Gnome? If you installed Debian or Pop with say Xfce or KDE, the issue would probably be avoided.

1 Like

I read about an issue like this on Reddit in the Pop!_OS and/or Ubuntu subreddit a couple days ago. No definitive solution that I saw.


I have mixed results to report.
I tried most of the above suggestions, especially sudo systemctl stop gdm. But needless to say, I do not remember what order I did them in., and have reason to believe that it was a mistake to run sudo systemctl disable gdm
In both cases, I am brought to a TTY prompted for login and password.
In Debian, I enter user/pw, then at the command prompt I enter:
sudo systemctl start gdm
and the old Gnome desktop returns, but it starts more slowly.
In Pop!, it is just an endless loop of TTY prompts. This is why I think the disable command was a mistake.
The return of the Debian Gnome display is a partial success. I just wish I knew how to skip that extra series of steps to start it.

1 Like

Cant you reverse it with
systemctl enable gdm

The old fashioned method of getting rid of a rogue display
manager is to login in single user mode and change the name of the gdm binary. Then it cant find gdm, and you will get the console login prompt.

1 Like

Not sure if I was clear or not - I disabled it and stopped it (or reverse order of that)

sudo systemctl stop gdm
sudo systemctl disable gdm

This is not a “mistake” in my use case, it WORKS on both bare metal, and virtualized, with Pop!_OS 22.04…

I had this (endless loop of tty prompts) on my Thinkpad with Ubuntu 22 or 23 - took forever for it to eventually stop looping - but eventually it did, I could login, and run “startx”.

That doesn’t happen on Pop!_OS on my AMD desktop machine, or virtualized in VirtualBox. With GDM disabled - soon as its finished booting - I get a stable constant (i.e. not looping) TTY prompt, I can login and run “startx”.

I’ve since re-install Pop!_OS from scratch (using a much later ISO build than the previous one) on my Thinkpad and haven’t seen that issue resurrect its ugly head - but that same ISO had issues on VirtualBox (as described previously).


Cant you reverse it with
systemctl enable gdm

I did not copy the exact text, but it said something to the effect that this request isn’t something you can do with the systemctl command, then offered a list of many explanations.
I have given up on this Pop! VM. I’ll wait for some sort of major update. If that doesn’t work, I’ll just delete it. When it is released with Cosmic desktop, I may create a new VM.

Meanwhile, Debian seems to be working fine but for he unnecessary steps to log in. A reminder: When I boot, the first screen shows a TTY login, then PW, then drops to a command prompt. Here I enter systemctl start gdm and then it is back to normal.


Well, somehow (and not due to any skill on my part) the Pop! VM is working. Here, as best as I can figure, are the steps
First, I booted to the CLI. I ran update && upgrade and saw a large number of libraries were being installed.
Then, I tried startx again. Imagine my surprise when it booted back to a basic Gnome desktop layout!
I ran an update from the PopShop window, mostly various runtimes
I rebooted, got the TTY login, then at CLI I entered sudo systmctl start gdm and it returned to that original Pop! layout
So now, I have four steps added to those two VMs but they are restored to their original display.


Your good luck.
It seems like there was some faulty package and the upgrade
fixed it.
It can be a lottery.