Webcam and mic suddenly not working on Pop OS


I have a fingers 108- hi res webcam which war working fine till the last month.

I opened my Pop os 22.04 after a month and its not detecting the webcam and the mic

Tried various solutions from web but non worked.

This is what it looks in settings

Please help as soon as possible!

Thanks in advance!

From the Terminal, run


In here, press F6 to select sound card and make sure that you see and select a sound card:

1 Like


First of all, thanks for the reply.

I saw 3 options:
default, intel and nvidia

Tried all three but none of them captured the mic. :frowning:

Any other solutions?


I just tried the solution u gave and i noticed something:

Here u can see the card and chip is shown as pulseaudio while it should be pipewire right?
Maybe it happened becuz I tried various solutions from internet yesterday, or maybe because of any other reason, I dont know!!

Any help would be appreciated and respected!


That could be the reason because if I remember correctly, Pop OS switched to Pipewire with version 22.04.

Try this and see if it works.

Reinstall Pipewire:

sudo apt reinstall pipewire pipewire-pulse

And then enable it:

systemctl --user --now enable pipewire pipewire-pulse

Now see if it works or not. You should not need it but still, reboot if it is not working immediately.

1 Like

Tried it , no luck.

Thanks for quick response btw.

Any other solutions?

Too bad.

Does it at least show Pipewire in Alsamixer now?

Perhaps try changing the sound card?

System76 has a dedicated page… but please make Timeshift backup or something like that so that you can restore things later (if you mess it up further).

I have to go out now (Sunday is for family). I will check the discussion again in the evening. Good luck.

1 Like

Okay so I identified that the prob is with the webcam(hardware).

Sorry for bothering and disturbing!:pray:

Thanks for the quick responses though!