Widevine drops support for 32-bit operating systems

I have 32bit machine with linux, Ubuntu 18.04.05, it plays Netflix fine until very recently. But widevine has withdrawn support for 32bit linux during june21. I am trying to work out how to install an old version of a browser that came with previous version of widevine. Can anyone recommend command line to do that?

Greetings and welcome. :wave:

Please try to avoid the following:

We should first identify the problem you have and then find an appropriate solution, instead of targeting a solution, without clarifying the problem, first.

Could you elaborate what your problem is?
Do you want to play Netflix on a 64-bit OS or what is your goal?


Unfortunately there is no alternative, it’s not Firefox’s fault it’s Google’s fault.

It’s another way of Google taking control of everything, forcing 32bit machines to go extinct. Meaning old hardware to be trashed. Forcing everyone to upgrade to 64bit. If you’re running a 64bit processor and your ram is only 1GB, meaning you’re running a 32bit OS, find out if you can upgrade the ram to say it’s max, at least 4GB for running a 64bit machine smoothly. Loads of 32bit machines out there with 64bit processors, that run really slowly because they don’t have the recommended ram to run 64bit, plus your average person, who just wants their machine to do everything they ask it to, normally has no clue about the technical side.

I have a Windows 8 tablet PC, that has a 64bit processor, yet Intel and Windows locked it down to 32bit only. I tried to install 32bit Linux on it and it locked me out every time. I also tried a 64bit Peppermint, but found it is locked to a 32bit EFI. How do you write a 32bit UEFI code onto a 64bit OS for Linux? You can’t.

1 Like

Somewhere 1-2 years ago read about how to workaround this. I wasn’t much interested, but remember it was a clever hack, but can’t recall details. I’ll dig it up for you - hopefully I’ll be able to find it.

Oh yeah… :smiley:
I met it originally here: Selecline netbook USB boot | ubuntu.hu
The OP’s problem was the same, wanted Linux on a 32 bit UEFI thing.
There are the suggested links to solve in the first reply, those are in english.
1: A sorta-beginner’s guide to installing Ubuntu Linux on 32-bit UEFI machines. | by zedgoat | Medium
2: linuxium.com.au: Running the latest Ubuntu on the Intel Compute Stick
3: 32-Bit UEFI Boot Support - Ask Ubuntu

And I found this myself too:
Need grubia32.efi - Linux Mint Forums


Thank you for this, will try again on that machine and let you know how I get on. :smiley:

1 Like

The problem is, is Netflix will still say it is unsupported, even if you find an earlier version or nightly build of Firefox. I would of thought so anyway? :thinking:

Thanks all. Yes my original goal is to play Netflix (and some other TV channels like ITV hub in UK) on my fairly old computer, which is running 32bit linux, Ubuntu 18.04.05. I expect it is correctly identified that this is problem with Widevine drops support for 32bit linux.,clatterfordslim, thanks for mentioning that installing old browser is unlikely to help.

Having read all above, I think i best try install a 64bit OS…So new question:

Processor is “Intel i5-2430M CPU @ 2.40GHz × 4”, memory is 3.8 GiB,…I am familiar with Ubuntu, so will try that in 64bit first. Any other distro’s recommended for me with this old computer, low RAM, and limited linux command line capability? To watch media (HD not required), surf, and use openoffice.

Thanks all.

With XFCE (XUbuntu) or MATE (Ubuntu MATE) should be fine.

Do you know whether the ram on your machine is soldered on or not?? With this Processor you can have up to 16GB of DDR3 ram. Not just any, but must be the same make you have in your system now and spec too obviously. I’d see if it can be upgraded to say a nice round number like 4GB of ram. That 3.8GB is a weird 32bit number only. By all means try a 64bit OS and please let us know how you get on?

I’d suggest 3.8 is yet another instance of the onboard GPU being allocated RAM… i.e. it’s being used by the graphics card…

4096 - 256 = 3840

I wouldn’t necessarily agree… e.g. the Dell Latitude I keep on my desk at work, has one 8 GB “Dell” branded and labelled LP-DDR3 module (note - generally motherboards that expect LP-DDR3 will not work with non-LP), it’s paired with a Kingston “generic” 8 GB LP-DDR3 module, never skipped a beat (and identical modules in my Gigabyte Brix NUC)… I got the Kingston RAM from a local “computer bits out of China, Taiwan and South Korea” outlet… Only thing that might happen, if they’re different speeds, they will both run at the slower speed, and if your system supports dual channel, it may no longer run in “dual channel” - odds are you may not notice the difference.

Of course - there’s every chance the “Dell” branded RAM is the EXACT same RAM as the Kingston with different labels…

And - also - YMMV (your mileage may vary) - don’t take this as a guarantee that any RAM will work. I’ve never experienced incompatibilities with DDR3 so-DIMM modules in laptops (or NUCs) - however - I have come across these countless times with full size DDR2 and DDR3 DIMM modules - every time I buy RAM for a desktop system, I half expect failure or error beep codes (and don’t get me started on 72 pin or 30 pin modules! compatibility NIGHTMARE!).
– also –
Netflix works without any issues (out of the box) for me in Google Chrome on Ubuntu 20.04 (AMD Ryzen 7 desktop system) - watched first two episodes of Rick and Morty season 5 the other night!

1 Like

Thanks all. I installed the 64bit Ubuntu 20.04.02 Gnome. So now Netflix and other streaming all work very well. The only downside, maybe inevitably, is that the reboot now takes far longer, i suppose because ive upgraded from 16 to 18 to 20, and from 32bit to 64bit on a machine that probably can only just cope. Anyway thanks all, maybe i shall experiment with lighter Linux 64bit versions next.

1 Like